summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nostromo_n50/ChangeLog8
-rw-r--r--x11-drivers/nostromo_n50/Manifest5
-rw-r--r--x11-drivers/nostromo_n50/files/60-nostromo.rules12
-rw-r--r--x11-drivers/nostromo_n50/metadata.xml5
-rw-r--r--x11-drivers/nostromo_n50/nostromo_n50-1.3.ebuild31
5 files changed, 61 insertions, 0 deletions
diff --git a/x11-drivers/nostromo_n50/ChangeLog b/x11-drivers/nostromo_n50/ChangeLog
new file mode 100644
index 000000000..44ad423af
--- /dev/null
+++ b/x11-drivers/nostromo_n50/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for x11-drivers/nostromo_n50
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 02 Mar 2008; Dwayne Asbury (kisak) <kisak42@gmail.com>
+ +files/60-nostromo.rules, +nostromo_n50-1.3.ebuild, +metadata.xml:
+ New ebuild from bug 211562. Thanks to Thomas, Allen, and James
+
diff --git a/x11-drivers/nostromo_n50/Manifest b/x11-drivers/nostromo_n50/Manifest
new file mode 100644
index 000000000..17f95430b
--- /dev/null
+++ b/x11-drivers/nostromo_n50/Manifest
@@ -0,0 +1,5 @@
+AUX 60-nostromo.rules 415 RMD160 4b83951344c4b34461ac44c09a429a82677554a1 SHA1 e7f1393f90739c989c261a2334591cf3fe8d4dfd SHA256 96558381f952c7a38bcf8d983c84eb8851fcfd3c6818d0b7d6d363027eb7b4a1
+DIST nostromo_n50-1.3.tar.gz 149289 RMD160 d92bd82209c2242e35c53ae0a342227943d82506 SHA1 c628fd91916f395d679f02bf03464d8365fe8b2d SHA256 3d9ec4195baaa873098877e76ccf972c1f984db65339015dbeae367b69d3fe61
+EBUILD nostromo_n50-1.3.ebuild 840 RMD160 c8d1474565b8d24d04a3fe44598681361b42cbb5 SHA1 e587cd44606d1e3ac923f32dbab9d6fe1c8440b7 SHA256 2348a47c80e02b4f27f49cfcae4512283c2a4ecda2c8bbe8a6ee44cc77fa45ee
+MISC ChangeLog 317 RMD160 fca4b425674d2754796f72df29c4f1a15d5785cb SHA1 fcf46dd2424e1343254524a7920e581ad914c167 SHA256 8e5d6a0d71dc17f12c347a617bda5316ddc2687ca2b8e249014047599f3040f3
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/x11-drivers/nostromo_n50/files/60-nostromo.rules b/x11-drivers/nostromo_n50/files/60-nostromo.rules
new file mode 100644
index 000000000..8e91ba1af
--- /dev/null
+++ b/x11-drivers/nostromo_n50/files/60-nostromo.rules
@@ -0,0 +1,12 @@
+# /etc/udev/rules.d/10-nostromo.rules: nostromo_n50 udev rule
+#
+# This file was created by nostromo_n50 to give proper permissions for nostromo_daemon.
+#
+#
+
+# nostromo n50
+KERNEL=="event*", SUBSYSTEMS=="usb", ATTRS{idVendor}=="050d", ATTRS{idProduct}=="0805", MODE="0660", GROUP="usb"
+
+# nostromo n52
+KERNEL=="event*", SUBSYSTEMS=="usb", ATTRS{idVendor}=="050d", ATTRS{idProduct}=="0815", MODE="0660", GROUP="usb"
+
diff --git a/x11-drivers/nostromo_n50/metadata.xml b/x11-drivers/nostromo_n50/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/x11-drivers/nostromo_n50/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/x11-drivers/nostromo_n50/nostromo_n50-1.3.ebuild b/x11-drivers/nostromo_n50/nostromo_n50-1.3.ebuild
new file mode 100644
index 000000000..1eb8ebb1f
--- /dev/null
+++ b/x11-drivers/nostromo_n50/nostromo_n50-1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils linux-info
+
+DESCRIPTION="Configuration GUI for Belkin Nostromo n50/n52 speedpads."
+HOMEPAGE="http://sf.net/projects/nostromodriver"
+SRC_URI="mirror://sourceforge/nostromodriver/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="x11-libs/libXft
+ x11-libs/libXtst
+ dev-libs/libxml2
+ x11-libs/gtk+"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-libs/fltk
+ x11-proto/xextproto"
+CONFIG_CHECK="INPUT_EVDEV"
+
+src_install() {
+ einstall || die "einstall failed"
+ insinto /etc/udev/rules.d
+ doins "${FILESDIR}/60-nostromo.rules"
+
+ make_desktop_entry nostromo_config "Nostromo Configuration" n50_tray.png "System"
+ make_desktop_entry nostromo_daemon "Nostromo Daemon" n50_tray.png "System"
+}