summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/hippo-canvas/hippo-canvas-0.2.23.ebuild')
-rw-r--r--x11-libs/hippo-canvas/hippo-canvas-0.2.23.ebuild36
1 files changed, 16 insertions, 20 deletions
diff --git a/x11-libs/hippo-canvas/hippo-canvas-0.2.23.ebuild b/x11-libs/hippo-canvas/hippo-canvas-0.2.23.ebuild
index c31ce0a7c..82ac71ff5 100644
--- a/x11-libs/hippo-canvas/hippo-canvas-0.2.23.ebuild
+++ b/x11-libs/hippo-canvas/hippo-canvas-0.2.23.ebuild
@@ -2,10 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-
-inherit autotools gnome.org eutils
+inherit autotools gnome2 eutils
DESCRIPTION="A canvas library based on GTK+-2, Cairo, and Pango"
HOMEPAGE="http://developer.mugshot.org/wiki/Hippo_Canvas"
@@ -13,16 +10,22 @@ HOMEPAGE="http://developer.mugshot.org/wiki/Hippo_Canvas"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc python"
+
+# Removed USE=doc for now since configure.ac needs fixing
+# otherwise eautoreconf fails
+IUSE="python" # doc
RDEPEND=">=dev-libs/glib-2.6
- >=x11-libs/gtk+-2.6
- python? ( dev-lang/python
- dev-python/pycairo
- dev-python/pygtk )"
+ >=x11-libs/gtk+-2.6
+ python? ( dev-lang/python
+ dev-python/pycairo
+ dev-python/pygtk )"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
- doc? ( >=dev-util/gtk-doc-1.6 )"
+ dev-util/pkgconfig
+ >=dev-util/gtk-doc-1.6"
+ # doc? ( >=dev-util/gtk-doc-1.6 )"
+
+DOCS="AUTHORS README TODO"
src_unpack() {
unpack ${A}
@@ -31,13 +34,6 @@ src_unpack() {
eautoreconf
}
-src_compile() {
- econf $(use_enable doc gtk-doc) $(use_enable python) ||
- die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS README TODO || die "dodoc failed"
+pkg_setup() {
+ G2CONF="$(use_enable python)"
}