summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libdrm_nouveau/libdrm_nouveau-2.4.9.ebuild')
-rw-r--r--x11-libs/libdrm_nouveau/libdrm_nouveau-2.4.9.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-libs/libdrm_nouveau/libdrm_nouveau-2.4.9.ebuild b/x11-libs/libdrm_nouveau/libdrm_nouveau-2.4.9.ebuild
new file mode 100644
index 000000000..c94892a85
--- /dev/null
+++ b/x11-libs/libdrm_nouveau/libdrm_nouveau-2.4.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libdrm/libdrm-2.4.4.ebuild,v 1.2 2009/02/05 13:33:40 remi Exp $
+
+EAPI="2"
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DRM_P="${P/_nouveau/}"
+
+DESCRIPTION="X.Org libdrm nouveau library"
+HOMEPAGE="http://dri.freedesktop.org/"
+SRC_URI="http://dri.freedesktop.org/libdrm/${DRM_P}.tar.gz"
+
+LICENSE="libdrm"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test" # see bug #236845
+
+RDEPEND="dev-libs/libpthread-stubs
+ !x11-libs/libdrm[video_cards_nouveau]
+ ~x11-libs/libdrm-${PV}"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${DRM_P}"
+PATCHES=(
+ "${FILESDIR}"/${PV}-0001-nouveau-store-bo-handle-in-public-struct-in-bo_ref_.patch
+ "${FILESDIR}"/${PV}-0002-nouveau-write-posting-got-lost-somewhere-bring-it.patch
+ "${FILESDIR}"/${PV}-0003-libdrm-mode-align-subpixel-results.patch
+ "${FILESDIR}"/${PV}-0004-intel-NULL-fake-bo-block-when-freeing-in-evict_all.patch
+)
+CONFIGURE_OPTIONS="--enable-nouveau-experimental-api"
+
+# FIXME, we should try to see how we can fit the --enable-udev configure flag
+
+src_install() {
+ x-modular_src_install
+ # do not install files already installed by libdrm
+ find "${D}" \( -type f -o -type l \) \! -name "*nouveau*" -exec rm '{}' \;
+ rm "${D}"/usr/include/drm/nouveau_drm.h
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ ewarn "libdrm's ABI may have changed without change in library name"
+ ewarn "Please rebuild media-libs/mesa, x11-base/xorg-server and"
+ ewarn "your video drivers in x11-drivers/*."
+}