summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/gnome-schedule/gnome-schedule-2.1.1.ebuild')
-rw-r--r--x11-misc/gnome-schedule/gnome-schedule-2.1.1.ebuild26
1 files changed, 17 insertions, 9 deletions
diff --git a/x11-misc/gnome-schedule/gnome-schedule-2.1.1.ebuild b/x11-misc/gnome-schedule/gnome-schedule-2.1.1.ebuild
index e22444f08..63e69e3e8 100644
--- a/x11-misc/gnome-schedule/gnome-schedule-2.1.1.ebuild
+++ b/x11-misc/gnome-schedule/gnome-schedule-2.1.1.ebuild
@@ -1,31 +1,39 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit gnome2
+EAPI="3"
-DESCRIPTION="Gnome-schedule is a GUI to aid users configuring the crontab and at daemons."
+PYTHON_DEPEND="2"
+
+inherit python gnome2
+
+DESCRIPTION="GUI to aid users configuring the crontab and at daemons"
HOMEPAGE="http://gnome-schedule.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND=">=x11-libs/gtk+-2.6
- >=gnome-base/gconf-2
- >=dev-libs/glib-2.6
- >=dev-lang/python-2.3
+RDEPEND="
+ x11-libs/gtk+:2
+ gnome-base/gconf:2
+ dev-libs/glib:2
>=dev-python/pygtk-2.6
virtual/cron
sys-process/at
>=dev-python/gnome-python-2.12.0
>=app-text/gnome-doc-utils-0.3.2
app-text/rarian"
-
DEPEND="${RDEPEND}
sys-devel/gettext
>=dev-util/pkgconfig-0.9
>=dev-util/intltool-0.28"
DOCS="AUTHORS NEWS README TODO"
+
+pkg_setup () {
+ python_set_active_version 2
+}