summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xorg-edit/xorg-edit-07.06.15.ebuild')
-rw-r--r--x11-misc/xorg-edit/xorg-edit-07.06.15.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/xorg-edit/xorg-edit-07.06.15.ebuild b/x11-misc/xorg-edit/xorg-edit-07.06.15.ebuild
new file mode 100644
index 000000000..34461693e
--- /dev/null
+++ b/x11-misc/xorg-edit/xorg-edit-07.06.15.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="GUI to edit XServer-file xorg.conf easily"
+HOMEPAGE="http://www.deesaster.org/progxorg.php"
+SRC_URI="mirror://sourceforge/xorg-edit/${PN}_${PV}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/wxGTK-2.6
+ x11-base/xorg-server"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ emake CXX=$(tc-getCXX) || die "emake failed"
+}
+
+src_install() {
+ dobin xorg-edit
+ dodoc CHANGELOG README
+}