summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/mandriva-galaxy/mandriva-galaxy-1.0.4.ebuild')
-rw-r--r--x11-themes/mandriva-galaxy/mandriva-galaxy-1.0.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/mandriva-galaxy/mandriva-galaxy-1.0.4.ebuild b/x11-themes/mandriva-galaxy/mandriva-galaxy-1.0.4.ebuild
new file mode 100644
index 000000000..455468a89
--- /dev/null
+++ b/x11-themes/mandriva-galaxy/mandriva-galaxy-1.0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+inherit eutils rpm kde-functions autotools
+
+MDV_EXTRAVERSION="3mdv2007.0"
+
+DESCRIPTION="Mandriva's Galaxy theme for GTK2, Metacity and KDE"
+HOMEPAGE="http://www.mandriva.com/"
+SRC_URI="ftp://ftp.free.fr/pub/Distributions_Linux/MandrivaLinux/official/2007.0/SRPMS/main/release/galaxy-${PV}-${MDV_EXTRAVERSION}.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kde"
+
+DEPEND=">=x11-libs/gtk+-2.0
+ kde? ( || ( kde-base/kwin:3.5 kde-base/kdebase:3.5 ) )"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/galaxy-${PV}
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/remove-gtk1.patch
+ use kde || epatch "${FILESDIR}"/remove-kde.patch
+ eautoreconf
+}
+
+src_compile() {
+ set-kdedir 3.5
+ econf
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS README ChangeLog || die "dodoc failed"
+}