summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/pinux-tux-xcursors/ChangeLog8
-rw-r--r--x11-themes/pinux-tux-xcursors/Manifest4
-rw-r--r--x11-themes/pinux-tux-xcursors/metadata.xml5
-rw-r--r--x11-themes/pinux-tux-xcursors/pinux-tux-xcursors-0.3.ebuild61
4 files changed, 78 insertions, 0 deletions
diff --git a/x11-themes/pinux-tux-xcursors/ChangeLog b/x11-themes/pinux-tux-xcursors/ChangeLog
new file mode 100644
index 000000000..1c9f2206a
--- /dev/null
+++ b/x11-themes/pinux-tux-xcursors/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for x11-themes/pinux-tux-xcursors
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 30 May 2008; Thomas Fischer (Sparki) <fischer@unix-ag.uni-kl.de>
+ +metadata.xml, +pinux-tux-xcursors-0.3.ebuild:
+ New Ebuild for bug 102203
+
diff --git a/x11-themes/pinux-tux-xcursors/Manifest b/x11-themes/pinux-tux-xcursors/Manifest
new file mode 100644
index 000000000..02e38f658
--- /dev/null
+++ b/x11-themes/pinux-tux-xcursors/Manifest
@@ -0,0 +1,4 @@
+DIST 19506-pinux's-tux-cursors-theme-0.3-cur.tar.bz2 160661 RMD160 c7a1ba788c5e81a9218258bbd184571e7e5da76f SHA1 2b8c280d12e4681fabbbfdd2dfc018d8f97bd8c1 SHA256 4c56b4b6bd562f3b0defd507145de00f91da3bb41e2a5c9b4000dc24289d8495
+EBUILD pinux-tux-xcursors-0.3.ebuild 1940 RMD160 3367c844e6856efd34f301746ae9a74e83180cf4 SHA1 09bce8c2997c9c4291184d04026a79e36d2fe980 SHA256 b685105a1e33c84ec0f68068203dc10ca828e7bf0d44a45ad6006749cba02d8e
+MISC ChangeLog 275 RMD160 4e2569d5c610b361e93ef4d28fa67e20af8dfa84 SHA1 3fefb90b28b0720eda9534e78d1f2c00b11b3fd6 SHA256 432c796a641635cfbb8f796870ed81c8025a86f31fcbd3007a09c546a99aaa37
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/x11-themes/pinux-tux-xcursors/metadata.xml b/x11-themes/pinux-tux-xcursors/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/x11-themes/pinux-tux-xcursors/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/x11-themes/pinux-tux-xcursors/pinux-tux-xcursors-0.3.ebuild b/x11-themes/pinux-tux-xcursors/pinux-tux-xcursors-0.3.ebuild
new file mode 100644
index 000000000..e63140037
--- /dev/null
+++ b/x11-themes/pinux-tux-xcursors/pinux-tux-xcursors-0.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Pinux's Tux Cursors Theme"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=19506"
+SRC_URI="http://www.kde-look.org/CONTENT/content-files/19506-pinux's-tux-cursors-theme-${PV}-cur.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="${RDEPEND}"
+RDEPEND=""
+
+# cursor themes to be installed
+THEMES="pCircle-24 pCircle-32 pDebian-24 pDebian-32 pGentoo-24 \
+ pGentoo-32 pSlackware-24 pSlackware-32 pSuse-24 pSuse-32 pTux-24 pTux-32 \
+ pUbuntu-24 pUbuntu-32"
+
+# are there other implementations?
+X11_IMPLEM="xorg-x11"
+
+src_install() {
+ for cursortheme in ${THEMES} ; do
+ dodir "/usr/share/cursors/${X11_IMPLEM}/${cursortheme}/"
+ for cursorfile in index.theme cursors ; do
+ cp -dr "${WORKDIR}/cursors/${cursortheme}/${cursorfile}" \
+ "${D}usr/share/cursors/${X11_IMPLEM}/${cursortheme}/" || die
+ done
+ done
+ dodoc "${WORKDIR}/README" "${WORKDIR}/COPYRIGHT"
+}
+
+pkg_postinst() {
+ einfo "The following cursor themes have been installed:"
+ for cursortheme in ${THEMES} ; do
+ einfo " ${cursortheme}"
+ done
+ einfo ""
+ einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
+ einfo "and add the following line:"
+ einfo "Xcursor.theme: pTux24"
+ einfo "Alternatively, use KDE's control center to switch to this set"
+ einfo "of cursors."
+ einfo ""
+ einfo "Also, to globally use this set of mouse cursors edit the file:"
+ einfo " /usr/local/share/cursors/${X11_IMPLEM}/default/index.theme"
+ einfo "and change the line:"
+ einfo " Inherits=[current setting]"
+ einfo "to"
+ einfo " Inherits=pTux24"
+ einfo ""
+ einfo "Note this will be overruled by a user's ~/.Xdefaults file."
+ einfo ""
+ ewarn "If you experience flickering, try setting the following line in"
+ ewarn ""
+ ewarn "the Device section of your xorg.conf file:"
+ ewarn " Option \"HWCursor\" \"false\""
+}