summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2011-07-16 20:15:05 +0200
committerRaúl Porcel <armin76@gentoo.org>2011-07-16 20:15:05 +0200
commita9a18390361663790d43ddf24545ca0b8f2ac7a4 (patch)
treedfa333f7fc04d22ac6a82f30864c9bb4f00ab04a
downloadtegra-a9a18390361663790d43ddf24545ca0b8f2ac7a4.tar.gz
tegra-a9a18390361663790d43ddf24545ca0b8f2ac7a4.tar.bz2
tegra-a9a18390361663790d43ddf24545ca0b8f2ac7a4.zip
Initial commit
-rw-r--r--profiles/repo_name1
-rw-r--r--sys-libs/tegra-libs/Manifest2
-rw-r--r--sys-libs/tegra-libs/tegra-libs-12_alpha1.ebuild38
-rw-r--r--x11-drivers/tegra-drivers/Manifest2
-rw-r--r--x11-drivers/tegra-drivers/tegra-drivers-12_alpha1.ebuild33
5 files changed, 76 insertions, 0 deletions
diff --git a/profiles/repo_name b/profiles/repo_name
new file mode 100644
index 0000000..91e829d
--- /dev/null
+++ b/profiles/repo_name
@@ -0,0 +1 @@
+tegra
diff --git a/sys-libs/tegra-libs/Manifest b/sys-libs/tegra-libs/Manifest
new file mode 100644
index 0000000..13a4db7
--- /dev/null
+++ b/sys-libs/tegra-libs/Manifest
@@ -0,0 +1,2 @@
+DIST tegra-linux-12.alpha.1.0.tar.gz 10811623 RMD160 545071ba32c450799325ae53253c52cc7421e5bd SHA1 38129d47d96eb10a8d69102ce5dcabdeaeb00da3 SHA256 77ee67f8e8aa56d94104ac9a744dbcdd1f030a5d8efc02cdf71afcb60f88dbd7
+EBUILD tegra-libs-12_alpha1.ebuild 731 RMD160 e2b2b55dbd050ec69f76ff1ee112bb413e66a19f SHA1 c21383eaa3e68e8d804ede6219925998f620a2d9 SHA256 e200e9e2c1d48d03121699071410920fd1f382837e30dd553d8175b36e4d1c99
diff --git a/sys-libs/tegra-libs/tegra-libs-12_alpha1.ebuild b/sys-libs/tegra-libs/tegra-libs-12_alpha1.ebuild
new file mode 100644
index 0000000..fce7b5a
--- /dev/null
+++ b/sys-libs/tegra-libs/tegra-libs-12_alpha1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="NVIDIA Tegra2 libraries"
+
+HOMEPAGE="http://developer.nvidia.com/content/linux-tegra-release-12-alpha-1-released"
+SRC_URI="http://developer.download.nvidia.com/assets/mobile/files/tegra-linux-12.alpha.1.0.tar.gz"
+
+
+LICENSE="nvidia"
+SLOT="0"
+KEYWORDS="arm"
+
+IUSE=""
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+RESTRICT="strip mirror"
+
+src_unpack() {
+ unpack ${A}
+ cd ldk/nv_tegra
+ unpack ./tegra_bins.tar.gz
+}
+
+src_install() {
+ cd ldk/nv_tegra
+ # We have x11-drivers/tegra-drivers for this
+ rm -rf usr/lib/xorg/
+
+ # These collide with mesa :(
+ rm usr/lib/libEGL.so
+
+ insinto /
+ doins -r usr lib
+}
diff --git a/x11-drivers/tegra-drivers/Manifest b/x11-drivers/tegra-drivers/Manifest
new file mode 100644
index 0000000..90570f9
--- /dev/null
+++ b/x11-drivers/tegra-drivers/Manifest
@@ -0,0 +1,2 @@
+DIST tegra-linux-12.alpha.1.0.tar.gz 10811623 RMD160 545071ba32c450799325ae53253c52cc7421e5bd SHA1 38129d47d96eb10a8d69102ce5dcabdeaeb00da3 SHA256 77ee67f8e8aa56d94104ac9a744dbcdd1f030a5d8efc02cdf71afcb60f88dbd7
+EBUILD tegra-drivers-12_alpha1.ebuild 670 RMD160 52ed881f94b30ea9306e855574497a921a473665 SHA1 bf547c00035e043bf3d0ee5be7c77632acd55852 SHA256 bd7b8cf733eba00c62f7f635e346af93283b6d657fa311a4d055dba94363f583
diff --git a/x11-drivers/tegra-drivers/tegra-drivers-12_alpha1.ebuild b/x11-drivers/tegra-drivers/tegra-drivers-12_alpha1.ebuild
new file mode 100644
index 0000000..4a445db
--- /dev/null
+++ b/x11-drivers/tegra-drivers/tegra-drivers-12_alpha1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="NVIDIA Tegra2 X.org driver"
+
+HOMEPAGE="http://developer.nvidia.com/content/linux-tegra-release-12-alpha-1-released"
+SRC_URI="http://developer.download.nvidia.com/assets/mobile/files/tegra-linux-12.alpha.1.0.tar.gz"
+
+
+LICENSE="nvidia"
+SLOT="0"
+KEYWORDS="arm"
+
+IUSE=""
+DEPEND="=x11-base/xorg-server-1.10*
+ =sys-libs/tegra-libs-${PV}"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+RESTRICT="strip mirror"
+
+src_unpack() {
+ unpack ${A}
+ cd ldk/nv_tegra
+ unpack ./tegra-drivers-abi10.tbz2
+}
+
+src_install() {
+ cd ldk/nv_tegra
+ insinto /
+ doins -r usr
+}