summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-02-11 11:16:48 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-02-11 11:30:34 +0100
commit90016a8aba0de9114f1b1b5834a99eeeacabb508 (patch)
tree5b712a743cad9e5bcb03eb935791fa20a6c4db56
parentdiff-tex: use "pquery --one-attr path" (diff)
downloadtex-90016a8aba0de9114f1b1b5834a99eeeacabb508.tar.gz
tex-90016a8aba0de9114f1b1b5834a99eeeacabb508.tar.bz2
tex-90016a8aba0de9114f1b1b5834a99eeeacabb508.zip
populate-distdir: improve, download doc and source too
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rwxr-xr-xpopulate-distdir8
1 files changed, 6 insertions, 2 deletions
diff --git a/populate-distdir b/populate-distdir
index 75e4042..7f805f5 100755
--- a/populate-distdir
+++ b/populate-distdir
@@ -3,14 +3,18 @@ set -euo pipefail
SCRIPT_DIR=$(cd -- "$( dirname -- "${BASH_SOURCE[0]}" )" &> /dev/null && pwd)
-: ${TEX_OVERLAY_PATH:=$(portageq get_repo_path / tex-overlay)
-: ${DISTDIR:="${SCRIPT_DIR}/distdir"}
+: "${TEX_OVERLAY_PATH:=$(portageq get_repo_path / tex-overlay)}"
+: "${DISTDIR:=$(portageq distdir)}"
if [[ ! -d "${DISTDIR}" ]]; then
mkdir "${DISTDIR}"
+ # https://bford.info/cachedir/
+ echo "Signature: 8a477f597d28d172789f06886806bc55" > "${DISTDIR}/CACHEDIR.TAG"
fi
export DISTDIR
+export USE="doc source"
+
find "${TEX_OVERLAY_PATH}" -type f -name '*.ebuild' -print0 |\
xargs --null -I {} ebuild {} manifest fetch