summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-12-29 11:34:26 +0100
committerFlorian Schmaus <flow@gentoo.org>2023-12-29 11:34:26 +0100
commitfd54e74f1014536a986f02044ab19705db1af0c9 (patch)
treef92268a28fed4b9b57d0d61bc53b0be1cf59f023
parentInitial commit (diff)
downloadtex-fd54e74f1014536a986f02044ab19705db1af0c9.tar.gz
tex-fd54e74f1014536a986f02044ab19705db1af0c9.tar.bz2
tex-fd54e74f1014536a986f02044ab19705db1af0c9.zip
add diff-tex script
Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rwxr-xr-xdiff-tex21
1 files changed, 21 insertions, 0 deletions
diff --git a/diff-tex b/diff-tex
new file mode 100755
index 0000000..560d93b
--- /dev/null
+++ b/diff-tex
@@ -0,0 +1,21 @@
+#!/usr/bin/env bash
+set -eu
+
+GENTOO_REPO_DIR=$(portageq get_repo_path / gentoo)
+TEX_REPO_DIR=$(portageq get_repo_path / tex-overlay)
+
+case "${1}" in
+ core)
+ diff -u \
+ "${GENTOO_REPO_DIR}/app-text/texlive-core/texlive-core-2021-r7.ebuild" \
+ "${TEX_REPO_DIR}/app-text/texlive-core/texlive-core-2023.ebuild"
+ ;;
+ eclass)
+ diff -u \
+ "${GENTOO_REPO_DIR}/eclass/texlive-common.eclass" \
+ "${TEX_REPO_DIR}/eclass/texlive-common.eclass"
+ diff -u \
+ "${GENTOO_REPO_DIR}/eclass/texlive-module.eclass" \
+ "${TEX_REPO_DIR}/eclass/texlive-module.eclass"
+ ;;
+esac