summaryrefslogtreecommitdiff
path: root/9999
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2022-10-08 20:14:29 +0800
committerWANG Xuerui <xen0n@gentoo.org>2022-10-08 20:14:29 +0800
commit0420678a87bef8c743a278e5a7a2d60a23e513cf (patch)
tree86e21e3d0ec25e9777bfc6fda20e6e293f4071da /9999
parentUpdate patches for binutils 2.39 (diff)
downloadbinutils-patches-0420678a87bef8c743a278e5a7a2d60a23e513cf.tar.gz
binutils-patches-0420678a87bef8c743a278e5a7a2d60a23e513cf.tar.bz2
binutils-patches-0420678a87bef8c743a278e5a7a2d60a23e513cf.zip
Rebase on top of upstream commit 4cbfd0daabd6851
Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Diffstat (limited to '9999')
-rw-r--r--9999/0001-Gentoo-gold-ld-add-support-for-poisoned-system-direc.patch42
-rw-r--r--9999/0002-Gentoo-libiberty-install-PIC-version-of-libiberty.a.patch4
-rw-r--r--9999/0003-Gentoo-add-with-extra-soversion-suffix-option.patch26
-rw-r--r--9999/0004-Gentoo-Pass-hash-style-sysv-to-ld-in-the-testsuite.patch4
-rw-r--r--9999/0005-Gentoo-Give-also-libctf-optionally-a-gentoo-specific.patch46
-rw-r--r--9999/0006-Gentoo-XFAIL-15-broken-ld.gold-tests.patch10
6 files changed, 66 insertions, 66 deletions
diff --git a/9999/0001-Gentoo-gold-ld-add-support-for-poisoned-system-direc.patch b/9999/0001-Gentoo-gold-ld-add-support-for-poisoned-system-direc.patch
index 8e2e947..1a03757 100644
--- a/9999/0001-Gentoo-gold-ld-add-support-for-poisoned-system-direc.patch
+++ b/9999/0001-Gentoo-gold-ld-add-support-for-poisoned-system-direc.patch
@@ -1,4 +1,4 @@
-From 6ad35e463cbd086b4d4e7bb5aca1da6b73e614c8 Mon Sep 17 00:00:00 2001
+From eaf58344eafc9b9943a0bd7e9e00130965b10274 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Tue, 20 Jul 2021 21:08:31 +0200
Subject: [PATCH 1/6] Gentoo: gold/ld: add support for poisoned system
@@ -88,10 +88,10 @@ index 04be98a3e39..64439f8af7a 100644
if (this->shared() && this->is_static())
gold_fatal(_("-shared and -static are incompatible"));
diff --git a/gold/options.h b/gold/options.h
-index 9509a445e8e..a3d76b294cd 100644
+index 17236eb9cb9..dad649870bf 100644
--- a/gold/options.h
+++ b/gold/options.h
-@@ -1394,6 +1394,13 @@ class General_options
+@@ -1398,6 +1398,13 @@ class General_options
DEFINE_bool(warn_multiple_gp, options::TWO_DASHES, '\0', false,
N_("Ignored"), NULL);
@@ -106,7 +106,7 @@ index 9509a445e8e..a3d76b294cd 100644
N_("Warn when skipping an incompatible library"),
N_("Don't warn when skipping an incompatible library"));
diff --git a/ld/config.in b/ld/config.in
-index 0ccd79d59cd..5e39814bce0 100644
+index 3916740eee4..7e70b0179ea 100644
--- a/ld/config.in
+++ b/ld/config.in
@@ -55,6 +55,9 @@
@@ -120,10 +120,10 @@ index 0ccd79d59cd..5e39814bce0 100644
#undef EXTRA_SHLIB_EXTENSION
diff --git a/ld/configure b/ld/configure
-index 1c2b64870b1..46b5789c77e 100755
+index 9dd3ed5f1e7..a9a67a8babe 100755
--- a/ld/configure
+++ b/ld/configure
-@@ -836,6 +836,7 @@ with_lib_path
+@@ -838,6 +838,7 @@ with_lib_path
enable_targets
enable_64_bit_bfd
with_sysroot
@@ -131,7 +131,7 @@ index 1c2b64870b1..46b5789c77e 100755
enable_gold
enable_got
enable_compressed_debug_sections
-@@ -1514,6 +1515,8 @@ Optional Features:
+@@ -1519,6 +1520,8 @@ Optional Features:
--enable-checking enable run-time checks
--enable-targets alternative target configurations
--enable-64-bit-bfd 64-bit support (on hosts with narrower word sizes)
@@ -140,25 +140,25 @@ index 1c2b64870b1..46b5789c77e 100755
--enable-gold[=ARG] build gold [ARG={default,yes,no}]
--enable-got=<type> GOT handling scheme (target, single, negative,
multigot)
-@@ -11491,7 +11494,7 @@ else
+@@ -11620,7 +11623,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 11494 "configure"
-+#line 11497 "configure"
+-#line 11623 "configure"
++#line 11626 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -11597,7 +11600,7 @@ else
+@@ -11726,7 +11729,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 11600 "configure"
-+#line 11603 "configure"
+-#line 11729 "configure"
++#line 11732 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -15349,6 +15352,19 @@ fi
+@@ -15478,6 +15481,19 @@ fi
@@ -179,10 +179,10 @@ index 1c2b64870b1..46b5789c77e 100755
if test "${enable_gold+set}" = set; then :
enableval=$enable_gold; case "${enableval}" in
diff --git a/ld/configure.ac b/ld/configure.ac
-index eb55904c090..0844c2364c5 100644
+index f1b2f9897f8..1927d79e728 100644
--- a/ld/configure.ac
+++ b/ld/configure.ac
-@@ -102,6 +102,16 @@ AC_SUBST(use_sysroot)
+@@ -103,6 +103,16 @@ AC_SUBST(use_sysroot)
AC_SUBST(TARGET_SYSTEM_ROOT)
AC_SUBST(TARGET_SYSTEM_ROOT_DEFINE)
@@ -218,10 +218,10 @@ index f3086bf30de..90cf1ca51e5 100644
enum endian_enum endian;
diff --git a/ld/ld.texi b/ld/ld.texi
-index eabbec8faa9..45f4858526c 100644
+index 9daed2e7e9f..d76b534a456 100644
--- a/ld/ld.texi
+++ b/ld/ld.texi
-@@ -2947,6 +2947,24 @@ creation of the metadata note, if one had been enabled by an earlier
+@@ -2952,6 +2952,24 @@ creation of the metadata note, if one had been enabled by an earlier
occurrence of the --package-metdata option.
If the linker has been built with libjansson, then the JSON string
will be validated.
@@ -292,7 +292,7 @@ index 57ade1f754b..b35a6122e09 100644
OPTION_POP_STATE,
OPTION_DISABLE_MULTIPLE_DEFS_ABS,
diff --git a/ld/ldmain.c b/ld/ldmain.c
-index ea72b14a301..706ec9ce26e 100644
+index d63002c994a..55364ef5773 100644
--- a/ld/ldmain.c
+++ b/ld/ldmain.c
@@ -321,6 +321,13 @@ main (int argc, char **argv)
@@ -310,7 +310,7 @@ index ea72b14a301..706ec9ce26e 100644
/* We initialize DEMANGLING based on the environment variable
COLLECT_NO_DEMANGLE. The gcc collect2 program will demangle the
diff --git a/ld/lexsup.c b/ld/lexsup.c
-index 9225f71b3ce..db5b170bc7c 100644
+index 299371fb775..02816ebb1b6 100644
--- a/ld/lexsup.c
+++ b/ld/lexsup.c
@@ -579,6 +579,18 @@ static const struct ld_option ld_options[] =
@@ -352,5 +352,5 @@ index 9225f71b3ce..db5b170bc7c 100644
input_flags.pushed = xmemdup (&input_flags,
sizeof (input_flags),
--
-2.35.1
+2.38.0
diff --git a/9999/0002-Gentoo-libiberty-install-PIC-version-of-libiberty.a.patch b/9999/0002-Gentoo-libiberty-install-PIC-version-of-libiberty.a.patch
index 34462cc..9a5590e 100644
--- a/9999/0002-Gentoo-libiberty-install-PIC-version-of-libiberty.a.patch
+++ b/9999/0002-Gentoo-libiberty-install-PIC-version-of-libiberty.a.patch
@@ -1,4 +1,4 @@
-From 4bd606f5945ea94b1ea0db8fba206cfe67959cde Mon Sep 17 00:00:00 2001
+From 14210956fa30806c5316ede3db67cac94420bb96 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Fri, 7 Jan 2005 00:15:53 -0500
Subject: [PATCH 2/6] Gentoo: libiberty: install PIC version of libiberty.a
@@ -30,5 +30,5 @@ index abef3c4601b..9dfb6b6d2b0 100644
else true; fi; \
if [ x"$(NOASANFLAG)" != x ]; then \
--
-2.35.1
+2.38.0
diff --git a/9999/0003-Gentoo-add-with-extra-soversion-suffix-option.patch b/9999/0003-Gentoo-add-with-extra-soversion-suffix-option.patch
index 9328241..81265e4 100644
--- a/9999/0003-Gentoo-add-with-extra-soversion-suffix-option.patch
+++ b/9999/0003-Gentoo-add-with-extra-soversion-suffix-option.patch
@@ -1,4 +1,4 @@
-From 2d3d27e6c5ad343a524a117dc02358ad7cb06e0d Mon Sep 17 00:00:00 2001
+From 96aa5434285fe8006fd671634fe753cf69451043 Mon Sep 17 00:00:00 2001
From: Sergei Trofimovich <slyfox@gentoo.org>
Date: Tue, 20 Jul 2021 21:12:38 +0200
Subject: [PATCH 3/6] Gentoo: add --with-extra-soversion-suffix= option
@@ -34,7 +34,7 @@ Ported to binutils 2.37 by Andreas K. Hüttel <dilfridge@gentoo.org>
4 files changed, 29 insertions(+)
diff --git a/bfd/Makefile.am b/bfd/Makefile.am
-index 670e0598f55..18d6eef60bb 100644
+index 794d992310d..34b71212d75 100644
--- a/bfd/Makefile.am
+++ b/bfd/Makefile.am
@@ -64,6 +64,8 @@ bfdinclude_HEADERS += $(INCDIR)/plugin-api.h
@@ -46,7 +46,7 @@ index 670e0598f55..18d6eef60bb 100644
# bfd.h goes here, for now
BFD_H = bfd.h
-@@ -983,6 +985,9 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/development.sh $(srcdir)/Makefile.in
+@@ -992,6 +994,9 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/development.sh $(srcdir)/Makefile.in
bfd_version_string="\"$(VERSION).$${bfd_version_date}\"" ;\
bfd_soversion="$(VERSION).$${bfd_version_date}" ;\
fi ;\
@@ -57,10 +57,10 @@ index 670e0598f55..18d6eef60bb 100644
-e "s,@bfd_version_string@,$$bfd_version_string," \
-e "s,@bfd_version_package@,$$bfd_version_package," \
diff --git a/bfd/Makefile.in b/bfd/Makefile.in
-index d3ef4c2524b..56fac1bb94d 100644
+index bdf12c99cfd..e4c613d7406 100644
--- a/bfd/Makefile.in
+++ b/bfd/Makefile.in
-@@ -354,6 +354,7 @@ ECHO_T = @ECHO_T@
+@@ -355,6 +355,7 @@ ECHO_T = @ECHO_T@
EGREP = @EGREP@
EXEEXT = @EXEEXT@
EXEEXT_FOR_BUILD = @EXEEXT_FOR_BUILD@
@@ -68,7 +68,7 @@ index d3ef4c2524b..56fac1bb94d 100644
FGREP = @FGREP@
GENCAT = @GENCAT@
GMSGFMT = @GMSGFMT@
-@@ -2453,6 +2454,9 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/development.sh $(srcdir)/Makefile.in
+@@ -2471,6 +2472,9 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/development.sh $(srcdir)/Makefile.in
bfd_version_string="\"$(VERSION).$${bfd_version_date}\"" ;\
bfd_soversion="$(VERSION).$${bfd_version_date}" ;\
fi ;\
@@ -79,10 +79,10 @@ index d3ef4c2524b..56fac1bb94d 100644
-e "s,@bfd_version_string@,$$bfd_version_string," \
-e "s,@bfd_version_package@,$$bfd_version_package," \
diff --git a/bfd/configure b/bfd/configure
-index 590986efb61..299f7bb0244 100755
+index b72e885f711..b464614592d 100755
--- a/bfd/configure
+++ b/bfd/configure
-@@ -691,6 +691,7 @@ WARN_CFLAGS
+@@ -695,6 +695,7 @@ WARN_CFLAGS
REPORT_BUGS_TEXI
REPORT_BUGS_TO
PKGVERSION
@@ -90,7 +90,7 @@ index 590986efb61..299f7bb0244 100755
DEBUGDIR
ENABLE_BFD_64_BIT_FALSE
ENABLE_BFD_64_BIT_TRUE
-@@ -832,6 +833,7 @@ enable_secureplt
+@@ -836,6 +837,7 @@ enable_secureplt
enable_separate_code
enable_leading_mingw64_underscores
with_separate_debug_dir
@@ -98,7 +98,7 @@ index 590986efb61..299f7bb0244 100755
with_pkgversion
with_bugurl
enable_werror
-@@ -1508,6 +1510,8 @@ Optional Packages:
+@@ -1518,6 +1520,8 @@ Optional Packages:
--with-separate-debug-dir=DIR
Look for global separate debug info in DIR
[[default=LIBDIR/debug]]
@@ -107,7 +107,7 @@ index 590986efb61..299f7bb0244 100755
--with-pkgversion=PKG Use PKG in the version string in place of "GNU
Binutils"
--with-bugurl=URL Direct users to URL to report a bug
-@@ -12014,6 +12018,15 @@ fi
+@@ -12033,6 +12037,15 @@ fi
@@ -124,7 +124,7 @@ index 590986efb61..299f7bb0244 100755
# Check whether --with-pkgversion was given.
diff --git a/bfd/configure.ac b/bfd/configure.ac
-index aad4f3c83a5..e9158315bf1 100644
+index 7a0ad0ffe33..2910cc9121f 100644
--- a/bfd/configure.ac
+++ b/bfd/configure.ac
@@ -168,6 +168,13 @@ AC_ARG_WITH(separate-debug-dir,
@@ -142,5 +142,5 @@ index aad4f3c83a5..e9158315bf1 100644
ACX_BUGURL([https://sourceware.org/bugzilla/])
--
-2.35.1
+2.38.0
diff --git a/9999/0004-Gentoo-Pass-hash-style-sysv-to-ld-in-the-testsuite.patch b/9999/0004-Gentoo-Pass-hash-style-sysv-to-ld-in-the-testsuite.patch
index caaf9c7..484c657 100644
--- a/9999/0004-Gentoo-Pass-hash-style-sysv-to-ld-in-the-testsuite.patch
+++ b/9999/0004-Gentoo-Pass-hash-style-sysv-to-ld-in-the-testsuite.patch
@@ -1,4 +1,4 @@
-From 19d0d0a3fca319b6a14888ce709a75d9b0765561 Mon Sep 17 00:00:00 2001
+From eeb95d2a0cda143dad4d905429ced8a339c486e3 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
Date: Tue, 20 Jul 2021 21:15:24 +0200
Subject: [PATCH 4/6] Gentoo: Pass --hash-style=sysv to ld in the testsuite
@@ -57,5 +57,5 @@ index ec27388a72e..fc7292a40a7 100644
# We don't care if we get a warning about a non-existent start
--
-2.35.1
+2.38.0
diff --git a/9999/0005-Gentoo-Give-also-libctf-optionally-a-gentoo-specific.patch b/9999/0005-Gentoo-Give-also-libctf-optionally-a-gentoo-specific.patch
index 4788ee0..2133994 100644
--- a/9999/0005-Gentoo-Give-also-libctf-optionally-a-gentoo-specific.patch
+++ b/9999/0005-Gentoo-Give-also-libctf-optionally-a-gentoo-specific.patch
@@ -1,4 +1,4 @@
-From ebc2d6f6c6d46a7fe77a37612ea0e12dccc467cf Mon Sep 17 00:00:00 2001
+From ee4de1adb09cbfcad39e544e2f05392b210b550a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
Date: Sat, 24 Jul 2021 15:20:16 +0200
Subject: [PATCH 5/6] Gentoo: Give also libctf optionally a gentoo-specific
@@ -45,10 +45,10 @@ index 27e90f0ba36..4990a20efa3 100644
libctf_nobfd_la_CPPFLAGS = $(AM_CPPFLAGS) -DNOBFD=1
libctf_nobfd_la_SOURCES = ctf-archive.c ctf-dump.c ctf-create.c ctf-decl.c ctf-error.c \
diff --git a/libctf/Makefile.in b/libctf/Makefile.in
-index 1984f50867a..55772ba94b3 100644
+index 036a63fa720..e971f0b31bb 100644
--- a/libctf/Makefile.in
+++ b/libctf/Makefile.in
-@@ -381,6 +381,7 @@ AUTOCONF = @AUTOCONF@
+@@ -383,6 +383,7 @@ AUTOCONF = @AUTOCONF@
AUTOHEADER = @AUTOHEADER@
AUTOMAKE = @AUTOMAKE@
AWK = @AWK@
@@ -56,7 +56,7 @@ index 1984f50867a..55772ba94b3 100644
CATALOGS = @CATALOGS@
CATOBJEXT = @CATOBJEXT@
CC = @CC@
-@@ -403,6 +404,7 @@ EXEEXT = @EXEEXT@
+@@ -405,6 +406,7 @@ EXEEXT = @EXEEXT@
# Setup the testing framework, if you have one
EXPECT = expect
@@ -64,7 +64,7 @@ index 1984f50867a..55772ba94b3 100644
FGREP = @FGREP@
GENCAT = @GENCAT@
GMSGFMT = @GMSGFMT@
-@@ -540,8 +542,13 @@ AM_CFLAGS = -std=gnu99 @ac_libctf_warn_cflags@ @warn@ @c_warn@ @WARN_PEDANTIC@ @
+@@ -547,8 +549,13 @@ AM_CFLAGS = -std=gnu99 @ac_libctf_warn_cflags@ @warn@ @c_warn@ @WARN_PEDANTIC@ @
@INSTALL_LIBBFD_FALSE@include_HEADERS =
@INSTALL_LIBBFD_TRUE@include_HEADERS = $(INCDIR)/ctf.h $(INCDIR)/ctf-api.h
@INSTALL_LIBBFD_FALSE@noinst_LTLIBRARIES = libctf.la libctf-nobfd.la
@@ -80,7 +80,7 @@ index 1984f50867a..55772ba94b3 100644
libctf_nobfd_la_CPPFLAGS = $(AM_CPPFLAGS) -DNOBFD=1
libctf_nobfd_la_SOURCES = ctf-archive.c ctf-dump.c ctf-create.c \
diff --git a/libctf/configure b/libctf/configure
-index 8704bc215f4..de99d1714d7 100755
+index 176b3d6b918..31fe5f72a90 100755
--- a/libctf/configure
+++ b/libctf/configure
@@ -646,6 +646,10 @@ BUILD_INFO_FALSE
@@ -93,43 +93,43 @@ index 8704bc215f4..de99d1714d7 100755
+EXTRA_SOVERSION_SUFFIX
ENABLE_LIBCTF_HASH_DEBUGGING_FALSE
ENABLE_LIBCTF_HASH_DEBUGGING_TRUE
- zlibinc
-@@ -807,6 +811,7 @@ enable_maintainer_mode
- enable_install_libbfd
+ ZSTD_LIBS
+@@ -813,6 +817,7 @@ enable_install_libbfd
with_system_zlib
+ with_zstd
enable_libctf_hash_debugging
+with_extra_soversion_suffix
'
ac_precious_vars='build_alias
host_alias
-@@ -1464,6 +1469,8 @@ Optional Packages:
- both]
- --with-gnu-ld assume the C compiler uses GNU ld [default=no]
+@@ -1477,6 +1482,8 @@ Optional Packages:
--with-system-zlib use installed libz
+ --with-zstd support zstd compressed debug sections
+ (default=auto)
+ --with-extra-soversion-suffix=SUFFIX
+ Append '.SUFFIX' to SONAME [[default=]]
Some influential environment variables:
CC C compiler command
-@@ -11635,7 +11642,7 @@ else
+@@ -11655,7 +11662,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 11638 "configure"
-+#line 11645 "configure"
+-#line 11658 "configure"
++#line 11665 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -11741,7 +11748,7 @@ else
+@@ -11761,7 +11768,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<_LT_EOF
--#line 11744 "configure"
-+#line 11751 "configure"
+-#line 11764 "configure"
++#line 11771 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -12948,6 +12955,26 @@ else
+@@ -13209,6 +13216,26 @@ else
fi
@@ -156,7 +156,7 @@ index 8704bc215f4..de99d1714d7 100755
# Similar to GDB_AC_CHECK_BFD.
OLD_CFLAGS=$CFLAGS
OLD_LDFLAGS=$LDFLAGS
-@@ -13840,6 +13867,10 @@ if test -z "${ENABLE_LIBCTF_HASH_DEBUGGING_TRUE}" && test -z "${ENABLE_LIBCTF_HA
+@@ -14101,6 +14128,10 @@ if test -z "${ENABLE_LIBCTF_HASH_DEBUGGING_TRUE}" && test -z "${ENABLE_LIBCTF_HA
as_fn_error $? "conditional \"ENABLE_LIBCTF_HASH_DEBUGGING\" was never defined.
Usually this means the macro was only invoked conditionally." "$LINENO" 5
fi
@@ -168,10 +168,10 @@ index 8704bc215f4..de99d1714d7 100755
if test -z "${NEED_CTF_QSORT_R_TRUE}" && test -z "${NEED_CTF_QSORT_R_FALSE}"; then
as_fn_error $? "conditional \"NEED_CTF_QSORT_R\" was never defined.
diff --git a/libctf/configure.ac b/libctf/configure.ac
-index 4996edd5b70..103fc8b9d33 100644
+index 2e2ccf4b624..fbe5f27241b 100644
--- a/libctf/configure.ac
+++ b/libctf/configure.ac
-@@ -78,6 +78,16 @@ if test "${enable_libctf_hash_debugging}" = yes; then
+@@ -79,6 +79,16 @@ if test "${enable_libctf_hash_debugging}" = yes; then
fi
AM_CONDITIONAL(ENABLE_LIBCTF_HASH_DEBUGGING, test "${enable_libctf_hash_debugging}" = yes)
@@ -189,5 +189,5 @@ index 4996edd5b70..103fc8b9d33 100644
OLD_CFLAGS=$CFLAGS
OLD_LDFLAGS=$LDFLAGS
--
-2.35.1
+2.38.0
diff --git a/9999/0006-Gentoo-XFAIL-15-broken-ld.gold-tests.patch b/9999/0006-Gentoo-XFAIL-15-broken-ld.gold-tests.patch
index 318552c..23e7576 100644
--- a/9999/0006-Gentoo-XFAIL-15-broken-ld.gold-tests.patch
+++ b/9999/0006-Gentoo-XFAIL-15-broken-ld.gold-tests.patch
@@ -1,4 +1,4 @@
-From 7eefd99e98a9396f0ce2e98e9bd86bfeb53a84dc Mon Sep 17 00:00:00 2001
+From 85c162be0eea0006c9d73fae243d771f7d0c9756 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
Date: Sat, 31 Jul 2021 01:18:18 +0200
Subject: [PATCH 6/6] Gentoo: XFAIL 15 broken ld.gold tests
@@ -16,7 +16,7 @@ Bug: https://sourceware.org/bugzilla/show_bug.cgi?id=27303
2 files changed, 18 insertions(+), 4 deletions(-)
diff --git a/gold/testsuite/Makefile.am b/gold/testsuite/Makefile.am
-index 38e54818f48..85c94d40660 100644
+index 843fd0d197c..4940119c190 100644
--- a/gold/testsuite/Makefile.am
+++ b/gold/testsuite/Makefile.am
@@ -1,5 +1,11 @@
@@ -32,7 +32,7 @@ index 38e54818f48..85c94d40660 100644
# system and the host system are the same. So these tests will not
# work when building with a cross-compiler.
diff --git a/gold/testsuite/Makefile.in b/gold/testsuite/Makefile.in
-index 7b4b7832d38..765c2b73140 100644
+index 21804df6573..6a4e2b5c5bb 100644
--- a/gold/testsuite/Makefile.in
+++ b/gold/testsuite/Makefile.in
@@ -15,10 +15,6 @@
@@ -61,7 +61,7 @@ index 7b4b7832d38..765c2b73140 100644
check_PROGRAMS = $(am__EXEEXT_1) $(am__EXEEXT_2) $(am__EXEEXT_3) \
$(am__EXEEXT_4) $(am__EXEEXT_5) $(am__EXEEXT_6) \
$(am__EXEEXT_7) $(am__EXEEXT_8) $(am__EXEEXT_9) \
-@@ -2742,6 +2746,10 @@ top_srcdir = @top_srcdir@
+@@ -2757,6 +2761,10 @@ top_srcdir = @top_srcdir@
zlibdir = @zlibdir@
zlibinc = @zlibinc@
@@ -73,5 +73,5 @@ index 7b4b7832d38..765c2b73140 100644
AUTOMAKE_OPTIONS = foreign -Wno-portability
--
-2.35.1
+2.38.0