summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to '9999/0003-Gentoo-opcodes-link-against-libbfd.la-for-rpath-deps.patch')
-rw-r--r--9999/0003-Gentoo-opcodes-link-against-libbfd.la-for-rpath-deps.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/9999/0003-Gentoo-opcodes-link-against-libbfd.la-for-rpath-deps.patch b/9999/0003-Gentoo-opcodes-link-against-libbfd.la-for-rpath-deps.patch
new file mode 100644
index 0000000..f3c9f8e
--- /dev/null
+++ b/9999/0003-Gentoo-opcodes-link-against-libbfd.la-for-rpath-deps.patch
@@ -0,0 +1,49 @@
+From c55536c61ec7e4c2e983e15f51f56f7a7c340889 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 5 Jul 2016 20:24:00 +0545
+Subject: [PATCH 3/6] Gentoo: opcodes: link against libbfd.la for rpath deps
+
+The reason opcodes doesn't link against libbfd.la is to workaround a
+libtool bug where it uses installed -L paths ahead of DESTDIR paths.
+The downside is that the library itself lacks rpath tags to find the
+right version of libbfd.so.
+
+Since Gentoo has patched the libtool bug for a while, we don't need
+the workaround. Use the .la file so we get the rpath tags.
+
+URL: https://bugs.gentoo.org/563934
+(cherry picked from commit 662586237b0b00ee881e79b56f6234ff36e8bfe6)
+---
+ opcodes/configure | 2 +-
+ opcodes/configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/opcodes/configure b/opcodes/configure
+index a3da5987f1b..22a05245286 100755
+--- a/opcodes/configure
++++ b/opcodes/configure
+@@ -12142,7 +12142,7 @@ if test "$enable_shared" = "yes"; then
+ SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.sl ${SHARED_LIBADD}"
+ ;;
+ *)
+- SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.so ${SHARED_LIBADD}"
++ SHARED_LIBADD="../bfd/libbfd.la ${SHARED_LIBADD}"
+ ;;
+ esac
+ SHARED_DEPENDENCIES="../bfd/libbfd.la"
+diff --git a/opcodes/configure.ac b/opcodes/configure.ac
+index e564f067334..fb6254cd69d 100644
+--- a/opcodes/configure.ac
++++ b/opcodes/configure.ac
+@@ -203,7 +203,7 @@ if test "$enable_shared" = "yes"; then
+ SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.sl ${SHARED_LIBADD}"
+ ;;
+ *)
+- SHARED_LIBADD="-Wl,`pwd`/../bfd/.libs/libbfd.so ${SHARED_LIBADD}"
++ SHARED_LIBADD="../bfd/libbfd.la ${SHARED_LIBADD}"
+ ;;
+ esac
+ SHARED_DEPENDENCIES="../bfd/libbfd.la"
+--
+2.31.1
+