summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--9999/0020-XFAIL-15-broken-ld.gold-tests.patch77
1 files changed, 77 insertions, 0 deletions
diff --git a/9999/0020-XFAIL-15-broken-ld.gold-tests.patch b/9999/0020-XFAIL-15-broken-ld.gold-tests.patch
new file mode 100644
index 0000000..777390f
--- /dev/null
+++ b/9999/0020-XFAIL-15-broken-ld.gold-tests.patch
@@ -0,0 +1,77 @@
+From 6f9a3d6ffa2bcf91bc047055848591dab77c0f11 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
+Date: Sat, 31 Jul 2021 01:18:18 +0200
+Subject: [PATCH] Gentoo: XFAIL 15 broken ld.gold tests
+
+It seems like either the tests or ld.gold in general cannot handle
+compilers built with --enable-default-pie. No fix yet, so let's ignore
+these test failures for the moment. For details see the linked bugs.
+
+Bug: https://bugs.gentoo.org/684046
+Bug: https://sourceware.org/bugzilla/show_bug.cgi?id=22755
+Bug: https://sourceware.org/bugzilla/show_bug.cgi?id=27303
+---
+ gold/testsuite/Makefile.am | 6 ++++++
+ gold/testsuite/Makefile.in | 16 ++++++++++++----
+ 2 files changed, 18 insertions(+), 4 deletions(-)
+
+diff --git a/gold/testsuite/Makefile.am b/gold/testsuite/Makefile.am
+index 38e54818f48..85c94d40660 100644
+--- a/gold/testsuite/Makefile.am
++++ b/gold/testsuite/Makefile.am
+@@ -1,5 +1,11 @@
+ # Process this file with automake to generate Makefile.in
+
++# Gentoo, https://bugs.gentoo.org/684046
++XFAIL_TESTS = exception_separate_shared_12_test exception_separate_shared_21_test \
++ weak_undef_test initpri3a justsyms_exec script_test_2 script_test_1 \
++ justsyms binary_test script_test_3 tls_phdrs_script_test script_test_12i \
++ dynamic_list_2 incremental_test_2 incremental_test_5
++
+ # As far as I can tell automake testing support assumes that the build
+ # system and the host system are the same. So these tests will not
+ # work when building with a cross-compiler.
+diff --git a/gold/testsuite/Makefile.in b/gold/testsuite/Makefile.in
+index 7b4b7832d38..765c2b73140 100644
+--- a/gold/testsuite/Makefile.in
++++ b/gold/testsuite/Makefile.in
+@@ -15,10 +15,6 @@
+ @SET_MAKE@
+
+ # Process this file with automake to generate Makefile.in
+-
+-# As far as I can tell automake testing support assumes that the build
+-# system and the host system are the same. So these tests will not
+-# work when building with a cross-compiler.
+ VPATH = @srcdir@
+ am__is_gnu_make = { \
+ if test -z '$(MAKELEVEL)'; then \
+@@ -94,6 +90,14 @@ POST_UNINSTALL = :
+ build_triplet = @build@
+ host_triplet = @host@
+ target_triplet = @target@
++XFAIL_TESTS = exception_separate_shared_12_test$(EXEEXT) \
++ exception_separate_shared_21_test$(EXEEXT) \
++ weak_undef_test$(EXEEXT) initpri3a$(EXEEXT) \
++ justsyms_exec$(EXEEXT) script_test_2$(EXEEXT) \
++ script_test_1$(EXEEXT) justsyms$(EXEEXT) binary_test$(EXEEXT) \
++ script_test_3$(EXEEXT) tls_phdrs_script_test$(EXEEXT) \
++ script_test_12i$(EXEEXT) dynamic_list_2$(EXEEXT) \
++ incremental_test_2$(EXEEXT) incremental_test_5$(EXEEXT)
+ check_PROGRAMS = $(am__EXEEXT_1) $(am__EXEEXT_2) $(am__EXEEXT_3) \
+ $(am__EXEEXT_4) $(am__EXEEXT_5) $(am__EXEEXT_6) \
+ $(am__EXEEXT_7) $(am__EXEEXT_8) $(am__EXEEXT_9) \
+@@ -2742,6 +2746,10 @@ top_srcdir = @top_srcdir@
+ zlibdir = @zlibdir@
+ zlibinc = @zlibinc@
+
++# As far as I can tell automake testing support assumes that the build
++# system and the host system are the same. So these tests will not
++# work when building with a cross-compiler.
++
+ # Ignore warning about AM_PROG_CC_C_O due to large_CFLAGS
+ AUTOMAKE_OPTIONS = foreign -Wno-portability
+
+--
+2.31.1
+