summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-12-19 06:41:42 +0000
committerMike Frysinger <vapier@gentoo.org>2016-12-19 06:41:42 +0000
commitd7ed33a9c5b2c00f15ac6a720ffa10677e9ab2ca (patch)
tree0e3f53104e5b813c283675d745dafa8bc7daaf6c
parentinitial 4.8 patchset based on last 4.7 patchset (diff)
downloadlinux-headers-patches-d7ed33a9c5b2c00f15ac6a720ffa10677e9ab2ca.tar.gz
linux-headers-patches-d7ed33a9c5b2c00f15ac6a720ffa10677e9ab2ca.tar.bz2
linux-headers-patches-d7ed33a9c5b2c00f15ac6a720ffa10677e9ab2ca.zip
initial 4.9 patchset based on last 4.8 patchset
-rw-r--r--4.9/00_all_0001-linux-stat.h-remove-__GLIBC__-checks.patch28
-rw-r--r--4.9/00_all_0002-netfilter-pull-in-limits.h.patch28
-rw-r--r--4.9/00_all_0003-convert-PAGE_SIZE-usage.patch54
-rw-r--r--4.9/00_all_0004-asm-generic-fcntl.h-namespace-kernel-file-structs.patch54
-rw-r--r--4.9/00_all_0005-unifdef-drop-unused-errno.h-include.patch32
-rw-r--r--4.9/00_all_0006-x86-do-not-build-relocs-tool-when-installing-headers.patch33
-rw-r--r--4.9/00_all_0007-timerfd-export-defines-to-userspace.patch74
-rw-r--r--4.9/00_all_0008-netlink-drop-int-cast-on-length-arg-in-NLMSG_OK.patch43
-rw-r--r--4.9/00_all_0009-uapi-mqueue.h-add-missing-linux-types.h-include.patch43
-rw-r--r--4.9/00_all_0010-uapi-fix-System-V-buf-header-includes.patch76
10 files changed, 465 insertions, 0 deletions
diff --git a/4.9/00_all_0001-linux-stat.h-remove-__GLIBC__-checks.patch b/4.9/00_all_0001-linux-stat.h-remove-__GLIBC__-checks.patch
new file mode 100644
index 0000000..00998fc
--- /dev/null
+++ b/4.9/00_all_0001-linux-stat.h-remove-__GLIBC__-checks.patch
@@ -0,0 +1,28 @@
+From e22e4d4519493dad74f4ddb53e82e346aa34153c Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 29 Dec 2008 06:52:59 -0500
+Subject: [PATCH] linux/stat.h: remove __GLIBC__ checks
+
+Only check __KERNEL__ so we don't assume the C library is glibc.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/uapi/linux/stat.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/uapi/linux/stat.h b/include/uapi/linux/stat.h
+index 7fec7e36d921..256ad24c64a8 100644
+--- a/include/uapi/linux/stat.h
++++ b/include/uapi/linux/stat.h
+@@ -2,7 +2,7 @@
+ #define _UAPI_LINUX_STAT_H
+
+
+-#if defined(__KERNEL__) || !defined(__GLIBC__) || (__GLIBC__ < 2)
++#if defined(__KERNEL__)
+
+ #define S_IFMT 00170000
+ #define S_IFSOCK 0140000
+--
+2.11.0.rc2
+
diff --git a/4.9/00_all_0002-netfilter-pull-in-limits.h.patch b/4.9/00_all_0002-netfilter-pull-in-limits.h.patch
new file mode 100644
index 0000000..6916c60
--- /dev/null
+++ b/4.9/00_all_0002-netfilter-pull-in-limits.h.patch
@@ -0,0 +1,28 @@
+From 9aa27a18ab670f758eff7c3344b4a11243833b45 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 9 May 2009 17:30:35 -0400
+Subject: [PATCH] netfilter: pull in limits.h
+
+A few netfilter sub-headers use INT_MAX which is in limits.h.
+
+URL: http://bugs.gentoo.org/246160
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/uapi/linux/netfilter.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/uapi/linux/netfilter.h b/include/uapi/linux/netfilter.h
+index d93f949d1d9a..beed62c8ce92 100644
+--- a/include/uapi/linux/netfilter.h
++++ b/include/uapi/linux/netfilter.h
+@@ -6,6 +6,7 @@
+ #include <linux/sysctl.h>
+ #include <linux/in.h>
+ #include <linux/in6.h>
++#include <limits.h>
+
+ /* Responses from hook functions. */
+ #define NF_DROP 0
+--
+2.11.0.rc2
+
diff --git a/4.9/00_all_0003-convert-PAGE_SIZE-usage.patch b/4.9/00_all_0003-convert-PAGE_SIZE-usage.patch
new file mode 100644
index 0000000..005d96a
--- /dev/null
+++ b/4.9/00_all_0003-convert-PAGE_SIZE-usage.patch
@@ -0,0 +1,54 @@
+From 6a918ccfd7348317ced65abc737a72e8f8e9dd94 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 13 Feb 2010 03:09:23 -0500
+Subject: [PATCH] convert PAGE_SIZE usage
+
+The size of a page may change at runtime or based on kernel settings, so
+a static value at compile time doesn't work. More importantly, no one
+exports PAGE_SIZE to user space anymore.
+
+URL: http://bugs.gentoo.org/301431
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/uapi/linux/binfmts.h | 3 ++-
+ include/uapi/linux/resource.h | 3 ++-
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/include/uapi/linux/binfmts.h b/include/uapi/linux/binfmts.h
+index 4eb5972867c0..516bfcf62f64 100644
+--- a/include/uapi/linux/binfmts.h
++++ b/include/uapi/linux/binfmts.h
+@@ -1,6 +1,7 @@
+ #ifndef _UAPI_LINUX_BINFMTS_H
+ #define _UAPI_LINUX_BINFMTS_H
+
++#include <unistd.h>
+ #include <linux/capability.h>
+
+ struct pt_regs;
+@@ -11,7 +12,7 @@ struct pt_regs;
+ * prevent the kernel from being unduly impacted by misaddressed pointers.
+ * MAX_ARG_STRINGS is chosen to fit in a signed 32-bit integer.
+ */
+-#define MAX_ARG_STRLEN (PAGE_SIZE * 32)
++#define MAX_ARG_STRLEN (sysconf(_SC_PAGESIZE) * 32)
+ #define MAX_ARG_STRINGS 0x7FFFFFFF
+
+ /* sizeof(linux_binprm->buf) */
+diff --git a/include/uapi/linux/resource.h b/include/uapi/linux/resource.h
+index 36fb3b5fb181..58efd0799cd7 100644
+--- a/include/uapi/linux/resource.h
++++ b/include/uapi/linux/resource.h
+@@ -68,7 +68,8 @@ struct rlimit64 {
+ * GPG2 wants 64kB of mlocked memory, to make sure pass phrases
+ * and other sensitive information are never written to disk.
+ */
+-#define MLOCK_LIMIT ((PAGE_SIZE > 64*1024) ? PAGE_SIZE : 64*1024)
++/* No one currently defines PAGE_SIZE bigger than 64kB */
++#define MLOCK_LIMIT (64 * 1024)
+
+ /*
+ * Due to binary compatibility, the actual resource numbers
+--
+2.11.0.rc2
+
diff --git a/4.9/00_all_0004-asm-generic-fcntl.h-namespace-kernel-file-structs.patch b/4.9/00_all_0004-asm-generic-fcntl.h-namespace-kernel-file-structs.patch
new file mode 100644
index 0000000..bddbcdf
--- /dev/null
+++ b/4.9/00_all_0004-asm-generic-fcntl.h-namespace-kernel-file-structs.patch
@@ -0,0 +1,54 @@
+From a40185b52a3124d332fbc653d1784b6afec87b2b Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 29 Dec 2008 07:39:14 -0500
+Subject: [PATCH] asm-generic/fcntl.h: namespace kernel file structs
+
+No one should be using these structs, but just in case they are,
+keep them available in the __kernel_ namespace.
+
+Otherwise, trying to include something like:
+ #include <fcntl.h>
+ #include <linux/inotify.h>
+leads to horrible failure.
+
+URL: http://bugs.gentoo.org/244470
+URL: http://bugs.gentoo.org/388633
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/uapi/asm-generic/fcntl.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/include/uapi/asm-generic/fcntl.h b/include/uapi/asm-generic/fcntl.h
+index e063effe0cc1..a98769e712ce 100644
+--- a/include/uapi/asm-generic/fcntl.h
++++ b/include/uapi/asm-generic/fcntl.h
+@@ -152,7 +152,7 @@
+ #define F_OWNER_PID 1
+ #define F_OWNER_PGRP 2
+
+-struct f_owner_ex {
++struct __kernel_f_owner_ex {
+ int type;
+ __kernel_pid_t pid;
+ };
+@@ -192,7 +192,7 @@ struct f_owner_ex {
+ #define __ARCH_FLOCK_PAD
+ #endif
+
+-struct flock {
++struct __kernel_flock {
+ short l_type;
+ short l_whence;
+ __kernel_off_t l_start;
+@@ -207,7 +207,7 @@ struct flock {
+ #define __ARCH_FLOCK64_PAD
+ #endif
+
+-struct flock64 {
++struct __kernel_flock64 {
+ short l_type;
+ short l_whence;
+ __kernel_loff_t l_start;
+--
+2.11.0.rc2
+
diff --git a/4.9/00_all_0005-unifdef-drop-unused-errno.h-include.patch b/4.9/00_all_0005-unifdef-drop-unused-errno.h-include.patch
new file mode 100644
index 0000000..1d55f86
--- /dev/null
+++ b/4.9/00_all_0005-unifdef-drop-unused-errno.h-include.patch
@@ -0,0 +1,32 @@
+From 1615191bb9afff184dc9054e9b37c48ef833eba9 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 6 Dec 2011 17:22:42 -0500
+Subject: [PATCH] unifdef: drop unused errno.h include
+
+This is the only header on my system that ends up requiring kernel
+headers, so if the kernel headers aren't available, we end up being
+unable to install kernel headers :).
+
+Since this file doesn't actually use anything from errno.h, drop
+the include so it at least makes us a bit more robust on glibc.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ scripts/unifdef.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/scripts/unifdef.c b/scripts/unifdef.c
+index 7493c0ee51cc..c5dfae538b08 100644
+--- a/scripts/unifdef.c
++++ b/scripts/unifdef.c
+@@ -48,7 +48,6 @@
+
+ #include <ctype.h>
+ #include <err.h>
+-#include <errno.h>
+ #include <stdarg.h>
+ #include <stdbool.h>
+ #include <stdio.h>
+--
+2.11.0.rc2
+
diff --git a/4.9/00_all_0006-x86-do-not-build-relocs-tool-when-installing-headers.patch b/4.9/00_all_0006-x86-do-not-build-relocs-tool-when-installing-headers.patch
new file mode 100644
index 0000000..c2948cc
--- /dev/null
+++ b/4.9/00_all_0006-x86-do-not-build-relocs-tool-when-installing-headers.patch
@@ -0,0 +1,33 @@
+From 08c1292913d8bf953bc7353272cf576a3134c47c Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 15 Nov 2014 03:37:38 -0500
+Subject: [PATCH] x86: do not build relocs tool when installing headers
+
+This isn't needed to install headers, so don't bother building it.
+Otherwise we run into a chicken/egg issue where we need the kernel
+headers in order to install the kernel headers. It's also a waste
+of time.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ arch/x86/Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/arch/x86/Makefile b/arch/x86/Makefile
+index 2d449337a360..a41878a7f714 100644
+--- a/arch/x86/Makefile
++++ b/arch/x86/Makefile
+@@ -182,8 +182,10 @@ KBUILD_CFLAGS += -fno-asynchronous-unwind-tables
+ KBUILD_CFLAGS += $(mflags-y)
+ KBUILD_AFLAGS += $(mflags-y)
+
++ifneq ($(filter-out headers_install,$(MAKECMDGOALS)),)
+ archscripts: scripts_basic
+ $(Q)$(MAKE) $(build)=arch/x86/tools relocs
++endif
+
+ ###
+ # Syscall table generation
+--
+2.11.0.rc2
+
diff --git a/4.9/00_all_0007-timerfd-export-defines-to-userspace.patch b/4.9/00_all_0007-timerfd-export-defines-to-userspace.patch
new file mode 100644
index 0000000..394977b
--- /dev/null
+++ b/4.9/00_all_0007-timerfd-export-defines-to-userspace.patch
@@ -0,0 +1,74 @@
+From 26bf01f8abe04a08343fd6bc1edca5479f21eb0d Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Tue, 30 Dec 2014 19:14:51 -0500
+Subject: [PATCH] timerfd: export defines to userspace
+
+Since userspace is expected to call timerfd syscalls directly with these
+flags/ioctls, make sure we export them so they don't have to duplicate
+the values themselves.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/linux/timerfd.h | 20 +-------------------
+ include/uapi/linux/Kbuild | 1 +
+ include/uapi/linux/timerfd.h | 36 ++++++++++++++++++++++++++++++++++++
+ 3 files changed, 38 insertions(+), 19 deletions(-)
+ create mode 100644 include/uapi/linux/timerfd.h
+
+diff --git a/include/uapi/linux/Kbuild b/include/uapi/linux/Kbuild
+index cd2be1c8e9fb..9c4d25ed8e1e 100644
+--- a/include/uapi/linux/Kbuild
++++ b/include/uapi/linux/Kbuild
+@@ -411,6 +411,7 @@ header-y += telephony.h
+ header-y += termios.h
+ header-y += thermal.h
+ header-y += time.h
++header-y += timerfd.h
+ header-y += times.h
+ header-y += timex.h
+ header-y += tiocl.h
+diff --git a/include/uapi/linux/timerfd.h b/include/uapi/linux/timerfd.h
+new file mode 100644
+index 000000000000..6fcfaa8da173
+--- /dev/null
++++ b/include/uapi/linux/timerfd.h
+@@ -0,0 +1,36 @@
++/*
++ * include/linux/timerfd.h
++ *
++ * Copyright (C) 2007 Davide Libenzi <davidel@xmailserver.org>
++ *
++ */
++
++#ifndef _UAPI_LINUX_TIMERFD_H
++#define _UAPI_LINUX_TIMERFD_H
++
++#include <linux/types.h>
++
++/* For O_CLOEXEC and O_NONBLOCK */
++#include <linux/fcntl.h>
++
++/* For _IO helpers */
++#include <linux/ioctl.h>
++
++/*
++ * CAREFUL: Check include/asm-generic/fcntl.h when defining
++ * new flags, since they might collide with O_* ones. We want
++ * to re-use O_* flags that couldn't possibly have a meaning
++ * from eventfd, in order to leave a free define-space for
++ * shared O_* flags.
++ *
++ * Also make sure to update the masks in include/linux/timerfd.h
++ * when adding new flags.
++ */
++#define TFD_TIMER_ABSTIME (1 << 0)
++#define TFD_TIMER_CANCEL_ON_SET (1 << 1)
++#define TFD_CLOEXEC O_CLOEXEC
++#define TFD_NONBLOCK O_NONBLOCK
++
++#define TFD_IOC_SET_TICKS _IOW('T', 0, __u64)
++
++#endif /* _UAPI_LINUX_TIMERFD_H */
+--
+2.11.0.rc2
+
diff --git a/4.9/00_all_0008-netlink-drop-int-cast-on-length-arg-in-NLMSG_OK.patch b/4.9/00_all_0008-netlink-drop-int-cast-on-length-arg-in-NLMSG_OK.patch
new file mode 100644
index 0000000..1370e2f
--- /dev/null
+++ b/4.9/00_all_0008-netlink-drop-int-cast-on-length-arg-in-NLMSG_OK.patch
@@ -0,0 +1,43 @@
+From 7c18a29dc18608869ed55175480b5301c110a201 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Thu, 5 Mar 2015 00:26:58 -0500
+Subject: [PATCH] netlink: drop (int) cast on length arg in NLMSG_OK
+
+The NLMSG_OK macro compares three things:
+ - the len arg from the user
+ - a size_t: sizeof(struct nlmsghdr)
+ - an int: sizeof(struct nlmsghdr) casted
+ - an u32: the nlmsghdr->nlmsg_len member
+
+When building with -Wsign-compare, this macro triggers a signed compare
+warning. This is because it compares len to an int, and then compares
+it to a u32. If len is signed, we get a warning due to the last test.
+If len is unsigned, we get a warning due to the first test. Like in
+strace:
+socketutils.c:145:8: warning: comparison between signed and unsigned
+ integer expressions [-Wsign-compare]
+
+Lets drop the int cast on the first sizeof. This way, once the user
+casts len to an unsigned value, everything shakes out correctly.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/uapi/linux/netlink.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/include/uapi/linux/netlink.h b/include/uapi/linux/netlink.h
+index 0dba4e4ed2be..56b79fbd84dc 100644
+--- a/include/uapi/linux/netlink.h
++++ b/include/uapi/linux/netlink.h
+@@ -85,7 +85,7 @@ struct nlmsghdr {
+ #define NLMSG_DATA(nlh) ((void*)(((char*)nlh) + NLMSG_LENGTH(0)))
+ #define NLMSG_NEXT(nlh,len) ((len) -= NLMSG_ALIGN((nlh)->nlmsg_len), \
+ (struct nlmsghdr*)(((char*)(nlh)) + NLMSG_ALIGN((nlh)->nlmsg_len)))
+-#define NLMSG_OK(nlh,len) ((len) >= (int)sizeof(struct nlmsghdr) && \
++#define NLMSG_OK(nlh,len) ((len) >= sizeof(struct nlmsghdr) && \
+ (nlh)->nlmsg_len >= sizeof(struct nlmsghdr) && \
+ (nlh)->nlmsg_len <= (len))
+ #define NLMSG_PAYLOAD(nlh,len) ((nlh)->nlmsg_len - NLMSG_SPACE((len)))
+--
+2.11.0.rc2
+
diff --git a/4.9/00_all_0009-uapi-mqueue.h-add-missing-linux-types.h-include.patch b/4.9/00_all_0009-uapi-mqueue.h-add-missing-linux-types.h-include.patch
new file mode 100644
index 0000000..35d13f2
--- /dev/null
+++ b/4.9/00_all_0009-uapi-mqueue.h-add-missing-linux-types.h-include.patch
@@ -0,0 +1,43 @@
+From 0d4e40b65f77ee7c819f43e00c8a20ed95ec255a Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@chromium.org>
+Date: Wed, 28 Oct 2015 18:41:33 -0400
+Subject: [PATCH] uapi: mqueue.h: add missing linux/types.h include
+
+Commit 63159f5dcccb3858d88aaef800c4ee0eb4cc8577 changed the types from
+long to __kernel_long_t, but didn't add a linux/types.h include. Code
+that tries to include this header directly breaks:
+
+/usr/include/linux/mqueue.h:26:2: error: unknown type name '__kernel_long_t'
+ __kernel_long_t mq_flags; /* message queue flags */
+
+This also upsets configure tests for this header:
+checking linux/mqueue.h usability... no
+checking linux/mqueue.h presence... yes
+configure: WARNING: linux/mqueue.h: present but cannot be compiled
+configure: WARNING: linux/mqueue.h: check for missing prerequisite headers?
+configure: WARNING: linux/mqueue.h: see the Autoconf documentation
+configure: WARNING: linux/mqueue.h: section "Present But Cannot Be Compiled"
+configure: WARNING: linux/mqueue.h: proceeding with the compiler's result
+checking for linux/mqueue.h... no
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/uapi/linux/mqueue.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/include/uapi/linux/mqueue.h b/include/uapi/linux/mqueue.h
+index d0a2b8e89813..bbd5116ea739 100644
+--- a/include/uapi/linux/mqueue.h
++++ b/include/uapi/linux/mqueue.h
+@@ -18,6 +18,8 @@
+ #ifndef _LINUX_MQUEUE_H
+ #define _LINUX_MQUEUE_H
+
++#include <linux/types.h>
++
+ #define MQ_PRIO_MAX 32768
+ /* per-uid limit of kernel memory used by mqueue, in bytes */
+ #define MQ_BYTES_MAX 819200
+--
+2.11.0.rc2
+
diff --git a/4.9/00_all_0010-uapi-fix-System-V-buf-header-includes.patch b/4.9/00_all_0010-uapi-fix-System-V-buf-header-includes.patch
new file mode 100644
index 0000000..8f38510
--- /dev/null
+++ b/4.9/00_all_0010-uapi-fix-System-V-buf-header-includes.patch
@@ -0,0 +1,76 @@
+From d7cd19b0b098f6fdd3e3ec57265e7f6115cb8f63 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 2 Nov 2015 13:30:12 -0500
+Subject: [PATCH] uapi: fix System V buf header includes
+
+These headers rely on kernel types but don't include the other headers
+that define them. So when you try to include them directly, you often
+hit build failures due to unknown types.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ include/uapi/asm-generic/ipcbuf.h | 2 ++
+ include/uapi/asm-generic/msgbuf.h | 3 +++
+ include/uapi/asm-generic/sembuf.h | 2 ++
+ include/uapi/asm-generic/shmbuf.h | 2 ++
+ 4 files changed, 9 insertions(+)
+
+diff --git a/include/uapi/asm-generic/ipcbuf.h b/include/uapi/asm-generic/ipcbuf.h
+index 3dbcc1e771c0..c37b32ab1304 100644
+--- a/include/uapi/asm-generic/ipcbuf.h
++++ b/include/uapi/asm-generic/ipcbuf.h
+@@ -1,6 +1,8 @@
+ #ifndef __ASM_GENERIC_IPCBUF_H
+ #define __ASM_GENERIC_IPCBUF_H
+
++#include <linux/types.h>
++
+ /*
+ * The generic ipc64_perm structure:
+ * Note extra padding because this structure is passed back and forth
+diff --git a/include/uapi/asm-generic/msgbuf.h b/include/uapi/asm-generic/msgbuf.h
+index f55ecc43c60f..473dcdc305a1 100644
+--- a/include/uapi/asm-generic/msgbuf.h
++++ b/include/uapi/asm-generic/msgbuf.h
+@@ -1,7 +1,10 @@
+ #ifndef __ASM_GENERIC_MSGBUF_H
+ #define __ASM_GENERIC_MSGBUF_H
+
++#include <linux/types.h>
+ #include <asm/bitsperlong.h>
++#include <asm/ipcbuf.h>
++
+ /*
+ * generic msqid64_ds structure.
+ *
+diff --git a/include/uapi/asm-generic/sembuf.h b/include/uapi/asm-generic/sembuf.h
+index 4cb2c13e5090..f57240f7e6a2 100644
+--- a/include/uapi/asm-generic/sembuf.h
++++ b/include/uapi/asm-generic/sembuf.h
+@@ -1,7 +1,9 @@
+ #ifndef __ASM_GENERIC_SEMBUF_H
+ #define __ASM_GENERIC_SEMBUF_H
+
++#include <linux/types.h>
+ #include <asm/bitsperlong.h>
++#include <asm/ipcbuf.h>
+
+ /*
+ * The semid64_ds structure for x86 architecture.
+diff --git a/include/uapi/asm-generic/shmbuf.h b/include/uapi/asm-generic/shmbuf.h
+index 7e9fb2f0853b..f9e28e413c3c 100644
+--- a/include/uapi/asm-generic/shmbuf.h
++++ b/include/uapi/asm-generic/shmbuf.h
+@@ -1,7 +1,9 @@
+ #ifndef __ASM_GENERIC_SHMBUF_H
+ #define __ASM_GENERIC_SHMBUF_H
+
++#include <linux/types.h>
+ #include <asm/bitsperlong.h>
++#include <asm/ipcbuf.h>
+
+ /*
+ * The shmid64_ds structure for x86 architecture.
+--
+2.11.0.rc2
+