summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/webtest/Manifest2
-rw-r--r--dev-python/webtest/webtest-1.2.3.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/webtest/Manifest b/dev-python/webtest/Manifest
new file mode 100644
index 0000000..4126059
--- /dev/null
+++ b/dev-python/webtest/Manifest
@@ -0,0 +1,2 @@
+DIST WebTest-1.2.3.tar.gz 49571 RMD160 41cee0779ed26fb484d692e7cbff165c46335095 SHA1 2bf3c6a11b948c6b166935bbd73a3a0a40e458e5 SHA256 5e1cdb914a889ee035daa610e9858c1a33fec481cbd7a7df45b537954cbb513b
+EBUILD webtest-1.2.3.ebuild 790 RMD160 998bbe88d1f6a6e20f57a81cbff9cc573330e3c0 SHA1 ab929dd018c03409af09b31065397e5dfa5f43b0 SHA256 9a4f8534a71262bde959c8afac398203e223d1e4d8b65335deb009002e01711c
diff --git a/dev-python/webtest/webtest-1.2.3.ebuild b/dev-python/webtest/webtest-1.2.3.ebuild
new file mode 100644
index 0000000..ffe2904
--- /dev/null
+++ b/dev-python/webtest/webtest-1.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webtest/webtest-1.2.2.ebuild,v 1.4 2010/10/21 22:04:02 fauli Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+# xml.etree.ElementTree module required.
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_PN="WebTest"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="http://pythonpaste.org/webtest/ http://pypi.python.org/pypi/WebTest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE=""
+
+RDEPEND=">=dev-python/webob-0.9.2"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"