aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml18
1 files changed, 2 insertions, 16 deletions
diff --git a/pyproject.toml b/pyproject.toml
index e23bf89..e6ca72f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,6 @@
[build-system]
-requires = ["setuptools"]
-build-backend = "setuptools.build_meta"
+requires = ["flit_core >=3.2,<4"]
+build-backend = "flit_core.buildapi"
[project]
name = "tyrian-sphinx-theme"
@@ -25,17 +25,3 @@ Homepage = "https://gitweb.gentoo.org/proj/tyrian-sphinx-theme.git"
[project.entry-points."sphinx.html_themes"]
tyrian_sphinx_theme = "tyrian_sphinx_theme"
-
-[tool.setuptools]
-packages = ["tyrian_sphinx_theme"]
-
-[tool.setuptools.package-data]
-tyrian_sphinx_theme = [
- "theme.conf",
- "*.html",
- "static/*.css",
- "static/*.css_t",
-]
-
-[tool.setuptools.dynamic]
-version = {attr = "tyrian_sphinx_theme.__version__"}