summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2011-10-29 15:16:08 -0500
committerWilliam Hubbs <williamh@gentoo.org>2011-10-29 15:16:08 -0500
commitba62574fdc12c39736032fa7be3715c202f9326c (patch)
tree6e6286c539e2bf7109005ef325bb8afb0b88aa98 /Makefile
parentremove warning about unreliable kernel/udev combination (diff)
downloadudev-gentoo-scripts-ba62574fdc12c39736032fa7be3715c202f9326c.tar.gz
udev-gentoo-scripts-ba62574fdc12c39736032fa7be3715c202f9326c.tar.bz2
udev-gentoo-scripts-ba62574fdc12c39736032fa7be3715c202f9326c.zip
Add kv_min variable to the udev init script
The makefile was hard coding a value for the minimal kernel version into the init script. I feel that a better approach is to have a variable with a default value in the init script. For testing, it is possible to adjust the value in /etc/conf.d/udev. I deliberately did not document this in the conf.d file, because this is a value we would not want users to modify.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 0 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 055d71a..028dcec 100644
--- a/Makefile
+++ b/Makefile
@@ -7,8 +7,6 @@ MODPROBE_DIR ?= $(SYSCONFDIR)/modprobe.d
VERSION = $(shell git describe --tags)
-KV_min ?= 2.6.24
-
DESTNAME = udev-gentoo-scripts-$(VERSION)
HELPERS = \
@@ -33,8 +31,6 @@ install:
@install -m 0755 init.d/* $(DESTDIR)$(INITD)
@install -d $(DESTDIR)$(MODPROBE_DIR)
@install -m 0644 modprobe.d/* $(DESTDIR)$(MODPROBE_DIR)
- @sed -e "s/%KV_MIN%/$(KV_min)/" \
- -i "$(DESTDIR)$(INITD)"/udev
check-git-repository:
git diff --quiet || { echo 'STOP, you have uncommitted changes in the working directory' ; false ; }