summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index 9f88d4d..c0f63a1 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
-PACKAGE = udev-init-scripts
VERSION = 28
-DISTNAME = $(PACKAGE)-$(VERSION)
+PACKAGE = udev-init-scripts
+TARBALL = $(PACKAGE)-$(VERSION).tar.gz
SYSCONFDIR ?= /etc
CONFD ?= $(SYSCONFDIR)/conf.d
@@ -19,8 +19,7 @@ check-git-repository:
git diff --cached --quiet || { echo 'STOP, you have uncommitted changes in the index' ; false ; }
dist:
- git archive --format=tar --prefix=$(DISTNAME)/ $(VERSION) | \
- bzip2 > $(DISTNAME).tar.bz2
+ git archive --prefix=$(PACKAGE)-$(VERSION)/ $(VERSION) -o $(TARBALL)
snapshot: check-git-repository
git archive --format=tar --prefix=$(PACKAGE)/ HEAD | \