summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2010-02-28 14:17:58 +0000
committerJoerg Bornkessel <hd_brummy@gentoo.org>2010-02-28 14:17:58 +0000
commit268bd6513fef536e88c5de0d5055fd0443635bac (patch)
treeadd4dde6a831dbde889ed0e67a45f5228ca1fd4e /media-tv
parentmask mantis-v4l-dvb-hg, s2-liplianin hg ebuild (diff)
downloadtesting-268bd6513fef536e88c5de0d5055fd0443635bac.tar.gz
testing-268bd6513fef536e88c5de0d5055fd0443635bac.tar.bz2
testing-268bd6513fef536e88c5de0d5055fd0443635bac.zip
media-tv/mantis-v4l-dvb-hg: initial mercurial ebuild, masked for live time
svn path=/testing/; revision=700
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mantis-v4l-dvb-hg/ChangeLog8
-rw-r--r--media-tv/mantis-v4l-dvb-hg/Manifest3
-rw-r--r--media-tv/mantis-v4l-dvb-hg/mantis-v4l-dvb-hg-0.1.ebuild128
-rw-r--r--media-tv/mantis-v4l-dvb-hg/metadata.xml10
4 files changed, 149 insertions, 0 deletions
diff --git a/media-tv/mantis-v4l-dvb-hg/ChangeLog b/media-tv/mantis-v4l-dvb-hg/ChangeLog
new file mode 100644
index 0000000..7276f43
--- /dev/null
+++ b/media-tv/mantis-v4l-dvb-hg/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for media-tv/mantis-v4l-dvb-hg
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 28 Feb 2010; Joerg Bornkessel <hd_brummy@gentoo.org>
+ +mantis-v4l-dvb-hg-0.1.ebuild, +metadata.xml:
+ initial mercurial ebuild, masked for live time
+
diff --git a/media-tv/mantis-v4l-dvb-hg/Manifest b/media-tv/mantis-v4l-dvb-hg/Manifest
new file mode 100644
index 0000000..cfe4258
--- /dev/null
+++ b/media-tv/mantis-v4l-dvb-hg/Manifest
@@ -0,0 +1,3 @@
+EBUILD mantis-v4l-dvb-hg-0.1.ebuild 2929 RMD160 b94cef363172271656d50fccccc444f6ea3b592a SHA1 e7ee5a86ff5d64585ffb401b351096f78a27f190 SHA256 90e135217bf8b6066876e4743032bfb501763aab83673cb682f6043936cdb67d
+MISC ChangeLog 280 RMD160 7d91b71252e784af4b346621662c83a56d9d3950 SHA1 9321ad1dad5d589b9882c7f2b2ed23c946cfdc00 SHA256 fb1ad5eb6bbef44fe184a9f02dc0f9995032d8dcf48d3160c93546b09cad09ad
+MISC metadata.xml 251 RMD160 b4bdfc1a9e947ad1d1f76c1942f02057d5cbc993 SHA1 6e174f6e4395999a9dafd53f523e079766c0b094 SHA256 b426b6e6d679a63de74d2c1a21e4da2381fb1b580b0180b041307471d67ab54f
diff --git a/media-tv/mantis-v4l-dvb-hg/mantis-v4l-dvb-hg-0.1.ebuild b/media-tv/mantis-v4l-dvb-hg/mantis-v4l-dvb-hg-0.1.ebuild
new file mode 100644
index 0000000..873c2e3
--- /dev/null
+++ b/media-tv/mantis-v4l-dvb-hg/mantis-v4l-dvb-hg-0.1.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-tv/v4l-dvb-hg/v4l-dvb-hg-0.1-r3.ebuild,v 1.3 2009/11/18 19:39:51 zzam Exp $
+
+: ${EHG_REPO_URI:=${MANTIS_V4L_DVB_HG_REPO_URI:-http://www.jusst.de/hg/mantis-v4l-dvb/}}
+
+EAPI="2"
+
+inherit linux-mod eutils toolchain-funcs mercurial savedconfig
+
+DESCRIPTION="Live development version of mantis V4L and DVB driver for kernel 2.6"
+SRC_URI=""
+HOMEPAGE="http://jusst.de/hg/mantis/"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="!media-tv/v4l-dvb-hg
+ !media-tv/s2-liplianin"
+
+S="${WORKDIR}/${EHG_REPO_URI##*/}mantis-v4l-dvb/v4l"
+
+CONFIG_CHECK="!DVB_CORE !VIDEO_DEV"
+
+pkg_setup()
+{
+ linux-mod_pkg_setup
+ if [[ "${KV_MAJOR}.${KV_MINOR}" != "2.6" ]]; then
+ ewarn "other Kernel than 2.6.x are not supported at the moment."
+ die "unsupported Kernel (not 2.6.x)"
+ fi
+ MODULE_NAMES="dvb(dvb:${S})"
+ BUILD_PARAMS="KDIR=${KERNEL_DIR}"
+ BUILD_TARGETS="default"
+}
+
+src_prepare() {
+
+ einfo "Removing modules-install"
+ sed -i "${S}"/Makefile \
+ -e "s/install:: media-install firmware_install/install:: media-install/"
+
+ # apply local patches
+ if test -n "${DVB_LOCAL_PATCHES}";
+ then
+ ewarn "Applying local patches:"
+ for LOCALPATCH in ${DVB_LOCAL_PATCHES};
+ do
+ if test -f "${LOCALPATCH}";
+ then
+ if grep -q linux/drivers "${LOCALPATCH}"; then
+ cd "${S}"/..
+ else
+ cd "${S}"
+ fi
+ epatch "${LOCALPATCH}"
+ fi
+ done
+ else
+ einfo "No additional local patches to use"
+ fi
+
+ export ARCH=$(tc-arch-kernel)
+ make allmodconfig ${BUILD_PARAMS}
+ export ARCH=$(tc-arch)
+
+ echo
+
+ elog "Removing autoload-entry from stradis-driver."
+ sed -i "${S}"/../linux/drivers/media/video/stradis.c -e '/MODULE_DEVICE_TABLE/d'
+
+ cd "${S}"
+ sed -e '/-install::/s:rminstall::' \
+ -i Makefile
+
+ elog "Removing depmod-calls"
+ sed -e '/depmod/d' -i Makefile* scripts/make_makefile.pl scripts/make_kconfig.pl \
+ || die "Failed removing depmod call from Makefile"
+
+ grep depmod * && die "Not removed depmod found."
+
+ mkdir "${WORKDIR}"/header
+ cd "${WORKDIR}"/header
+ cp "${S}"/../linux/include/linux/dvb/* .
+ sed -e '/compiler/d' \
+ -e 's/__user//' \
+ -i *.h
+
+ cd "${S}"
+ restore_config .config
+}
+
+src_install() {
+ # install the modules
+ local DEST="${D}/lib/modules/${KV_FULL}/v4l-dvb"
+ make install \
+ DEST="${DEST}" \
+ KDIR26="${DEST}" \
+ KDIRA="${DEST}" \
+ || die "make install failed"
+
+ cd "${S}"/..
+ dodoc linux/Documentation/dvb/*.txt
+ dosbin linux/Documentation/dvb/get_dvb_firmware
+
+ insinto /usr/include/v4l-dvb-hg/linux/dvb
+ cd "${WORKDIR}/header"
+ doins *.h
+
+ cd "${S}"
+ save_config .config
+}
+
+pkg_postinst() {
+ echo
+ elog "Firmware-files can be found in media-tv/linuxtv-dvb-firmware"
+ echo
+
+ linux-mod_pkg_postinst
+ echo
+ echo
+ elog "if you want to use the IR-port or networking"
+ elog "with the dvb-card you need to"
+ elog "install linuxtv-dvb-apps"
+ echo
+}
diff --git a/media-tv/mantis-v4l-dvb-hg/metadata.xml b/media-tv/mantis-v4l-dvb-hg/metadata.xml
new file mode 100644
index 0000000..5f9f146
--- /dev/null
+++ b/media-tv/mantis-v4l-dvb-hg/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+</pkgmetadata>
+