summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2012-06-17 09:23:02 -0400
committerVadim Kuznetsov <vadimk@gentoo.org>2012-06-17 09:23:02 -0400
commit1bb76d1c0e84039b47ef9c25f482a7eae494e0a7 (patch)
tree45ec32b0b5ec6598e0dd37db741895054144d20c /app-emulation/vmware-modules
parentplayer without fetch restriction (diff)
downloadvmware-1bb76d1c0e84039b47ef9c25f482a7eae494e0a7.tar.gz
vmware-1bb76d1c0e84039b47ef9c25f482a7eae494e0a7.tar.bz2
vmware-1bb76d1c0e84039b47ef9c25f482a7eae494e0a7.zip
removed server, old modules; repoman QA fixes.
Diffstat (limited to 'app-emulation/vmware-modules')
-rw-r--r--app-emulation/vmware-modules/Manifest2
-rw-r--r--app-emulation/vmware-modules/vmware-modules-138.10.7.ebuild70
-rw-r--r--app-emulation/vmware-modules/vmware-modules-208.2.ebuild73
-rw-r--r--app-emulation/vmware-modules/vmware-modules-238.6.ebuild2
-rw-r--r--app-emulation/vmware-modules/vmware-modules-264.4.ebuild2
5 files changed, 2 insertions, 147 deletions
diff --git a/app-emulation/vmware-modules/Manifest b/app-emulation/vmware-modules/Manifest
deleted file mode 100644
index 1e5e29d..0000000
--- a/app-emulation/vmware-modules/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST vmware-modules-138.10-genpatches-7.tar.bz2 14498 RMD160 a6927bad3eb2b797eb5d8d2a90c6447ebb1fd709 SHA1 57a1524149f976bccfbc0789cd40863f1ab012f0 SHA256 2b3209e71543904eb39919b3da19df4b1c702b00e5f2def9c9d53b3ca9b7e2b6
-DIST vmware-modules-208.2.patch.bz2 7239 SHA256 7b1d16163626b2ea2c1bba82a537368e2f758356580044480994b1fbe0073b47 SHA512 5ace413529025ac384cd2be598a12b7242a8e6518d2ad05dba8f5518f08b28fa9b051b3429fcfacb3a80ac01b4835b00c860418c94ba429c7c8b7f7783b818c4 WHIRLPOOL f64e6138ca482834884d4d7492825efee55560b232184c5d1c1396ca8cedf21674d54e3324559f42aab6f29fb95318ae79bd24beec39782cb605e6790f58da01
diff --git a/app-emulation/vmware-modules/vmware-modules-138.10.7.ebuild b/app-emulation/vmware-modules/vmware-modules-138.10.7.ebuild
deleted file mode 100644
index 1d43989..0000000
--- a/app-emulation/vmware-modules/vmware-modules-138.10.7.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit eutils flag-o-matic linux-mod versionator
-
-DESCRIPTION="VMware kernel modules for vmware server 1.0.x"
-HOMEPAGE="http://www.vmware.com/"
-
-MY_PV=$(get_version_component_range 1-2 "${PV}")
-MY_P=${PN}-${MY_PV}
-GENPATCHES_VER=$(get_version_component_range 3 "${PV}")
-MY_SV=$(get_version_component_range 2 "${PV}")
-SRC_URI="http://ftp.disconnected-by-peer.at/vmware/${MY_P}-genpatches-${GENPATCHES_VER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- =app-emulation/vmware-server-1.0.${MY_SV}*"
-
-S=${WORKDIR}
-
-pkg_setup() {
- linux-mod_pkg_setup
-
- VMWARE_GROUP=${VMWARE_GROUP:-vmware}
-
- VMWARE_MODULE_LIST="vmmon vmnet"
- VMWARE_MOD_DIR="${PF}"
-
- BUILD_TARGETS="auto-build VMWARE_VER=${VMWARE_VER} KERNEL_DIR=${KERNEL_DIR} KBUILD_OUTPUT=${KV_OUT_DIR}"
-
- enewgroup "${VMWARE_GROUP}"
- filter-flags -mfpmath=sse
-
- for mod in ${VMWARE_MODULE_LIST}; do
- MODULE_NAMES="${MODULE_NAMES} ${mod}(misc:${S}/${mod}-only)"
- done
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- for mod in ${VMWARE_MODULE_LIST}; do
- tar -xf /opt/vmware/server/lib/modules/source/${mod}.tar
- done
-}
-
-src_prepare() {
- EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${WORKDIR}/patches" epatch
- sed -i -e '/\smake\s/s/make/$(MAKE)/g' {vmmon,vmnet}-only/Makefile || die "Sed failed."
-
-}
-
-src_install() {
- # this adds udev rules for vmmon*
- if echo ${VMWARE_MODULE_LIST} | grep -q vmmon ; then
- dodir /etc/udev/rules.d
- echo 'KERNEL=="vmmon*", GROUP="'${VMWARE_GROUP}'", MODE=660' >> "${D}/etc/udev/rules.d/60-vmware.rules" || die
- echo 'KERNEL=="vmnet*", GROUP="'${VMWARE_GROUP}'", MODE=660' >> "${D}/etc/udev/rules.d/60-vmware.rules" || die
- fi
-
- linux-mod_src_install
-}
diff --git a/app-emulation/vmware-modules/vmware-modules-208.2.ebuild b/app-emulation/vmware-modules/vmware-modules-208.2.ebuild
deleted file mode 100644
index 4bdbfd1..0000000
--- a/app-emulation/vmware-modules/vmware-modules-208.2.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-1.0.0.24-r3.ebuild,v 1.2 2011/03/16 17:36:57 vadimk Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic linux-mod versionator
-
-PV_MAJOR=$(get_major_version)
-PV_MINOR=$(get_version_component_range 2)
-
-DESCRIPTION="VMware kernel modules"
-HOMEPAGE="http://www.vmware.com/"
-
-SRC_URI="mirror://gentoo/${P}.patch.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- =app-emulation/vmware-server-2.0.${PV_MINOR}*"
-
-S="${WORKDIR}"
-
-pkg_setup() {
- linux-mod_pkg_setup
-
- VMWARE_VER="VME_V65" # THIS VALUE IS JUST A PLACE HOLDER
- VMWARE_GROUP=${VMWARE_GROUP:-vmware}
-
- VMWARE_MODULE_LIST="vmci vmmon vmnet vsock"
- VMWARE_MOD_DIR="${PN}-${PVR}"
-
- BUILD_TARGETS="auto-build VMWARE_VER=${VMWARE_VER} KERNEL_DIR=${KERNEL_DIR} KBUILD_OUTPUT=${KV_OUT_DIR}"
-
- enewgroup "${VMWARE_GROUP}"
- filter-flags -mfpmath=sse
-
- for mod in ${VMWARE_MODULE_LIST}; do
- MODULE_NAMES="${MODULE_NAMES} ${mod}(misc:${S}/${mod}-only)"
- done
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- for mod in ${VMWARE_MODULE_LIST}; do
- tar -xf /opt/vmware/server/lib/modules/source/${mod}.tar
- done
-
-}
-
-src_prepare() {
- epatch "${S}/${P}.patch"
- kernel_is ge 2 6 35 && epatch "${FILESDIR}/${PV_MAJOR}-sk_sleep.patch"
- kernel_is ge 2 6 36 && epatch "${FILESDIR}/${PV_MAJOR}-unlocked_ioctl.patch"
- kernel_is ge 2 6 37 && epatch "${FILESDIR}/${PV_MAJOR}-sema.patch"
-}
-
-src_install() {
- linux-mod_src_install
- local udevrules="${T}/60-vmware.rules"
- cat > "${udevrules}" <<-EOF
- KERNEL=="vmci", GROUP="${VMWARE_GROUP}", MODE=660
- KERNEL=="vmmon", GROUP="${VMWARE_GROUP}", MODE=660
- KERNEL=="vsock", GROUP="${VMWARE_GROUP}", MODE=660
- EOF
- insinto /etc/udev/rules.d/
- doins "${udevrules}"
-}
diff --git a/app-emulation/vmware-modules/vmware-modules-238.6.ebuild b/app-emulation/vmware-modules/vmware-modules-238.6.ebuild
index 2f95c64..930c41a 100644
--- a/app-emulation/vmware-modules/vmware-modules-238.6.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-238.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-238.5.ebuild,v 1.1 2011/10/08 18:04:57 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-238.6.ebuild,v 1.1 2012/06/17 13:09:10 vadimk Exp $
EAPI="4"
diff --git a/app-emulation/vmware-modules/vmware-modules-264.4.ebuild b/app-emulation/vmware-modules/vmware-modules-264.4.ebuild
index b137ff4..6a4edfd 100644
--- a/app-emulation/vmware-modules/vmware-modules-264.4.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-264.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-264.2.ebuild,v 1.1 2012/03/10 14:17:50 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-modules/vmware-modules-264.4.ebuild,v 1.1 2012/06/17 13:09:10 vadimk Exp $
EAPI="4"