summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Rossi <rossi.f@inwind.it>2020-04-11 16:04:23 +0200
committerFabio Rossi <rossi.f@inwind.it>2020-04-11 16:04:23 +0200
commit72d119b3e283024c1d9a9fc5a84651abf7843e13 (patch)
tree76e44359d8ae2441f532be8274899b632c36b95a /app-emulation/vmware-modules
parentapp-emulation/vmware-modules: fixes for kernel 5.4 (diff)
downloadvmware-72d119b3e283024c1d9a9fc5a84651abf7843e13.tar.gz
vmware-72d119b3e283024c1d9a9fc5a84651abf7843e13.tar.bz2
vmware-72d119b3e283024c1d9a9fc5a84651abf7843e13.zip
app-emulation/vmware-modules: changes for kernel 5.5
vsock module needs symbols of the vmci module, the way used to pass extra symbols to the kernel modpost tool has been changed in version >=5.5 Signed-off-by: Fabio Rossi <rossi.f@inwind.it>
Diffstat (limited to 'app-emulation/vmware-modules')
-rw-r--r--app-emulation/vmware-modules/vmware-modules-308.5.9.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-emulation/vmware-modules/vmware-modules-308.5.9.ebuild b/app-emulation/vmware-modules/vmware-modules-308.5.9.ebuild
index aebac67..107bfbf 100644
--- a/app-emulation/vmware-modules/vmware-modules-308.5.9.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-308.5.9.ebuild
@@ -51,11 +51,16 @@ pkg_setup() {
VMWARE_MODULE_LIST_ALL="vmblock vmmon vmnet vmci vsock"
VMWARE_MODULE_LIST="vmblock vmmon vmnet"
use vmci && VMWARE_MODULE_LIST="${VMWARE_MODULE_LIST} vmci"
- use vsock && VMWARE_MODULE_LIST="${VMWARE_MODULE_LIST} vsock"
+ use vsock && VMWARE_MODULE_LIST="${VMWARE_MODULE_LIST} vsock" # vsock must be listed AFTER vmci
VMWARE_MOD_DIR="${PN}-${PVR}"
- BUILD_TARGETS="auto-build KERNEL_DIR=${KERNEL_DIR} KBUILD_OUTPUT=${KV_OUT_DIR}"
+ BUILD_TARGETS="auto-build"
+ BUILD_PARAMS="KERNEL_DIR=${KERNEL_DIR} KBUILD_OUTPUT=${KV_OUT_DIR}"
+ # Since kernel 5.5 (commit 39808e451fdf) the Module.symvers is not read automatically
+ # but an extra parameter KBUILD_EXTRA_SYMBOLS has been defined for that purpose.
+ # Here vsock needs symbols defined by vmci
+ kernel_is ge 5 5 0 && BUILD_PARAMS="${BUILD_PARAMS} KBUILD_EXTRA_SYMBOLS=${S}/Module.symvers"
enewgroup "${VMWARE_GROUP}"