summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Rossi <rossi.f@inwind.it>2019-03-23 18:49:38 +0100
committerFabio Rossi <rossi.f@inwind.it>2019-03-23 18:49:38 +0100
commit747e5fbd28fa2499a18cddc7d7d72e88b010c1fd (patch)
tree47557d17ae9993993e4ddd6a4408c0f23cf0a67a /app-emulation/vmware-player
parentapp-emulation/vmware-modules: add support to kernel 5.0 (diff)
downloadvmware-747e5fbd28fa2499a18cddc7d7d72e88b010c1fd.tar.gz
vmware-747e5fbd28fa2499a18cddc7d7d72e88b010c1fd.tar.bz2
vmware-747e5fbd28fa2499a18cddc7d7d72e88b010c1fd.zip
shipped libgcrypt.so.11 is mandatory now
dev-libs/libgcrypt:11 is going to be removed soon from portage so it cannot be removed from bundled libs anymore. See also bugs #567382 or #656372. Changed also the message to the user clearly stating the security issue!
Diffstat (limited to 'app-emulation/vmware-player')
-rw-r--r--app-emulation/vmware-player/vmware-player-12.5.9.7535481.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/app-emulation/vmware-player/vmware-player-12.5.9.7535481.ebuild b/app-emulation/vmware-player/vmware-player-12.5.9.7535481.ebuild
index 9dd9629..074ec9e 100644
--- a/app-emulation/vmware-player/vmware-player-12.5.9.7535481.ebuild
+++ b/app-emulation/vmware-player/vmware-player-12.5.9.7535481.ebuild
@@ -53,7 +53,6 @@ BUNDLED_LIBS="
libfuse.so.2
libgailutil.so.18
libgcc_s.so.1
- libgcrypt.so.11
libgdk-x11-2.0.so.0
libgdk_pixbuf-2.0.so.0
libgio-2.0.so.0
@@ -85,7 +84,6 @@ BUNDLED_LIB_DEPENDS="
dev-cpp/pangomm
dev-libs/atk
dev-libs/glib:2
- dev-libs/libgcrypt:11/11
dev-libs/libgpg-error
dev-libs/libsigc++:2
dev-libs/libxml2
@@ -368,9 +366,10 @@ pkg_postinst() {
readme.gentoo_print_elog
ewarn "${P} is using an old version of libgcrypt library which"
- ewarn "is going to be soon removed from portage due to security reasons"
- ewarn "(see https://bugs.gentoo.org/show_bug.cgi?id=541564)."
- ewarn "Until vmware is fixed upstream you're exposed to security issues!"
+ ewarn "has been removed from portage due to security reasons"
+ ewarn "(see also bugs #567382 or #656372)."
+ ewarn "This version of vmware is not going to be fixed upstream (EOL)"
+ ewarn "so you're exposed to security issues!"
}
pkg_prerm() {