summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEvan Teran <evan.teran@gmail.com>2016-03-17 23:14:17 -0400
committerEvan Teran <evan.teran@gmail.com>2016-03-17 23:14:17 -0400
commitdf07c010bf6ed8e418d6a677dc181ae89c7b26f7 (patch)
tree61b5a252f81b6d14b2018e63cf9fc4d44cea5490 /app-emulation/vmware-tools/vmware-tools-10.0.5.3228253.ebuild
parentinitial support for vmware-12 (diff)
downloadvmware-df07c010bf6ed8e418d6a677dc181ae89c7b26f7.tar.gz
vmware-df07c010bf6ed8e418d6a677dc181ae89c7b26f7.tar.bz2
vmware-df07c010bf6ed8e418d6a677dc181ae89c7b26f7.zip
app-emulation/vmware-tools: initial support for vmware-12
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-emulation/vmware-tools/vmware-tools-10.0.5.3228253.ebuild')
-rw-r--r--app-emulation/vmware-tools/vmware-tools-10.0.5.3228253.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-emulation/vmware-tools/vmware-tools-10.0.5.3228253.ebuild b/app-emulation/vmware-tools/vmware-tools-10.0.5.3228253.ebuild
new file mode 100644
index 0000000..be67177
--- /dev/null
+++ b/app-emulation/vmware-tools/vmware-tools-10.0.5.3228253.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit versionator vmware-bundle
+
+MY_PV="$(replace_version_separator 3 - $PV)"
+BASE_URI="http://softwareupdate.vmware.com/cds/vmw-desktop/ws/12.1.0/3272444/linux/packages/"
+
+DESCRIPTION="VMware Tools for guest operating systems"
+HOMEPAGE="http://www.vmware.com/products/player/"
+
+LICENSE="vmware"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="mirror"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+IUSE_VMWARE_GUEST="freebsd linux netware solaris windows winPre2k"
+
+VM_INSTALL_DIR="/opt/vmware"
+
+for guest in ${IUSE_VMWARE_GUEST} ; do
+ SRC_URI+=" vmware_guest_${guest}? (
+ amd64? ( ${BASE_URI}vmware-tools-${guest}-${MY_PV}.x86_64.component.tar )
+ )"
+ IUSE+=" vmware_guest_${guest}"
+done ; unset guest
+
+src_unpack() {
+ local arch
+ if use x86 ; then arch='i386'
+ elif use amd64 ; then arch='x86_64'
+ fi
+ local guest ; for guest in ${IUSE_VMWARE_GUEST} ; do
+ if use "vmware_guest_${guest}" ; then
+ local component="vmware-tools-${guest}-${MY_PV}.${arch}.component"
+ unpack "${component}.tar"
+ vmware-bundle_extract-component "${component}"
+ fi
+ done
+}
+
+src_install() {
+ insinto "${VM_INSTALL_DIR}"/lib/vmware/isoimages
+ local somethingdone;
+ local guest ; for guest in ${IUSE_VMWARE_GUEST} ; do
+ if use "vmware_guest_${guest}" ; then
+ doins "${guest}".iso{,.sig}
+ somethingdone=yes
+ fi
+ done
+
+ [ -n "${somethingdone}" ] || ewarn "You should set VMWARE_GUEST in make.conf to specify which operating systems you need."
+}