summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2011-10-05 15:31:07 +0000
committerVadim Kuznetsov <vadimk@gentoo.org>2011-10-05 15:31:07 +0000
commit43bfd613d2f6567e2b11fac43c6bf8e5c0009cf5 (patch)
tree6ff58471d6cec0f6038d83fa97b3873ce6f4f602 /app-emulation/vmware-tools/vmware-tools-8.4.8.491717.ebuild
parentadded VMware Desktop build 491717 (Player 3.1.5, Workstation 7.1.5) (diff)
downloadvmware-43bfd613d2f6567e2b11fac43c6bf8e5c0009cf5.tar.gz
vmware-43bfd613d2f6567e2b11fac43c6bf8e5c0009cf5.tar.bz2
vmware-43bfd613d2f6567e2b11fac43c6bf8e5c0009cf5.zip
added vmware-tools; removed x.1.4; workstation 7.1.5 small fixes
svn path=/trunk/; revision=503
Diffstat (limited to 'app-emulation/vmware-tools/vmware-tools-8.4.8.491717.ebuild')
-rw-r--r--app-emulation/vmware-tools/vmware-tools-8.4.8.491717.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/vmware-tools/vmware-tools-8.4.8.491717.ebuild b/app-emulation/vmware-tools/vmware-tools-8.4.8.491717.ebuild
new file mode 100644
index 0000000..0c8d962
--- /dev/null
+++ b/app-emulation/vmware-tools/vmware-tools-8.4.8.491717.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator vmware-bundle
+
+MY_PV="$(replace_version_separator 3 - $PV)"
+BASE_URI="http://softwareupdate.vmware.com/cds/vmw-desktop/player/3.1.5/491717/linux/packages/"
+
+DESCRIPTION="VMware Tools for guest operating systems"
+HOMEPAGE="http://www.vmware.com/products/player/"
+
+LICENSE="vmware"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="mirror"
+IUSE=""
+
+DEPEND="!<app-emulation/vmware-workstation-7"
+RDEPEND=""
+
+IUSE_VMWARE_GUEST="freebsd linux netware solaris windows winPre2k"
+
+VM_INSTALL_DIR="/opt/vmware"
+
+for guest in ${IUSE_VMWARE_GUEST} ; do
+ SRC_URI+=" vmware_guest_${guest}? (
+ amd64? ( ${BASE_URI}vmware-tools-${guest}-${MY_PV}.x86_64.component.tar )
+ x86? ( ${BASE_URI}vmware-tools-${guest}-${MY_PV}.i386.component.tar )
+ )"
+ IUSE+=" vmware_guest_${guest}"
+done ; unset guest
+
+src_unpack() {
+ local arch
+ if use x86 ; then arch='i386'
+ elif use amd64 ; then arch='x86_64'
+ fi
+ local guest ; for guest in ${IUSE_VMWARE_GUEST} ; do
+ if use "vmware_guest_${guest}" ; then
+ local component="vmware-tools-${guest}-${MY_PV}.${arch}.component"
+ unpack "${component}.tar"
+ vmware-bundle_extract-component "${component}"
+ fi
+ done
+}
+
+src_install() {
+ insinto "${VM_INSTALL_DIR}"/lib/vmware/isoimages
+ local guest ; for guest in ${IUSE_VMWARE_GUEST} ; do
+ if use "vmware_guest_${guest}" ; then
+ doins "${guest}".iso{,.sig}
+ fi
+ done
+}