summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2012-03-02 20:47:04 +0000
committerVadim Kuznetsov <vadimk@gentoo.org>2012-03-02 20:47:04 +0000
commit921c5d96e5946614df0426352b277af6ad0295e1 (patch)
tree6aacea5dc1dc9ef66f16fe53ad0882bd3670970c /app-emulation/vmware-tools/vmware-tools-8.8.2.591240.ebuild
parentVersion bump to VMware desktop build 591240 (diff)
downloadvmware-921c5d96e5946614df0426352b277af6ad0295e1.tar.gz
vmware-921c5d96e5946614df0426352b277af6ad0295e1.tar.bz2
vmware-921c5d96e5946614df0426352b277af6ad0295e1.zip
VMware-tools build 591240
svn path=/trunk/; revision=535
Diffstat (limited to 'app-emulation/vmware-tools/vmware-tools-8.8.2.591240.ebuild')
-rw-r--r--app-emulation/vmware-tools/vmware-tools-8.8.2.591240.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-emulation/vmware-tools/vmware-tools-8.8.2.591240.ebuild b/app-emulation/vmware-tools/vmware-tools-8.8.2.591240.ebuild
new file mode 100644
index 0000000..c8244f7
--- /dev/null
+++ b/app-emulation/vmware-tools/vmware-tools-8.8.2.591240.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator vmware-bundle
+
+MY_PV="$(replace_version_separator 3 - $PV)"
+BASE_URI="http://softwareupdate.vmware.com/cds/vmw-desktop/player/4.0.$(get_version_component_range 3)/$(get_version_component_range 4)/linux/packages/"
+
+DESCRIPTION="VMware Tools for guest operating systems"
+HOMEPAGE="http://www.vmware.com/products/player/"
+
+LICENSE="vmware"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="mirror"
+IUSE=""
+
+DEPEND="!<app-emulation/vmware-workstation-7"
+RDEPEND=""
+
+IUSE_VMWARE_GUEST="freebsd linux netware solaris windows winPre2k"
+
+VM_INSTALL_DIR="/opt/vmware"
+
+for guest in ${IUSE_VMWARE_GUEST} ; do
+ SRC_URI+=" vmware_guest_${guest}? (
+ amd64? ( ${BASE_URI}vmware-tools-${guest}-${MY_PV}.x86_64.component.tar )
+ x86? ( ${BASE_URI}vmware-tools-${guest}-${MY_PV}.i386.component.tar )
+ )"
+ IUSE+=" vmware_guest_${guest}"
+done ; unset guest
+
+src_unpack() {
+ local arch
+ if use x86 ; then arch='i386'
+ elif use amd64 ; then arch='x86_64'
+ fi
+ local guest ; for guest in ${IUSE_VMWARE_GUEST} ; do
+ if use "vmware_guest_${guest}" ; then
+ local component="vmware-tools-${guest}-${MY_PV}.${arch}.component"
+ unpack "${component}.tar"
+ vmware-bundle_extract-component "${component}"
+ fi
+ done
+}
+
+src_install() {
+ insinto "${VM_INSTALL_DIR}"/lib/vmware/isoimages
+ local guest ; for guest in ${IUSE_VMWARE_GUEST} ; do
+ if use "vmware_guest_${guest}" ; then
+ doins "${guest}".iso{,.sig}
+ fi
+ done
+}