summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormattw <mattw@localhost>2011-11-19 12:41:54 +0000
committermattw <mattw@localhost>2011-11-19 12:41:54 +0000
commitea5983b5f3716d3c34decadbaf307e91e3d6fe9f (patch)
tree35c9294eb5c42ec7fd70cb03e80b44c17e9e1d01 /app-emulation/vmware-workstation
parentopen-vm-tools: fixed default network script (diff)
downloadvmware-ea5983b5f3716d3c34decadbaf307e91e3d6fe9f.tar.gz
vmware-ea5983b5f3716d3c34decadbaf307e91e3d6fe9f.tar.bz2
vmware-ea5983b5f3716d3c34decadbaf307e91e3d6fe9f.zip
version bump to VMware desktop build 528992
vmware-modules-264.1.ebuild fails to build for me against sys-kernel/gentoo-sources-3.0.6, so I've removed its keywords until a fix can be found. svn path=/trunk/; revision=514
Diffstat (limited to 'app-emulation/vmware-workstation')
-rw-r--r--app-emulation/vmware-workstation/Manifest3
-rw-r--r--app-emulation/vmware-workstation/vmware-workstation-8.0.1.528992.ebuild489
2 files changed, 492 insertions, 0 deletions
diff --git a/app-emulation/vmware-workstation/Manifest b/app-emulation/vmware-workstation/Manifest
index 4ae02aa..7a64e16 100644
--- a/app-emulation/vmware-workstation/Manifest
+++ b/app-emulation/vmware-workstation/Manifest
@@ -7,6 +7,9 @@ DIST VMware-Workstation-7.1.5-491717.i386.bundle 130351656 RMD160 110bc8a4486bdf
DIST VMware-Workstation-7.1.5-491717.x86_64.bundle 137361206 RMD160 b5f302400a0c33b2bc4a2b68ccc070f9329af047 SHA1 0cca1399008630ed76374d794806d60a93dc3e97 SHA256 857a71e4022a357a49aadc0516dae8909b34abf7a3681fbba5e76d92ee3be90b
DIST VMware-Workstation-Full-8.0.0-471780.i386.bundle 337749469 RMD160 6505d7511ce86f55cff392faa220021c0e5b5e7f SHA1 00a7a255e060fb2883b32c4267b16ad7af204e5c SHA256 6fbdd01c7ee378bc3352b8c230bec0deae352e3aa0e3d0101fe2af3aab6fcff7
DIST VMware-Workstation-Full-8.0.0-471780.x86_64.bundle 337435853 RMD160 ed5881078e7eb60699f6d0180c305f6a240e4360 SHA1 1e75bda32c0dd7aa81d1953464d35236335ddf6e SHA256 6a9099659484a1de2bee50c96ddd3dc1b91c6ab02b067288e1c17c2b6d5a9f9a
+DIST VMware-Workstation-Full-8.0.1-528992.i386.bundle 189608656 RMD160 e08827258f7f5fa80118b65397225bb2f66e1b7f SHA1 f3a78e309a74ba6a9a86bd948db78626009dd3fd SHA256 8bc5a97fae34fcd78084d3b6c74c5c1f71da82dae0e1e68e6a17f9c368a25157
+DIST VMware-Workstation-Full-8.0.1-528992.x86_64.bundle 189359415 RMD160 80ad7822a468ccdae07ba3e06f156a345f0e9e5a SHA1 939a5ae7c8fbeb2a01cae02cb4ed8cc3326ea0d9 SHA256 223b6aaba2bcd2c7976fbc6cbcf9a57fa9cb5cd45d3845986e7e19fccca1acb5
EBUILD vmware-workstation-7.1.5.491717.ebuild 8264 RMD160 a90d1e633561f0d47aa252b63812e6c5e331ee94 SHA1 2a73547f67b10dda1d97d8d1c78f0231ebfdfc9f SHA256 b30027da9c1e27f88eb6edf69a53d38cc1f21e8e6d4b92164f5efea8e7111d2f
EBUILD vmware-workstation-8.0.0.471780-r5.ebuild 13391 RMD160 bbd4d982057794d7772cda62c3f3c099f9054d35 SHA1 ed34dce95df0b771f59dd44c40bd9d9e4952b545 SHA256 5c32643dd2feeed6e2c52ce53404b4e6521200ae3638df65c67b4d3ed4e1612d
+EBUILD vmware-workstation-8.0.1.528992.ebuild 13391 RMD160 e9344cc58ed1f3a432582f8c888949ef4a61485f SHA1 7ab88c1fdf5258b568981e097222afaef5eb8d1b SHA256 92061ed54876676a6331a455bb767b395713a5e7c22583c615fbc1a76c511c78
MISC metadata.xml 821 RMD160 3fe06e26c1f6550712d29d27dbbe1bde8eeb3d29 SHA1 4cacecf9b113a8c46e921e1738d5c191bf693872 SHA256 b5634de5978f816c03495e72d4ee1cb72b372209ee7b8a8e88cec8963aa38647
diff --git a/app-emulation/vmware-workstation/vmware-workstation-8.0.1.528992.ebuild b/app-emulation/vmware-workstation/vmware-workstation-8.0.1.528992.ebuild
new file mode 100644
index 0000000..96812b1
--- /dev/null
+++ b/app-emulation/vmware-workstation/vmware-workstation-8.0.1.528992.ebuild
@@ -0,0 +1,489 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: vadimk Exp $
+
+EAPI="4"
+
+inherit eutils versionator fdo-mime gnome2-utils pam vmware-bundle
+
+MY_PN="VMware-Workstation"
+MY_PV="$(replace_version_separator 3 - $PV)"
+MY_P="${MY_PN}-Full-${MY_PV}"
+
+DESCRIPTION="Emulate a complete PC on your PC without the usual performance overhead of most emulators"
+HOMEPAGE="http://www.vmware.com/products/workstation/"
+SRC_URI="
+ x86? ( ${MY_P}.i386.bundle )
+ amd64? ( ${MY_P}.x86_64.bundle )
+ "
+
+LICENSE="vmware"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="cups doc gnome kde ovftool server vix vmware-tools"
+RESTRICT="binchecks fetch mirror strip"
+
+# vmware-workstation should not use virtual/libc as this is a
+# precompiled binary package thats linked to glibc.
+RDEPEND="dev-cpp/cairomm
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ dev-cpp/libgnomecanvasmm
+ dev-cpp/libsexymm
+ dev-cpp/pangomm
+ dev-libs/atk
+ dev-libs/glib:2
+ dev-libs/icu
+ dev-libs/expat
+ dev-libs/libaio
+ dev-libs/libsigc++
+ dev-libs/libxml2
+ =dev-libs/openssl-0.9.8*
+ dev-libs/xmlrpc-c
+ gnome-base/libgnomecanvas
+ gnome-base/libgtop:2
+ gnome-base/librsvg:2
+ gnome-base/orbit
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libart_lgpl
+ =media-libs/libpng-1.2*
+ media-libs/libpng
+ net-misc/curl
+ cups? ( net-print/cups )
+ sys-devel/gcc
+ sys-fs/fuse
+ sys-libs/glibc
+ sys-libs/zlib
+ x11-libs/cairo
+ gnome? ( x11-libs/gksu )
+ kde? ( kde-base/kdesu )
+ x11-libs/gtk+:2
+ x11-libs/libgksu
+ x11-libs/libICE
+ x11-libs/libsexy
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXft
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/pango
+ x11-libs/startup-notification
+ x11-themes/hicolor-icon-theme
+ !app-emulation/vmware-server
+ !app-emulation/vmware-player"
+PDEPEND="~app-emulation/vmware-modules-264.1
+ vmware-tools? ( app-emulation/vmware-tools )"
+
+S=${WORKDIR}
+VM_INSTALL_DIR="/opt/vmware"
+VM_DATA_STORE_DIR="/var/lib/vmware/Shared VMs"
+VM_HOSTD_USER="root"
+
+pkg_nofetch() {
+ local bundle
+
+ if use x86; then
+ bundle="${MY_P}.i386.bundle"
+ elif use amd64; then
+ bundle="${MY_P}.x86_64.bundle"
+ fi
+
+ einfo "Please download ${bundle}"
+ einfo "from ${HOMEPAGE}"
+ einfo "and place it in ${DISTDIR}"
+}
+
+src_unpack() {
+ local component; for component in \
+ vmware-vmx \
+ vmware-player-app \
+ vmware-player-setup \
+ vmware-workstation \
+ vmware-network-editor \
+ vmware-network-editor-ui \
+ vmware-usbarbitrator
+ do
+ vmware-bundle_extract-bundle-component "${DISTDIR}/${A}" "${component}" "${S}"
+ done
+
+ if use server; then
+ vmware-bundle_extract-bundle-component "${DISTDIR}/${A}" vmware-workstation-server #"${S}"
+ fi
+
+ if use vix; then
+ vmware-bundle_extract-bundle-component "${DISTDIR}/${A}" vmware-vix-core vmware-vix
+ vmware-bundle_extract-bundle-component "${DISTDIR}/${A}" vmware-vix-lib-Workstation800andvSphere500 vmware-vix
+ fi
+ if use ovftool; then
+ vmware-bundle_extract-bundle-component "${DISTDIR}/${A}" vmware-ovftool
+ fi
+
+}
+
+src_prepare() {
+ rm -f bin/vmware-modconfig
+ rm -rf lib/modules/binary
+ if use server; then
+ rm -f vmware-workstation-server/bin/{openssl,configure-hostd.sh}
+ fi
+
+ find "${S}" -name '*.a' -delete
+
+# clean_bundled_libs
+}
+
+clean_bundled_libs() {
+ ebegin 'Removing superfluous libraries'
+ cd lib/lib || die
+ ldconfig -p | \
+ sed 's:^\s\+\([^(]*[^( ]\).*=> /.*$:\1:g;t;d' | \
+ fgrep -vx 'libcrypto.so.0.9.8
+libssl.so.0.9.8i
+libgcr.so.0
+libglib-2.0.so.0' |
+ xargs -d'\n' -r rm -rf
+ eend
+}
+
+src_install() {
+ local major_minor=$(get_version_component_range 1-2 "${PV}")
+ local major_minor_revision=$(get_version_component_range 1-3 "${PV}")
+ local build=$(get_version_component_range 4 "${PV}")
+
+ # install the binaries
+ into "${VM_INSTALL_DIR}"
+ dobin bin/*
+
+ # install the libraries
+ insinto "${VM_INSTALL_DIR}"/lib/vmware
+ doins -r lib/*
+
+ # install the ancillaries
+ insinto /usr
+ doins -r share
+
+ if use cups; then
+ exeinto $(cups-config --serverbin)/filter
+ doexe extras/thnucups
+
+ insinto /etc/cups
+ doins -r etc/cups/*
+ fi
+
+ insinto /etc/xdg
+ doins -r etc/xdg/*
+
+ # install documentation
+ doman man/man1/vmware.1.gz
+
+ if use doc; then
+ dodoc doc/*
+ fi
+
+ insinto "${VM_INSTALL_DIR}"/lib/vmware/setup
+ doins vmware-config
+
+ # install vmware workstation server
+ if use server; then
+ dosbin sbin/*
+
+ cd "${S}"/vmware-workstation-server
+
+ # install binaries
+ into "${VM_INSTALL_DIR}"/lib/vmware
+ dobin bin/*
+
+ # install the libraries
+ insinto "${VM_INSTALL_DIR}"/lib/vmware/lib
+ doins -r lib/*
+
+ into "${VM_INSTALL_DIR}"
+ for tool in vmware-{hostd,vim-cmd,adminTool} ; do
+ cat > "${T}/${tool}" <<-EOF
+ #!/usr/bin/env bash
+ set -e
+
+ . /etc/vmware/bootstrap
+
+ exec "${VM_INSTALL_DIR}/lib/vmware/lib/wrapper-gtk24.sh" \\
+ "${VM_INSTALL_DIR}/lib/vmware/lib" \\
+ "${VM_INSTALL_DIR}/lib/vmware/bin/${tool}" \\
+ "${VM_INSTALL_DIR}/lib/vmware/libconf" "\$@"
+ EOF
+ dobin "${T}/${tool}"
+ done
+
+ insinto "${VM_INSTALL_DIR}"/lib/vmware
+ doins -r hostd
+
+ # create the configuration
+ insinto /etc/vmware/hostd
+ doins -r config/etc/vmware/hostd/*
+ doins -r etc/vmware/hostd/*
+
+ insinto /etc/vmware/ssl
+ doins etc/vmware/ssl/*
+
+ # pam
+ pamd_mimic_system vmware-authd auth account
+
+ # create directory for shared virtual machines.
+ keepdir "${VM_DATA_STORE_DIR}"
+ keepdir /var/log/vmware
+ fi
+
+ # install vmware-vix
+ if use vix; then
+ cd "${S}"/vmware-vix
+
+ # install the binary
+ into "${VM_INSTALL_DIR}"
+ dobin bin/*
+
+ # install the libraries
+ insinto "${VM_INSTALL_DIR}"/lib/vmware-vix
+ doins -r lib/*
+
+ dosym vmware-vix/libvixAllProducts.so "${VM_INSTALL_DIR}"/lib/libbvixAllProducts.so
+
+ # install headers
+ insinto /usr/include/vmware-vix
+ doins include/*
+
+ if use doc; then
+ dohtml -r doc/*
+ fi
+ fi
+
+ # install ovftool
+ if use ovftool; then
+ cd "${S}"
+
+ insinto "${VM_INSTALL_DIR}"/lib/vmware-ovftool
+ doins -r vmware-ovftool/*
+
+ chmod 0755 "${D}${VM_INSTALL_DIR}"/lib/vmware-ovftool/{ovftool,ovftool.bin}
+ dosym "${D}${VM_INSTALL_DIR}"/lib/vmware-ovftool/ovftool "${VM_INSTALL_DIR}"/bin/ovftool
+ fi
+
+ # create symlinks for the various tools
+ local tool ; for tool in thnuclnt vmware vmplayer{,-daemon} \
+ vmware-{acetool,enter-serial,gksu,fuseUI,modconfig{,-console},netcfg,tray,unity-helper} ; do
+ dosym appLoader "${VM_INSTALL_DIR}"/lib/vmware/bin/"${tool}"
+ done
+ dosym "${VM_INSTALL_DIR}"/lib/vmware/bin/vmplayer "${VM_INSTALL_DIR}"/bin/vmplayer
+ dosym "${VM_INSTALL_DIR}"/lib/vmware/bin/vmware "${VM_INSTALL_DIR}"/bin/vmware
+ dosym "${VM_INSTALL_DIR}"/lib/vmware/icu /etc/vmware/icu
+
+ # fixing gksu problem
+ if use gnome; then
+ rm "${D}${VM_INSTALL_DIR}"/bin/vmware-gksu
+ dosym /usr/bin/gksu "${VM_INSTALL_DIR}"/bin/vmware-gksu
+ fi
+ if use kde; then
+ rm "${D}${VM_INSTALL_DIR}"/bin/vmware-gksu
+ dosym /usr/bin/kdesu "${VM_INSTALL_DIR}"/bin/vmware-gksu
+ fi
+
+ # fix up permissions
+ chmod 0755 "${D}${VM_INSTALL_DIR}"/lib/vmware/{bin/*,lib/wrapper-gtk24.sh,lib/libgksu2.so.0/gksu-run-helper,setup/*}
+ chmod 04711 "${D}${VM_INSTALL_DIR}"/bin/vmware-mount
+ if use server; then
+ chmod 04711 "${D}${VM_INSTALL_DIR}"/sbin/vmware-authd
+ fi
+ chmod 04711 "${D}${VM_INSTALL_DIR}"/lib/vmware/bin/vmware-vmx*
+
+ if use vix; then
+ chmod 0755 "${D}${VM_INSTALL_DIR}"/lib/vmware-vix/setup/*
+ fi
+
+ # create the environment
+ local envd="${T}/90vmware"
+ cat > "${envd}" <<-EOF
+ PATH='${VM_INSTALL_DIR}/bin'
+ ROOTPATH='${VM_INSTALL_DIR}/bin'
+ EOF
+ doenvd "${envd}"
+
+ # create the configuration
+ dodir /etc/vmware
+
+ cat > "${D}"/etc/vmware/bootstrap <<-EOF
+ BINDIR='${VM_INSTALL_DIR}/bin'
+ LIBDIR='${VM_INSTALL_DIR}/lib'
+ EOF
+
+ cat > "${D}"/etc/vmware/config <<-EOF
+ bindir = "${VM_INSTALL_DIR}/bin"
+ libdir = "${VM_INSTALL_DIR}/lib/vmware"
+ initscriptdir = "/etc/init.d"
+ authd.fullpath = "${VM_INSTALL_DIR}/sbin/vmware-authd"
+ gksu.rootMethod = "su"
+ VMCI_CONFED = "yes"
+ VMBLOCK_CONFED = "yes"
+ VSOCK_CONFED = "yes"
+ NETWORKING = "yes"
+ player.product.version = "${major_minor_revision}"
+ product.version = "${major_minor_revision}"
+ product.buildNumber = "${build}"
+ product.name = "VMware Workstation"
+ workstation.product.version = "${major_minor_revision}"
+ EOF
+
+ if use vix; then
+ cat >> "${D}"/etc/vmware/config <<-EOF
+ vmware.fullpath = "${VM_INSTALL_DIR}/bin/vmware"
+ vix.libdir = "${VM_INSTALL_DIR}/lib/vmware-vix"
+ vix.config.version = "1"
+ EOF
+ fi
+
+ if use server; then
+ cat >> "${D}"/etc/vmware/config <<-EOF
+ authd.client.port = "902"
+ authd.proxy.nfc = "vmware-hostd:ha-nfc"
+ authd.soapserver = "TRUE"
+ EOF
+ fi
+
+ # install the init.d script
+ local initscript="${T}/vmware.rc"
+ sed -e "s:@@BINDIR@@:${VM_INSTALL_DIR}/bin:g" \
+ "${FILESDIR}/vmware-${major_minor}.rc" > ${initscript}
+ newinitd "${initscript}" vmware
+
+ if use server; then
+ # install the init.d script
+ local initscript="${T}/vmware-workstation-server.rc"
+ sed -e "s:@@ETCDIR@@:/etc/vmware:g" \
+ -e "s:@@PREFIX@@:${VM_INSTALL_DIR}:g" \
+ -e "s:@@BINDIR@@:${VM_INSTALL_DIR}/bin:g" \
+ -e "s:@@LIBDIR@@:${VM_INSTALL_DIR}/lib/vmware:g" \
+ "${FILESDIR}/vmware-server-8.0.rc" > ${initscript}
+ newinitd "${initscript}" vmware-workstation-server
+ fi
+
+ # fill in variable placeholders
+ sed -e "s:@@LIBCONF_DIR@@:${VM_INSTALL_DIR}/lib/vmware/libconf:g" \
+ -i "${D}${VM_INSTALL_DIR}"/lib/vmware/libconf/etc/{gtk-2.0/{gdk-pixbuf.loaders,gtk.immodules},pango/pango{.modules,rc}}
+ sed -e "s:@@BINARY@@:${VM_INSTALL_DIR}/bin/vmware:g" \
+ -i "${D}/usr/share/applications/${PN}.desktop"
+ sed -e "s:@@BINARY@@:${VM_INSTALL_DIR}/bin/vmplayer:g" \
+ -i "${D}/usr/share/applications/vmware-player.desktop"
+ sed -e "s:@@BINARY@@:${VM_INSTALL_DIR}/bin/vmware-netcfg:g" \
+ -i "${D}/usr/share/applications/vmware-netcfg.desktop"
+
+ if use server; then
+ # Configuration for vmware-workstation-server
+ local hostdUser="${VM_HOSTD_USER:-root}"
+ sed -e "/ACEDataUser/s:root:${hostdUser}:g" \
+ -i "${D}/etc/vmware/hostd/authorization.xml" || die
+
+ # Shared VMs Path: [standard].
+ sed -e "s:##{DS_NAME}##:standard:g" \
+ -e "s:##{DS_PATH}##:${VM_DATA_STORE_DIR}:g" \
+ -i "${D}/etc/vmware/hostd/datastores.xml" || die
+
+ sed -e "s:##{HTTP_PORT}##:-1:g" \
+ -e "s:##{HTTPS_PORT}##:443:g" \
+ -e "s:##{PIPE_PREFIX}##:/var/run/vmware/:g" \
+ -i "${D}/etc/vmware/hostd/proxy.xml" || die
+
+ # See vmware-workstation-server.py for more details.
+ sed -e "s:##{BUILD_CFGDIR}##:/etc/vmware/hostd/:g" \
+ -e "s:##{CFGALTDIR}##:/etc/vmware/hostd/:g" \
+ -e "s:##{CFGDIR}##:/etc/vmware/:g" \
+ -e "s:##{ENABLE_AUTH}##:true:g" \
+ -e "s:##{HOSTDMODE}##:ws:g" \
+ -e "s:##{HOSTD_CFGDIR}##:/etc/vmware/hostd/:g" \
+ -e "s:##{HOSTD_MOCKUP}##:false:g" \
+ -e "s:##{LIBDIR}##:${VM_INSTALL_DIR}/lib/vmware:g" \
+ -e "s:##{LIBDIR_INSTALLED}##:${VM_INSTALL_DIR}/lib/vmware/:g" \
+ -e "s:##{LOGDIR}##:/var/log/vmware/:g" \
+ -e "s:##{LOGLEVEL}##:verbose:g" \
+ -e "s:##{MOCKUP}##:mockup-host-config.xml:g" \
+ -e "s:##{PLUGINDIR}##:./:g" \
+ -e "s:##{SHLIB_PREFIX}##:lib:g" \
+ -e "s:##{SHLIB_SUFFIX}##:.so:g" \
+ -e "s:##{USE_BLKLISTSVC}##:false:g" \
+ -e "s:##{USE_CBRCSVC}##:false:g" \
+ -e "s:##{USE_CIMSVC}##:false:g" \
+ -e "s:##{USE_DIRECTORYSVC}##:false:g" \
+ -e "s:##{USE_DIRECTORYSVC_MOCKUP}##:false:g" \
+ -e "s:##{USE_DYNAMIC_PLUGIN_LOADING}##:false:g" \
+ -e "s:##{USE_DYNAMO}##:false:g" \
+ -e "s:##{USE_DYNSVC}##:false:g" \
+ -e "s:##{USE_GUESTSVC}##:false:g" \
+ -e "s:##{USE_HBRSVC}##:false:g" \
+ -e "s:##{USE_HBRSVC_MOCKUP}##:false:g" \
+ -e "s:##{USE_HOSTSVC_MOCKUP}##:false:g" \
+ -e "s:##{USE_HTTPNFCSVC}##:false:g" \
+ -e "s:##{USE_HTTPNFCSVC_MOCKUP}##:false:g" \
+ -e "s:##{USE_LICENSESVC_MOCKUP}##:false:g" \
+ -e "s:##{USE_NFCSVC}##:true:g" \
+ -e "s:##{USE_NFCSVC_MOCKUP}##:false:g" \
+ -e "s:##{USE_OVFMGRSVC}##:true:g" \
+ -e "s:##{USE_PARTITIONSVC}##:false:g" \
+ -e "s:##{USE_SECURESOAP}##:false:g" \
+ -e "s:##{USE_SNMPSVC}##:false:g" \
+ -e "s:##{USE_SOLO_MOCKUP}##:false:g" \
+ -e "s:##{USE_STATSSVC_MOCKUP}##:false:g" \
+ -e "s:##{USE_VCSVC_MOCKUP}##:false:g" \
+ -e "s:##{USE_VDISKSVC}##:false:g" \
+ -e "s:##{USE_VDISKSVC_MOCKUP}##:false:g" \
+ -e "s:##{USE_VMSVC_MOCKUP}##:false:g" \
+ -e "s:##{VM_INVENTORY}##:vmInventory.xml:g" \
+ -e "s:##{VM_RESOURCES}##:vmResources.xml:g" \
+ -e "s:##{WEBSERVER_PORT_ENTRY}##::g" \
+ -e "s:##{WORKINGDIR}##:./:g" \
+ -i "${D}/etc/vmware/hostd/config.xml" || die
+
+ sed -e "s:##{ENV_LOCATION}##:/etc/vmware/hostd/env/:g" \
+ -i "${D}/etc/vmware/hostd/environments.xml" || die
+
+ # @@VICLIENT_URL@@=XXX
+ sed -e "s:@@AUTHD_PORT@@:902:g" \
+ -i "${D}${VM_INSTALL_DIR}/lib/vmware/hostd/docroot/client/clients.xml" || die
+ fi
+}
+
+pkg_config() {
+ "${VM_INSTALL_DIR}"/bin/vmware-networks --postinstall ${PN},old,new
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+
+ ewarn "/etc/env.d was updated. Please run:"
+ ewarn "env-update && source /etc/profile"
+ ewarn ""
+ ewarn "Before you can use vmware workstation, you must configure a default network setup."
+ ewarn "You can do this by running 'emerge --config ${PN}'."
+}
+
+pkg_prerm() {
+ einfo "Stopping ${PN} for safe unmerge"
+ /etc/init.d/vmware stop
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}