summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2011-04-19 13:39:02 +0000
committerVadim Kuznetsov <vadimk@gentoo.org>2011-04-19 13:39:02 +0000
commit336ac3c27cd63fd5f53a2d61a879ef572ec17848 (patch)
tree18fed9583b236c9470d77a7643a2d7ef9cca7c5e /app-emulation
parentcleanup (diff)
downloadvmware-336ac3c27cd63fd5f53a2d61a879ef572ec17848.tar.gz
vmware-336ac3c27cd63fd5f53a2d61a879ef572ec17848.tar.bz2
vmware-336ac3c27cd63fd5f53a2d61a879ef572ec17848.zip
work in progress
svn path=/trunk/; revision=476
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vmware-vsphere-cli/ChangeLog11
-rw-r--r--app-emulation/vmware-vsphere-cli/Manifest6
-rw-r--r--app-emulation/vmware-vsphere-cli/files/makefile.patch48
-rw-r--r--app-emulation/vmware-vsphere-cli/metadata.xml17
-rw-r--r--app-emulation/vmware-vsphere-cli/vmware-vsphere-cli-4.1.0.254719.ebuild141
5 files changed, 223 insertions, 0 deletions
diff --git a/app-emulation/vmware-vsphere-cli/ChangeLog b/app-emulation/vmware-vsphere-cli/ChangeLog
new file mode 100644
index 0000000..7e9bf35
--- /dev/null
+++ b/app-emulation/vmware-vsphere-cli/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emulation/vmware-vsphere-cli
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*vmware-vsphere-cli-4.1.0.254719 (19 Apr 2011)
+
+ 19 Apr 2011; Vadim Kuznetsov <vadimk@gentoo.org>
+ +vmware-vsphere-cli-4.1.0.254719.ebuild, +files/makefile.patch,
+ +metadata.xml:
+ initial ebuild. work in progress
+
diff --git a/app-emulation/vmware-vsphere-cli/Manifest b/app-emulation/vmware-vsphere-cli/Manifest
new file mode 100644
index 0000000..5aa1896
--- /dev/null
+++ b/app-emulation/vmware-vsphere-cli/Manifest
@@ -0,0 +1,6 @@
+AUX makefile.patch 1128 RMD160 4181310858c3f291c2dba931a211cd4f1f17ef62 SHA1 06745c752f69b4a60a08769fe03141612da3cb29 SHA256 6c700f94685f7a6a273528fbabb1770ad550af92a0c72aa62bb3302cffac442a
+DIST VMware-vSphere-CLI-4.1.0-254719.i386.tar.gz 24109045 RMD160 a13cd6dc51c39665332eb0d3439275b0355b028f SHA1 bd125b1d47a4e3a1d4eff9eccdfbe49bb1df9c0f SHA256 261fa3651e8bbfb3da030b49434aaff6891779ca66af0273d434575b47d7ea7c
+DIST VMware-vSphere-CLI-4.1.0-254719.x86_64.tar.gz 23896345 RMD160 81ce63a51335954e804807bec9ea9d3818b125e9 SHA1 8c2874af4ac3a98549cdcab0bf2e1c60f670682d SHA256 78e0bddd734a35ba18f2737ea9a748097f6f8ca044a8ef00f86746cf69332396
+EBUILD vmware-vsphere-cli-4.1.0.254719.ebuild 3161 RMD160 f8907149a2758935ae018c938261984a5420de50 SHA1 90a3b360a97bb8b7bc6ea89204c24acc7bbfee53 SHA256 b5cc9f2ba92c82776207edf79b8eb6e44c141c2eb344b1b09f1618557eca1b8e
+MISC ChangeLog 351 RMD160 b5b6bcea3bc08c7a9a8dc34fcd683036c13cdcab SHA1 1d93a85d18325fc997c514ff10a7fc9697932c12 SHA256 d98e505e17236a2c2739421008c93efdb92c6b29a25e87b4ad775cd66bad9ef2
+MISC metadata.xml 723 RMD160 ea2d0941a2bfd064527fdf79b1a8e2f0b2671f8c SHA1 4cd898d707882a4d857998237b4f57c3f4aeddd3 SHA256 1dbc89531a7ef3744ca56bb0769638ace5871c9db36abc37ac046ed383171b9e
diff --git a/app-emulation/vmware-vsphere-cli/files/makefile.patch b/app-emulation/vmware-vsphere-cli/files/makefile.patch
new file mode 100644
index 0000000..1afd873
--- /dev/null
+++ b/app-emulation/vmware-vsphere-cli/files/makefile.patch
@@ -0,0 +1,48 @@
+diff --git a/Makefile.PL b/Makefile.PL
+index 046e794..429dc42 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -81,43 +81,5 @@ WriteMakefile(
+ # /usr/bin/perl, and attempt to find a reasonable spot if you
+ # are running some other perl.
+ #
+- macro => {
+- # vmware apps
+- INST_VMWARE_APPS => 'apps',
+- DEST_VMWARE_APPS => (
+- $Config{perlpath} eq '/usr/bin/perl' ?
+- '/usr/lib/vmware-viperl/apps' :
+- '$(INSTALLSITESCRIPT)/apps'
+- ),
+- # vmware docs
+- INST_VMWARE_DOC => 'doc',
+- DEST_VMWARE_DOC => (
+- $Config{perlpath} eq '/usr/bin/perl' ?
+- '/usr/share/doc/vmware-viperl/doc' :
+- '$(SITEPREFIX)/doc'
+- ),
+- },
+ );
+
+-#
+-# Additional targets for installing apps and doc.
+-#
+-sub MY::postamble {
+- return <<'MAKE';
+-install :: install_vmware_apps install_vmware_doc
+- $(NOECHO) $(NOOP)
+-
+-install_vmware_apps :
+- $(NOECHO) $(MOD_INSTALL) \
+- $(INST_VMWARE_APPS) $(DEST_VMWARE_APPS)
+-
+-install_vmware_doc :
+- $(NOECHO) $(MOD_INSTALL) \
+- $(INST_VMWARE_DOC) $(DEST_VMWARE_DOC)
+-
+-clean ::
+- $(RM_RF) VMware WSMan
+-
+-MAKE
+-}
+-
diff --git a/app-emulation/vmware-vsphere-cli/metadata.xml b/app-emulation/vmware-vsphere-cli/metadata.xml
new file mode 100644
index 0000000..2c9f073
--- /dev/null
+++ b/app-emulation/vmware-vsphere-cli/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vmware</herd>
+ <maintainer>
+ <email>vadimk@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ The vSphere Command-Line Interface (vSphere CLI) command set allows you
+ to run common system administration commands against ESX/ESXi systems
+ from any machine with network access to those systems. You can also run
+ most vSphere CLI commands against a vCenter Server system and target any
+ ESX/ESXi system that vCenter Server system manages. vSphere CLI commands
+ are especially useful for ESXi hosts because ESXi does not include a
+ service console.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-emulation/vmware-vsphere-cli/vmware-vsphere-cli-4.1.0.254719.ebuild b/app-emulation/vmware-vsphere-cli/vmware-vsphere-cli-4.1.0.254719.ebuild
new file mode 100644
index 0000000..e3a06bb
--- /dev/null
+++ b/app-emulation/vmware-vsphere-cli/vmware-vsphere-cli-4.1.0.254719.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Unlike many other binary packages the user doesn't need to agree to a licence
+# to download VMWare. The agreeing to a licence is part of the configure step
+# which the user must run manually.
+
+EAPI="2"
+
+inherit eutils perl-module versionator
+
+MY_PV=$(replace_version_separator 3 '-' )
+MY_PN="VMware-vSphere-CLI-${MY_PV}"
+
+DESCRIPTION="VMware vSphere Command-Line Interface"
+HOMEPAGE="http://www.vmware.com/"
+SRC_URI=" x86? ( mirror://vmware/software/vmserver/${MY_PN}.i386.tar.gz )
+ amd64? ( mirror://vmware/software/vmserver/${MY_PN}.x86_64.tar.gz ) "
+
+LICENSE="vmware"
+IUSE=""
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+RESTRICT="strip"
+
+DEPEND="
+ >=dev-lang/perl-5
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/libxml2
+ dev-libs/openssl
+ dev-perl/Archive-Zip
+ dev-perl/Class-MethodMaker
+ dev-perl/Crypt-SSLeay
+ dev-perl/Data-Dump
+ dev-perl/Data-Dumper-Concise
+ dev-perl/HTML-Parser
+ dev-perl/SOAP-Lite
+ dev-perl/URI
+ dev-perl/Data-UUID
+ dev-perl/XML-LibXML
+ dev-perl/XML-NamespaceSupport
+ dev-perl/XML-SAX
+ dev-perl/libwww-perl
+ dev-perl/libxml-perl
+ perl-core/Compress-Raw-Zlib
+ perl-core/IO-Compress
+ perl-core/version
+ sys-fs/e2fsprogs
+ sys-libs/zlib"
+# !app-emulation/vmware-server
+# !app-emulation/vmware-vix
+# !app-emulation/vmware-workstation"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}-distrib
+
+pkg_setup() {
+ if use x86; then
+ MY_P="${MY_PN}.i386"
+ elif use amd64; then
+ MY_P="${MY_PN}.x86_64"
+ fi
+}
+
+src_prepare() {
+ VMWARE_GROUP=${VMWARE_GROUP:-vmware}
+ VMWARE_INSTALL_DIR=/opt/${PN//-//}
+
+ shortname="vcli"
+ product="vmware-vcli"
+ config_dir="/etc/vmware-vcli"
+ product_name="vSphere CLI"
+
+ enewgroup ${VMWARE_GROUP}
+
+ sed -i.bak -e "s:/sbin/lsmod:/bin/lsmod:" "${S}"/installer/services.sh || die "sed of services"
+
+ # We won't want any perl scripts from VMware
+ rm -f *.pl bin/*.pl
+ rm -f etc/installer.sh
+
+ epatch "${FILESDIR}"/makefile.patch
+
+ perl-module_src_prepare || die
+}
+
+src_install() {
+ # We loop through our directories and copy everything to our system.
+ for x in apps bin
+ do
+ if [[ -e "${S}"/${x} ]]
+ then
+ dodir "${VMWARE_INSTALL_DIR}"/${x}
+ cp -pPR "${S}"/${x}/* "${D}""${VMWARE_INSTALL_DIR}"/${x} || die "copying ${x}"
+ fi
+ done
+
+ perl-module_src_install || die
+
+ # init script
+ if [[ -e "${FILESDIR}/${PN}.rc" ]]
+ then
+ newinitd "${FILESDIR}"/${PN}.rc ${product} || die "newinitd"
+ fi
+
+ # create the environment
+ local envd="${T}/90vmware-cli"
+ cat > "${envd}" <<-EOF
+ PATH='${VMWARE_INSTALL_DIR}/bin'
+ ROOTPATH='${VMWARE_INSTALL_DIR}/bin'
+ EOF
+ doenvd "${envd}"
+
+ # Last, we check for any mime files.
+ if [[ -e "${FILESDIR}/${PN}.xml" ]]
+ then
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/${PN}.xml || die "mimetypes"
+ fi
+
+ if [[ -e doc/EULA ]]
+ then
+ insinto "${VMWARE_INSTALL_DIR}"/doc
+ doins doc/EULA || die "copying EULA"
+ fi
+
+ doman man/*
+
+ # create the configuration
+ #dodir "${config_dir}"
+
+}
+
+pkg_postinst() {
+ [[ -d "${config_dir}" ]] && chown -R root:${VMWARE_GROUP} ${config_dir}
+
+ ewarn "In order to run ${product_name}, you have to"
+ ewarn "be in the '${VMWARE_GROUP}' group."
+}