summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2012-05-22 09:28:42 -0400
committerVadim Kuznetsov <vadimk@gentoo.org>2012-05-22 09:28:42 -0400
commitf366d6993fa2b058d6a15d3ccdaed45de7b70639 (patch)
treee54d29a8a67b908f8385494adc3d832f412ec774 /app-emulation
parentbump vmware-tools to 8.8.2.703057 (diff)
downloadvmware-f366d6993fa2b058d6a15d3ccdaed45de7b70639.tar.gz
vmware-f366d6993fa2b058d6a15d3ccdaed45de7b70639.tar.bz2
vmware-f366d6993fa2b058d6a15d3ccdaed45de7b70639.zip
d_make_root patch for 3.4 kernel. Bug 411853.
new file: app-emulation/vmware-modules/files/264-d-make-root.patch modified: app-emulation/vmware-modules/vmware-modules-264.3.ebuild
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vmware-modules/files/264-d-make-root.patch16
-rw-r--r--app-emulation/vmware-modules/vmware-modules-264.3.ebuild1
2 files changed, 17 insertions, 0 deletions
diff --git a/app-emulation/vmware-modules/files/264-d-make-root.patch b/app-emulation/vmware-modules/files/264-d-make-root.patch
new file mode 100644
index 0000000..a02e4ce
--- /dev/null
+++ b/app-emulation/vmware-modules/files/264-d-make-root.patch
@@ -0,0 +1,16 @@
+diff --git a/vmblock-only/linux/filesystem.c b/vmblock-only/linux/filesystem.c
+index b7c535e..a36a01e 100644
+--- a/vmblock-only/linux/filesystem.c
++++ b/vmblock-only/linux/filesystem.c
+@@ -525,7 +525,11 @@ FsOpReadSuper(struct super_block *sb, // OUT: Superblock object
+ return -EINVAL;
+ }
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 4, 0)
+ rootDentry = d_alloc_root(rootInode);
++#else
++ rootDentry = d_make_root(rootInode);
++#endif
+ if (!rootDentry) {
+ iput(rootInode);
+ return -ENOMEM;
diff --git a/app-emulation/vmware-modules/vmware-modules-264.3.ebuild b/app-emulation/vmware-modules/vmware-modules-264.3.ebuild
index afef047..763796d 100644
--- a/app-emulation/vmware-modules/vmware-modules-264.3.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-264.3.ebuild
@@ -66,6 +66,7 @@ src_prepare() {
epatch "${FILESDIR}/${PV_MAJOR}-3.2.0.patch"
use pax_kernel && epatch "${FILESDIR}/hardened.patch"
epatch "${FILESDIR}/${PV_MAJOR}-apic.patch"
+ epatch "${FILESDIR}/${PV_MAJOR}-d-make-root.patch"
}
src_install() {