summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/vmware-modules/files/238-d-make-root.patch14
-rw-r--r--app-emulation/vmware-modules/vmware-modules-238.5-r1.ebuild1
2 files changed, 15 insertions, 0 deletions
diff --git a/app-emulation/vmware-modules/files/238-d-make-root.patch b/app-emulation/vmware-modules/files/238-d-make-root.patch
new file mode 100644
index 0000000..7e83a1e
--- /dev/null
+++ b/app-emulation/vmware-modules/files/238-d-make-root.patch
@@ -0,0 +1,14 @@
+--- a/vmblock-only/linux/filesystem.c 2012-05-23 20:08:00.632051396 -0500
++++ b/vmblock-only/linux/filesystem.c 2012-05-23 20:17:00.896297163 -0500
+@@ -517,7 +517,11 @@
+ return -EINVAL;
+ }
+
++#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 4, 0)
+ rootDentry = d_alloc_root(rootInode);
++#else
++ rootDentry = d_make_root(rootInode);
++#endif
+ if (!rootDentry) {
+ iput(rootInode);
+ return -ENOMEM;
diff --git a/app-emulation/vmware-modules/vmware-modules-238.5-r1.ebuild b/app-emulation/vmware-modules/vmware-modules-238.5-r1.ebuild
index 2f8a6d7..fdfcc9d 100644
--- a/app-emulation/vmware-modules/vmware-modules-238.5-r1.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-238.5-r1.ebuild
@@ -66,6 +66,7 @@ src_prepare() {
kernel_is ge 2 6 39 && epatch "${FILESDIR}/${PV_MAJOR}-2.6.39.patch"
epatch "${FILESDIR}/${PV_MAJOR}-netdevice.patch"
epatch "${FILESDIR}/${PV_MAJOR}-3.2.0.patch"
+ epatch "${FILESDIR}/${PV_MAJOR}-d-make-root.patch"
}
src_install() {