summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/vmware-modules/files/304-4.7-00-trans_start.patch11
-rw-r--r--app-emulation/vmware-modules/files/308-4.07-00-trans_start.patch11
-rw-r--r--app-emulation/vmware-modules/vmware-modules-304.3-r1.ebuild1
-rw-r--r--app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild1
4 files changed, 24 insertions, 0 deletions
diff --git a/app-emulation/vmware-modules/files/304-4.7-00-trans_start.patch b/app-emulation/vmware-modules/files/304-4.7-00-trans_start.patch
new file mode 100644
index 0000000..751924f
--- /dev/null
+++ b/app-emulation/vmware-modules/files/304-4.7-00-trans_start.patch
@@ -0,0 +1,11 @@
+--- ./vmnet-only/netif.c.old 2016-05-19 20:13:14.259914206 +0200
++++ ./vmnet-only/netif.c 2016-05-19 20:13:21.250914596 +0200
+@@ -465,7 +465,7 @@
+ VNetSend(&netIf->port.jack, skb);
+
+ netIf->stats.tx_packets++;
+- dev->trans_start = jiffies;
++ netif_trans_update(dev);
+
+ return 0;
+ }
diff --git a/app-emulation/vmware-modules/files/308-4.07-00-trans_start.patch b/app-emulation/vmware-modules/files/308-4.07-00-trans_start.patch
new file mode 100644
index 0000000..751924f
--- /dev/null
+++ b/app-emulation/vmware-modules/files/308-4.07-00-trans_start.patch
@@ -0,0 +1,11 @@
+--- ./vmnet-only/netif.c.old 2016-05-19 20:13:14.259914206 +0200
++++ ./vmnet-only/netif.c 2016-05-19 20:13:21.250914596 +0200
+@@ -465,7 +465,7 @@
+ VNetSend(&netIf->port.jack, skb);
+
+ netIf->stats.tx_packets++;
+- dev->trans_start = jiffies;
++ netif_trans_update(dev);
+
+ return 0;
+ }
diff --git a/app-emulation/vmware-modules/vmware-modules-304.3-r1.ebuild b/app-emulation/vmware-modules/vmware-modules-304.3-r1.ebuild
index c56f4de..665965c 100644
--- a/app-emulation/vmware-modules/vmware-modules-304.3-r1.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-304.3-r1.ebuild
@@ -102,6 +102,7 @@ src_prepare() {
kernel_is ge 4 3 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.3-00-misc_deregister.patch"
kernel_is ge 4 5 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.5-00-get_link.patch"
kernel_is ge 4 6 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.6-00-user-pages.patch"
+ kernel_is ge 4 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.7-00-trans_start.patch"
# Allow user patches so they can support RC kernels and whatever else
epatch_user
diff --git a/app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild b/app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild
index a7e1daa..1bfbcb4 100644
--- a/app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-308.1.1.ebuild
@@ -102,6 +102,7 @@ src_prepare() {
kernel_is ge 4 3 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.03-00-vmci-misc_deregister.patch"
kernel_is ge 4 5 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.05-00-vmblock-follow_link.patch"
kernel_is ge 4 6 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.06-00-user-pages.patch"
+ kernel_is ge 4 7 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.07-00-trans_start.patch"
# Allow user patches so they can support RC kernels and whatever else
epatch_user