summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/open-vm-tools-kmod/Manifest1
-rw-r--r--app-emulation/open-vm-tools-kmod/files/vmhgfs-linux-3.11.patch42
-rw-r--r--app-emulation/open-vm-tools-kmod/metadata.xml11
-rw-r--r--app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.09.16.1328054.ebuild67
4 files changed, 0 insertions, 121 deletions
diff --git a/app-emulation/open-vm-tools-kmod/Manifest b/app-emulation/open-vm-tools-kmod/Manifest
deleted file mode 100644
index b35af64..0000000
--- a/app-emulation/open-vm-tools-kmod/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST open-vm-tools-2013.09.16-1328054.tar.gz 3793719 SHA256 470a6ea3ce14c2c5ea6b7bc59745eccbacc8d88a3f343e712312786435975d13 SHA512 7ae62d5411b4bdefd0e8db5f0a81bb357bfd4a624af06bf9a5a74f49ede0b7051b41dfe548c758fd7e73cded34af983c8aa0c412e65343092e05ae9b997895cb WHIRLPOOL 688fb4e494fb7aab7d0eb09189afff95ec8727bcc1893a4ec632bb8198661a1a55d58a813d2d56a3ac330fd7a55afc1fa7dc11f1d60c06c91ecf6a0bf866b249
diff --git a/app-emulation/open-vm-tools-kmod/files/vmhgfs-linux-3.11.patch b/app-emulation/open-vm-tools-kmod/files/vmhgfs-linux-3.11.patch
deleted file mode 100644
index 3918162..0000000
--- a/app-emulation/open-vm-tools-kmod/files/vmhgfs-linux-3.11.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Source: https://github.com/rasa/vmware-tools-patches/
-
---- a/modules/linux/vmhgfs/inode.c
-+++ b/modules/linux/vmhgfs/inode.c
-@@ -31,6 +31,9 @@
- #include <linux/namei.h>
- #endif
- #include <linux/highmem.h>
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 11, 0)
-+#include <linux/dcache.h>
-+#endif
-
- #include "compat_cred.h"
- #include "compat_fs.h"
-@@ -1890,7 +1893,11 @@
- #endif
- &inode->i_dentry,
- d_alias) {
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 11, 0)
-+ int dcount = d_count(dentry);
-+#else
- int dcount = dentry->d_count;
-+#endif
- if (dcount) {
- LOG(4, ("Found %s %d \n", dentry->d_name.name, dcount));
- return HgfsAccessInt(dentry, mask & (MAY_READ | MAY_WRITE | MAY_EXEC));
-@@ -1943,10 +1950,12 @@
- list_for_each(pos, &inode->i_dentry) {
- int dcount;
- struct dentry *dentry = list_entry(pos, struct dentry, d_alias);
--#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 38)
-- dcount = atomic_read(&dentry->d_count);
--#else
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 11, 0)
-+ dcount = d_count(dentry);
-+#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 38)
- dcount = dentry->d_count;
-+#else
-+ dcount = atomic_read(&dentry->d_count);
- #endif
- if (dcount) {
- LOG(4, ("Found %s %d \n", (dentry)->d_name.name, dcount));
diff --git a/app-emulation/open-vm-tools-kmod/metadata.xml b/app-emulation/open-vm-tools-kmod/metadata.xml
deleted file mode 100644
index 89f3183..0000000
--- a/app-emulation/open-vm-tools-kmod/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <herd>vmware</herd>
- <longdescription>
- The Open Virtual Machine Tools (open-vm-tools) are the open source
- implementation of VMware Tools. They are a set of guest operating system
- virtualization components that enhance performance and user experience
- of virtual machines.
- </longdescription>
-</pkgmetadata>
diff --git a/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.09.16.1328054.ebuild b/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.09.16.1328054.ebuild
deleted file mode 100644
index 8ab6ce4..0000000
--- a/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.09.16.1328054.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools-kmod/open-vm-tools-kmod-2013.09.16.1328054.ebuild,v 1.6 2014/08/10 16:18:12 floppym Exp $
-
-EAPI="5"
-
-inherit eutils linux-mod versionator udev
-
-MY_PN="${PN/-kmod}"
-MY_PV="$(replace_version_separator 3 '-')"
-MY_P="${MY_PN}-${MY_PV}"
-
-DESCRIPTION="Opensourced tools for VMware guests"
-HOMEPAGE="http://open-vm-tools.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="vmhgfs"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- CONFIG_CHECK="~DRM_VMWGFX ~VMWARE_BALLOON ~VMWARE_PVSCSI ~VMXNET3
- !UIDGID_STRICT_TYPE_CHECKS"
-
- # See logic in configure.ac.
- local MODULES="vmxnet"
-
- use vmhgfs && MODULES+=" vmhgfs"
-
- if kernel_is -lt 3 9; then
- MODULES+=" vmci vsock"
- else
- CONFIG_CHECK+=" VMWARE_VMCI ~VMWARE_VMCI_VSOCKETS"
- fi
-
- if kernel_is -lt 3; then
- MODULES+=" vmblock vmsync"
- else
- CONFIG_CHECK+=" ~FUSE_FS"
- fi
-
- local mod
- for mod in ${MODULES}; do
- MODULE_NAMES+=" ${mod}(ovt:modules/linux/${mod})"
- done
-
- linux-mod_pkg_setup
-}
-
-src_prepare() {
- epatch "${FILESDIR}/vmhgfs-linux-3.11.patch"
- epatch_user
-}
-
-src_configure() {
- BUILD_TARGETS="auto-build"
- export OVT_SOURCE_DIR="${S}"
- export LINUXINCLUDE="${KV_OUT_DIR}/include"
-}
-
-src_install() {
- linux-mod_src_install
- udev_dorules "${FILESDIR}/60-vmware.rules"
-}