summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vmware-modules')
-rw-r--r--app-emulation/vmware-modules/files/308-5.03-00-force_sig.patch14
-rw-r--r--app-emulation/vmware-modules/vmware-modules-308.5.9.ebuild1
2 files changed, 15 insertions, 0 deletions
diff --git a/app-emulation/vmware-modules/files/308-5.03-00-force_sig.patch b/app-emulation/vmware-modules/files/308-5.03-00-force_sig.patch
new file mode 100644
index 0000000..ad19156
--- /dev/null
+++ b/app-emulation/vmware-modules/files/308-5.03-00-force_sig.patch
@@ -0,0 +1,14 @@
+--- ./vmmon-only/linux/hostif.c 2019-08-09 11:03:35.984541672 +0200
++++ ./vmmon-only/linux/hostif.c.new 2019-08-09 11:37:39.484542449 +0200
+@@ -3583,7 +3583,11 @@
+ }
+ } else {
+ if (linuxState.fastClockThread) {
++#if LINUX_VERSION_CODE > KERNEL_VERSION(5, 2, 99)
++ send_sig(SIGKILL, linuxState.fastClockThread, 1);
++#else
+ force_sig(SIGKILL, linuxState.fastClockThread);
++#endif
+ kthread_stop(linuxState.fastClockThread);
+ close_rtc(linuxState.fastClockFile, current->files);
+
diff --git a/app-emulation/vmware-modules/vmware-modules-308.5.9.ebuild b/app-emulation/vmware-modules/vmware-modules-308.5.9.ebuild
index 933f0df..d92cd23 100644
--- a/app-emulation/vmware-modules/vmware-modules-308.5.9.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-308.5.9.ebuild
@@ -126,6 +126,7 @@ src_prepare() {
kernel_is ge 5 00 0 && epatch "${FILESDIR}/${PV_MAJOR}-5.00-02-do_gettimeofday.patch"
kernel_is ge 5 01 0 && epatch "${FILESDIR}/${PV_MAJOR}-5.01-00-vm_fault_t.patch"
kernel_is ge 5 01 0 && epatch "${FILESDIR}/${PV_MAJOR}-5.01-01-kernel_ds.patch"
+ kernel_is ge 5 03 0 && epatch "${FILESDIR}/${PV_MAJOR}-5.03-00-force_sig.patch"
# Allow user patches so they can support RC kernels and whatever else
epatch_user