summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vmware-player/vmware-player-4.0.1.528992-r1.ebuild')
-rw-r--r--app-emulation/vmware-player/vmware-player-4.0.1.528992-r1.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/app-emulation/vmware-player/vmware-player-4.0.1.528992-r1.ebuild b/app-emulation/vmware-player/vmware-player-4.0.1.528992-r1.ebuild
index e1a8fa9..62aa7d1 100644
--- a/app-emulation/vmware-player/vmware-player-4.0.1.528992-r1.ebuild
+++ b/app-emulation/vmware-player/vmware-player-4.0.1.528992-r1.ebuild
@@ -103,8 +103,8 @@ src_unpack() {
vmware-player-app \
vmware-vmx \
vmware-usbarbitrator \
- vmware-network-editor
- #vmware-player-setup
+ vmware-network-editor \
+ vmware-player-setup
#vmware-ovftool
do
vmware-bundle_extract-bundle-component "${DISTDIR}/${A}" "${component}" "${S}"
@@ -158,15 +158,19 @@ src_install() {
dodoc doc/*
fi
+ exeinto "${VM_INSTALL_DIR}"/lib/vmware/setup
+ doexe vmware-config
+
# create symlinks for the various tools
local tool ; for tool in thnuclnt vmplayer{,-daemon} \
vmware-{acetool,unity-helper,modconfig{,-console},gksu,fuseUI} ; do
dosym appLoader "${VM_INSTALL_DIR}"/lib/vmware/bin/"${tool}"
done
dosym "${VM_INSTALL_DIR}"/lib/vmware/bin/vmplayer "${VM_INSTALL_DIR}"/bin/vmplayer
+ dosym "${VM_INSTALL_DIR}"/lib/vmware/icu /etc/vmware/icu
# fix up permissions
- fperms 0755 "${VM_INSTALL_DIR}"/lib/vmware/{bin/*,lib/wrapper-gtk24.sh}
+ fperms 0755 "${VM_INSTALL_DIR}"/lib/vmware/{bin/*,lib/wrapper-gtk24.sh,lib/libgksu2.so.0/gksu-run-helper}
fperms 4711 "${VM_INSTALL_DIR}"/lib/vmware/bin/vmware-vmx*
# create the environment