summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vmware-workstation')
-rw-r--r--app-emulation/vmware-workstation/vmware-workstation-11.1.2.2780323-r3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-emulation/vmware-workstation/vmware-workstation-11.1.2.2780323-r3.ebuild b/app-emulation/vmware-workstation/vmware-workstation-11.1.2.2780323-r3.ebuild
index c17809b..986b5a5 100644
--- a/app-emulation/vmware-workstation/vmware-workstation-11.1.2.2780323-r3.ebuild
+++ b/app-emulation/vmware-workstation/vmware-workstation-11.1.2.2780323-r3.ebuild
@@ -29,6 +29,14 @@ RESTRICT="mirror strip"
BUNDLED_LIBS_DIR=/opt/vmware/lib/vmware/lib
+BUNDLED_LIBS_PATCH="
+ libvmplayer.so
+ libvmware-enter-serial.so
+ libvmware-fuseUI.so
+ libgcr.so.0
+ libgksu2.so.0
+"
+
BUNDLED_LIBS="
libXau.so.6
libXcomposite.so.1
@@ -131,6 +139,8 @@ RDEPEND="
PDEPEND="~app-emulation/vmware-modules-304.${PV_MINOR}
vmware-tools? ( app-emulation/vmware-tools )"
+DEPEND="dev-util/patchelf"
+
S=${WORKDIR}
VM_INSTALL_DIR="/opt/vmware"
VM_DATA_STORE_DIR="/var/lib/vmware/Shared VMs"
@@ -177,6 +187,15 @@ clean_bundled_libs() {
done
}
+patch_bundled_libs() {
+ for libname in ${BUNDLED_LIBS_PATCH} ; do
+ if [[ -f "${S}"/lib/lib/${libname}/${libname} ]]; then
+ einfo "Setting RPATH of ${libname}"
+ patchelf --set-rpath "${VM_INSTALL_DIR}"/lib/vmware/lib "${S}"/lib/lib/${libname}/${libname} || die "Failed patching ${libname}"
+ fi
+ done
+}
+
src_prepare() {
rm -f bin/vmware-modconfig
rm -rf lib/modules/binary
@@ -192,6 +211,7 @@ src_prepare() {
if ! use bundled-libs ; then
clean_bundled_libs
fi
+ patch_bundled_libs
DOC_CONTENTS="
/etc/env.d is updated during ${PN} installation. Please run:\n