summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vmware-vix/ChangeLog10
-rw-r--r--app-emulation/vmware-vix/Manifest5
-rw-r--r--app-emulation/vmware-vix/metadata.xml17
-rw-r--r--app-emulation/vmware-vix/vmware-vix-1.10.2.331862.ebuild128
4 files changed, 160 insertions, 0 deletions
diff --git a/app-emulation/vmware-vix/ChangeLog b/app-emulation/vmware-vix/ChangeLog
new file mode 100644
index 0000000..8c50290
--- /dev/null
+++ b/app-emulation/vmware-vix/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emulation/vmware-vix
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*vmware-vix-1.10.2.331862 (27 Mar 2011)
+
+ 27 Mar 2011; Vadim Kuznetsov <vadimk@gentoo.org>
+ +vmware-vix-1.10.2.331862.ebuild, +metadata.xml:
+ initial ebuild. work in progress.
+
diff --git a/app-emulation/vmware-vix/Manifest b/app-emulation/vmware-vix/Manifest
new file mode 100644
index 0000000..335fb6c
--- /dev/null
+++ b/app-emulation/vmware-vix/Manifest
@@ -0,0 +1,5 @@
+DIST VMware-VIX-1.10.2-331862.i386.bundle 70738512 RMD160 dc92deff1f7a3a5ae12ef615289ba77f5cf75ab1 SHA1 59f8a838cd073eb863e9d95c72de2c8822cd0563 SHA256 9e7c98fd90523be819a5d04963ff4a8cb2521091c98724d9db797b5602887e6a
+DIST VMware-VIX-1.10.2-331862.x86_64.bundle 76018726 RMD160 747310321842ac1f8eb4f2eed574ef42ad14f217 SHA1 5b0cfd8b9002edd8b08d41bdfa7d2d2223533313 SHA256 12e191f9d2c5e10c54321f420ea15396956dcc2d4e1de476ae77de729fc5cc7c
+EBUILD vmware-vix-1.10.2.331862.ebuild 3000 RMD160 3397eab76cd6c720b2f675d4a44ddeb30c28cd97 SHA1 646b1e06754ad3bb50e72a65733b5b5ec3034fd3 SHA256 82731ff18fec03194806c6aa0fb3e337c5c78cc97b45097d86878624087133f4
+MISC ChangeLog 305 RMD160 53e0cadec4592ddaddc9c0a8cb3474c74a5f8654 SHA1 43dde0292a84b9eedcb83a1574cef8837eaaa6e4 SHA256 6ced88386c1e5c6c283e8fbd1abe164242bc5e9ca6c596dd95981f872cedec7b
+MISC metadata.xml 736 RMD160 9e0b6138a82c1ca34b847bc71bc072e44c60d95a SHA1 4365d9dc523f50c84cb02caf44fadf05ee996b3c SHA256 3882e8981caee5b279a4a1990df6b404e920ab088d6a4cd1d789cbb29e301f74
diff --git a/app-emulation/vmware-vix/metadata.xml b/app-emulation/vmware-vix/metadata.xml
new file mode 100644
index 0000000..5599850
--- /dev/null
+++ b/app-emulation/vmware-vix/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vmware</herd>
+ <maintainer>
+ <email>vadimk@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ The VIX API allows you to write programs and scripts that automate
+ virtual machine operations, as well as the guests within virtual
+ machines. This API is high-level, easy to use, and practical for both
+ script writers and application programmers. It runs on both Windows and
+ Linux and supports management of VMware Server, Workstation, and Virtual
+ Infrastructure (both ESX and vCenter). Bindings are provided for C,
+ Perl, and COM (Visual Basic, VBscript, C#).
+ </longdescription>
+</pkgmetadata>
diff --git a/app-emulation/vmware-vix/vmware-vix-1.10.2.331862.ebuild b/app-emulation/vmware-vix/vmware-vix-1.10.2.331862.ebuild
new file mode 100644
index 0000000..e879da0
--- /dev/null
+++ b/app-emulation/vmware-vix/vmware-vix-1.10.2.331862.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils versionator vmware-bundle
+
+MY_PN="VMware-VIX"
+MY_PV="$(replace_version_separator 3 - $PV)"
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="VMware VIX API for Linux"
+HOMEPAGE="http://www.vmware.com/support/developer/vix-api/"
+SRC_URI="
+ x86? ( ${MY_P}.i386.bundle )
+ amd64? ( ${MY_P}.x86_64.bundle )
+ "
+
+LICENSE="vmware"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE="doc"
+RESTRICT="binchecks fetch mirror strip"
+
+# vmware-workstation should not use virtual/libc as this is a
+# precompiled binary package thats linked to glibc.
+RDEPEND="
+ dev-libs/glib
+ dev-libs/libxml2
+ =dev-libs/openssl-0.9.8*
+ net-misc/curl
+ sys-libs/glibc
+ sys-libs/zlib
+ !app-emulation/vmware-workstation"
+
+S=${WORKDIR}
+VM_INSTALL_DIR="/opt/vmware"
+
+pkg_nofetch() {
+ local bundle
+
+ if use x86; then
+ bundle="${MY_P}.i386.bundle"
+ elif use amd64; then
+ bundle="${MY_P}.x86_64.bundle"
+ fi
+
+ einfo "Please download ${bundle}"
+ einfo "from ${HOMEPAGE}"
+ einfo "and place it in ${DISTDIR}"
+}
+
+src_unpack() {
+ vmware-bundle_extract-bundle-component "${DISTDIR}/${A}" vmware-vix
+}
+
+src_prepare() {
+ # remove superfluous libraries
+ ebegin 'Removing superfluous libraries'
+ #cd vmware-player-app/lib/lib || die
+ # exclude OpenSSL from unbundling until the AES-NI patch gets into the tree
+ # see http://forums.gentoo.org/viewtopic-t-835867.html
+ #ldconfig -p | sed 's:^\s\+\([^(]*[^( ]\).*=> /.*$:\1:g;t;d' | fgrep -vx 'libcrypto.so.0.9.8 libssl.so.0.9.8' | xargs -d'\n' -r rm -rf
+ #cd ../../../vmware-workstation/lib/lib || die
+ #ldconfig -p | sed 's:^\s\+\([^(]*[^( ]\).*=> /.*$:\1:g;t;d' | fgrep -vx 'libcrypto.so.0.9.8 libssl.so.0.9.8' | xargs -d'\n' -r rm -rf
+ eend
+}
+
+src_install() {
+ # install vmware-vix
+ cd "${S}"/vmware-vix
+
+ # install the binary
+ into "${VM_INSTALL_DIR}"
+ dobin bin/*
+
+ # install the libraries
+ insinto "${VM_INSTALL_DIR}"/lib/vmware-vix
+ doins -r lib/*
+
+ dosym vmware-vix/libvixAllProducts.so "${VM_INSTALL_DIR}"/lib/libbvixAllProducts.so
+
+ # install headers
+ insinto /usr/include/vmware-vix
+ doins include/*
+
+ if use doc; then
+ dohtml -r doc/*
+ fi
+
+ # fix up permissions
+ chmod 0755 "${D}${VM_INSTALL_DIR}"/lib/vmware-vix/setup/*
+
+ # create the environment
+ local envd="${T}/90${PN}"
+ cat > "${envd}" <<-EOF
+ PATH='${VM_INSTALL_DIR}/bin'
+ ROOTPATH='${VM_INSTALL_DIR}/bin'
+ EOF
+ doenvd "${envd}"
+
+ # create the configuration
+ dodir /etc/vmware
+
+ cat >> "${D}"/etc/vmware/config <<-EOF
+ vmware.fullpath = "${VM_INSTALL_DIR}/bin/vmware"
+ vix.libdir = "${VM_INSTALL_DIR}/lib/vmware-vix"
+ vix.config.version = "1"
+ EOF
+}
+
+pkg_config() {
+ :;
+}
+
+pkg_postinst() {
+ ewarn "/etc/env.d was updated. Please run:"
+ ewarn "env-update && source /etc/profile"
+ ewarn ""
+ ewarn "Before you can use ${PN}, you must configure a default network setup."
+ ewarn "You can do this by running 'emerge --config ${PN}'."
+}
+
+pkg_prerm() {
+ sed -i -e "/vix.libdir/d" "${ROOT}"/etc/vmware/config
+}
+