summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vmware-modules/files/308-4.13-00-vmnet-refcount.patch11
-rw-r--r--app-emulation/vmware-modules/vmware-modules-308.5.7.ebuild1
2 files changed, 12 insertions, 0 deletions
diff --git a/app-emulation/vmware-modules/files/308-4.13-00-vmnet-refcount.patch b/app-emulation/vmware-modules/files/308-4.13-00-vmnet-refcount.patch
new file mode 100644
index 0000000..0a1d835
--- /dev/null
+++ b/app-emulation/vmware-modules/files/308-4.13-00-vmnet-refcount.patch
@@ -0,0 +1,11 @@
+--- vmnet-only/bridge.c 2017-06-20 04:54:39.000000000 +0200
++++ vmnet-only/bridge.c.new 2017-08-18 11:16:20.979974593 +0200
+@@ -636,7 +636,7 @@
+ unsigned long flags;
+ int i;
+
+- atomic_inc(&clone->users);
++ refcount_inc(&clone->users);
+
+ clone->dev = dev;
+ clone->protocol = eth_type_trans(clone, dev);
diff --git a/app-emulation/vmware-modules/vmware-modules-308.5.7.ebuild b/app-emulation/vmware-modules/vmware-modules-308.5.7.ebuild
index ad6b45c..59ce990 100644
--- a/app-emulation/vmware-modules/vmware-modules-308.5.7.ebuild
+++ b/app-emulation/vmware-modules/vmware-modules-308.5.7.ebuild
@@ -110,6 +110,7 @@ src_prepare() {
kernel_is ge 4 12 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.12-00-vmblock-current_time.patch"
kernel_is ge 4 12 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.12-01-vmci-do_once.patch"
kernel_is ge 4 12 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.12-02-vmci-pci_enable_msix.patch"
+ kernel_is ge 4 13 0 && epatch "${FILESDIR}/${PV_MAJOR}-4.13-00-vmnet-refcount.patch"
# Allow user patches so they can support RC kernels and whatever else
epatch_user