summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/libview/libview-0.6.6.ebuild')
-rw-r--r--x11-libs/libview/libview-0.6.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-libs/libview/libview-0.6.6.ebuild b/x11-libs/libview/libview-0.6.6.ebuild
new file mode 100644
index 0000000..ba7bcc6
--- /dev/null
+++ b/x11-libs/libview/libview-0.6.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libview/libview-0.6.2.ebuild,v 1.3 2009/01/12 21:41:05 maekke Exp $
+
+EAPI=3
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="VMware's Incredibly Exciting Widgets"
+HOMEPAGE="http://view.sourceforge.net"
+SRC_URI="mirror://sourceforge/view/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.4.0
+ >=dev-cpp/gtkmm-2.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+G2CONF="--enable-deprecated"
+
+src_unpack() {
+ gnome2_src_unpack
+}
+
+src_prepare() {
+ # Fix the pkgconfig file
+ epatch "${FILESDIR}"/${PN}-0.5.6-pcfix.patch
+ eautoreconf -i
+}