summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-01-18 08:59:38 +0000
committerChristian Heim <phreak@gentoo.org>2007-01-18 08:59:38 +0000
commit4bfa8a31e787f6ea77634eaffaff4f3e91518a15 (patch)
tree294d1cdbf82d78728e5752bb48ee27e53f2b8772
parentUpdating vserver-sources. (diff)
downloadoverlay-4bfa8a31e787f6ea77634eaffaff4f3e91518a15.tar.gz
overlay-4bfa8a31e787f6ea77634eaffaff4f3e91518a15.tar.bz2
overlay-4bfa8a31e787f6ea77634eaffaff4f3e91518a15.zip
Overlay ebuild for vzctl-3.0.14 (including the fix from Kir for src/ndsend.c).
svn path=/; revision=92
-rw-r--r--sys-cluster/vzctl/Manifest12
-rw-r--r--sys-cluster/vzctl/files/digest-vzctl-3.0.143
-rw-r--r--sys-cluster/vzctl/files/vzctl-3.0.14-ndsend.c.patch12
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.14.ebuild67
4 files changed, 94 insertions, 0 deletions
diff --git a/sys-cluster/vzctl/Manifest b/sys-cluster/vzctl/Manifest
new file mode 100644
index 0000000..71f71bf
--- /dev/null
+++ b/sys-cluster/vzctl/Manifest
@@ -0,0 +1,12 @@
+AUX vzctl-3.0.14-ndsend.c.patch 333 RMD160 0a1fda036be77bfc5b4569ba5c0df395deb0ec7a SHA1 d0c99f4d6535425031f7b840a6667d77be36b120 SHA256 8fef90a7b4c8193c0df7b8460fc5345bf7eca5b07d7a00691a7468fe45967418
+MD5 10807ba11492d1d129a88aaa5259912c files/vzctl-3.0.14-ndsend.c.patch 333
+RMD160 0a1fda036be77bfc5b4569ba5c0df395deb0ec7a files/vzctl-3.0.14-ndsend.c.patch 333
+SHA256 8fef90a7b4c8193c0df7b8460fc5345bf7eca5b07d7a00691a7468fe45967418 files/vzctl-3.0.14-ndsend.c.patch 333
+DIST vzctl-3.0.14.tar.bz2 356300 RMD160 529b4e3bb1fbcf673831d2891becedf6e003dcd8 SHA1 c773b495d688ee6b172d1c0941a5a57e2c188c57 SHA256 86be0231fd12f97e45bae8dae86fadc466e631051d4ee04569d40bb8f82d8b83
+EBUILD vzctl-3.0.14.ebuild 1989 RMD160 d27b6a94e43e0affe53d32cfedfff65c6b27964c SHA1 b5302765516846847d814e48fa9b87b02230648c SHA256 1f75c7f6aff636ddc6a2e108b44cb3bbb661de02ed5512f15a8398da234e51a9
+MD5 68110a4a505bd884f0e6139c97c806b5 vzctl-3.0.14.ebuild 1989
+RMD160 d27b6a94e43e0affe53d32cfedfff65c6b27964c vzctl-3.0.14.ebuild 1989
+SHA256 1f75c7f6aff636ddc6a2e108b44cb3bbb661de02ed5512f15a8398da234e51a9 vzctl-3.0.14.ebuild 1989
+MD5 604d30b9c731718babaeebabb624dd01 files/digest-vzctl-3.0.14 241
+RMD160 f2ada0ab328e14ff8b97255c320a6fdc82b9f89a files/digest-vzctl-3.0.14 241
+SHA256 f31d206d22b741c4a7e5b5acee694512e153e1d7f8c4e61e1e9d31c9d633d611 files/digest-vzctl-3.0.14 241
diff --git a/sys-cluster/vzctl/files/digest-vzctl-3.0.14 b/sys-cluster/vzctl/files/digest-vzctl-3.0.14
new file mode 100644
index 0000000..07b13a2
--- /dev/null
+++ b/sys-cluster/vzctl/files/digest-vzctl-3.0.14
@@ -0,0 +1,3 @@
+MD5 c0e3a15f711e5161b504f77b52898906 vzctl-3.0.14.tar.bz2 356300
+RMD160 529b4e3bb1fbcf673831d2891becedf6e003dcd8 vzctl-3.0.14.tar.bz2 356300
+SHA256 86be0231fd12f97e45bae8dae86fadc466e631051d4ee04569d40bb8f82d8b83 vzctl-3.0.14.tar.bz2 356300
diff --git a/sys-cluster/vzctl/files/vzctl-3.0.14-ndsend.c.patch b/sys-cluster/vzctl/files/vzctl-3.0.14-ndsend.c.patch
new file mode 100644
index 0000000..f41d65b
--- /dev/null
+++ b/sys-cluster/vzctl/files/vzctl-3.0.14-ndsend.c.patch
@@ -0,0 +1,12 @@
+Index: vzctl-3.0.14/src/ndsend.c
+===================================================================
+--- vzctl-3.0.14.orig/src/ndsend.c
++++ vzctl-3.0.14/src/ndsend.c
+@@ -17,6 +17,7 @@
+ #include <netdb.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
++#include <linux/types.h>
+ #include <linux/if.h>
+ #include <netinet/icmp6.h>
+
diff --git a/sys-cluster/vzctl/vzctl-3.0.14.ebuild b/sys-cluster/vzctl/vzctl-3.0.14.ebuild
new file mode 100644
index 0000000..77be6e1
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.0.14.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.13.ebuild,v 1.2 2006/12/03 08:33:48 hollow Exp $
+
+inherit bash-completion eutils flag-o-matic multilib
+
+DESCRIPTION="OpenVZ VPS control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE="bash-completion logrotate udev"
+
+RDEPEND="logrotate? ( app-admin/logrotate )
+ net-firewall/iptables
+ sys-apps/ed
+ sys-apps/iproute2
+ sys-fs/vzquota
+ udev? ( sys-fs/udev )
+ virtual/cron"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-ndsend.c.patch
+}
+
+src_compile() {
+ econf || die "econf failed!"
+ emake CFLAGS="${CFLAGS}" || die "emake failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/vzctl" install install-gentoo || die "make install failed"
+
+ # the get_libdir in `make install' breaks src/Makefile's logic (and thus all
+ # contained tools), so we have to create a env.d entry for vzctl's LDPATH.
+ dodir /etc/env.d
+ echo "LDPATH=\"/usr/$(get_libdir)/vzctl\"" > "${D}"/etc/env.d/05vzctl
+
+ # Remove udev files unless USE=udev
+ use udev || rm -rf "${D}"/etc/udev
+
+ # Remove the bash-completion and use dobashcompletion to install it in the
+ # right place!
+ rm -rf "${D}"/etc/bash_completion.d
+ dobashcompletion "${S}"/etc/bash_completion.d/vzctl.sh vzctl
+
+ # Remove the logrotate entry unless USE=logrotate
+ use logrotate || rm -rf "${D}"/etc/logrotate.d
+}
+
+pkg_postinst() {
+ if has_version "<3.0.10"; then
+ ewarn
+ ewarn "The location of some vzctl files have changed. Most notably,"
+ ewarn "VE configuration files and samples directory has changed from"
+ ewarn "/etc/vz to /etc/vz/conf. In order to be able to work with"
+ ewarn "your VEs, please do the following:"
+ ewarn
+ ewarn "bash# mv /etc/vz/[0-9]*.conf /etc/vz/conf/"
+ ewarn
+ fi
+}