summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-apps/cake/ChangeLog6
-rw-r--r--www-apps/cake/Manifest4
-rw-r--r--www-apps/cake/cake-1.2.0.6311.ebuild63
3 files changed, 71 insertions, 2 deletions
diff --git a/www-apps/cake/ChangeLog b/www-apps/cake/ChangeLog
index 4e4a46e..8338e27 100644
--- a/www-apps/cake/ChangeLog
+++ b/www-apps/cake/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for www-apps/cake
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 24 Jun 2008; Nathan Sullivan <nathan@nightsys.net>
+ +cake-1.2.0.6311.ebuild:
+ version bump to new 1.2 series
+
30 Nov 2007; Jakub Moc <jakub@gentoo.org> cake-1.1.18.5850.ebuild:
Fix webapp_configfile call, thanks to Paul Sumner
diff --git a/www-apps/cake/Manifest b/www-apps/cake/Manifest
index 58f7196..41f6a0c 100644
--- a/www-apps/cake/Manifest
+++ b/www-apps/cake/Manifest
@@ -1,5 +1,7 @@
AUX postinstall-en.txt 1087 RMD160 27a49e407a0971627b18a9894beae430da1a95d8 SHA1 aaafe11d12f269dda002bd5e99341ba800801c85 SHA256 d57b04a64a34cc3f3825c1d36c16359529fef6a20e727975d6bf2ee491343b06
DIST cake_1.1.18.5850.tar.bz2 162144 RMD160 bfe266b539307325d2ca66f57596e2152923e578 SHA1 6672338d2b7c6a9778428077286c6b97bfbf615f SHA256 1e6b91b22ed094e6e67546ff4eb58d911e490853da0d98f27dc491ad1204ea95
+DIST cake_1.2.0.6311.tar.bz2 432880 RMD160 df8bd0b2b64581824bcda3b3364d5cc4e317679d SHA1 17f57fcbd13aad6a81d26546d1c28f1c4bd02a2b SHA256 94860e87c9bdce6fa1023bfc32bf90f360941f5bf5af516f69291ed791ef4792
EBUILD cake-1.1.18.5850.ebuild 1753 RMD160 158ea91487db8f961fa7cf13b88489239d48bd4f SHA1 50c8fdb220ec17ed122d44e589b50d5fdbc5403d SHA256 413d517c69fd55bd0889a356683767c1224008326d7af13b2eb3385348612ae5
-MISC ChangeLog 502 RMD160 731e0ce2bdf8480c8716c335659aba10bf7c4913 SHA1 5d7baa47f98c86cafc6cf16f2fc42cffefda608a SHA256 8e9b15f754e9e61dbba59f7f5180c06fd13193b1cfc49efe5ec905db9c45cf0f
+EBUILD cake-1.2.0.6311.ebuild 1760 RMD160 3c84ec835943493f6737d6d0064dabd715ed90ea SHA1 ca8017d241c1f8da56ae90f74854070cbe1dea28 SHA256 24ba2ee20b54c9178531927129254753cdb94f3d81fa56482137667e65cca203
+MISC ChangeLog 616 RMD160 4c830313dc83852ccfc6c68792a1a807c6f0f7a8 SHA1 559ab91984edaa015c356bff1a4e4cf2eeaf9795 SHA256 cf3a5f0b46215cea7a0804ebfa057cb1e0062da3a958450efd806929c6032b25
MISC metadata.xml 185 RMD160 30ae785ddd1a348aadf63a6e048aa58d606f7643 SHA1 515cf211239faff08ee0db8d0c5e31e63f130dac SHA256 50ea7b31f12cdf7d828e64c52756c0afdaa3982061a0ffcd25961c1c13e9e136
diff --git a/www-apps/cake/cake-1.2.0.6311.ebuild b/www-apps/cake/cake-1.2.0.6311.ebuild
new file mode 100644
index 0000000..bb16c99
--- /dev/null
+++ b/www-apps/cake/cake-1.2.0.6311.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit webapp depend.php
+
+DESCRIPTION="A rapid development framework for PHP"
+HOMEPAGE="http://cakephp.org/"
+
+# Ugly hack until the source is provided w/o going through the donation
+# interstitial and to handle the underscore...
+MY_P="${PN}_${PV}"
+DLID="595"
+SRC_URI="http://cakeforge.org/frs/download.php/${DLID}/${MY_P}.tar.bz2/donation=complete/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE="adodb"
+
+RDEPEND="virtual/httpd-cgi
+ adodb? ( dev-php/adodb )"
+
+need_php_httpd
+
+S="${WORKDIR}/${MY_P}-beta"
+
+pkg_setup () {
+ webapp_pkg_setup
+
+ local flags="xml session"
+ local dbflags="mysql postgres sqlite"
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} || \
+ ( ! use adodb && ! PHPCHECKNODIE="yes" require_php_with_any_use ${dbflags} ) ; then
+ die "Re-install ${PHP_PKG} with ${flags} and at least one of ${dbflags} USE flags enabled."
+ elif
+ use adodb && ! PHPCHECKNODIE="yes" require_php_with_any_use ${dbflags} ; then
+ ewarn
+ ewarn "Assuming you are going to use ADOdb wrapper for database backend."
+ ewarn "You are on you own with this. Unless you know what you are doing,"
+ ewarn "you should re-emerge ${PHP_PKG} with at least one of"
+ ewarn "${dbflags} USE flags enabled."
+ else
+ einfo "All PHP checks passed, continue..."
+ fi
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc docs/*
+ rm -rf docs/
+
+ cp app/config/database.php.default app/config/database.php
+ cp -r . "${D}"/${MY_HTDOCSDIR}
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/app/tmp
+ for i in app/config/*.php ; do
+ webapp_configfile ${MY_HTDOCSDIR}/${i}
+ done
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}