summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2011-09-17 22:19:32 -0400
committerMatt Turner <mattst88@gmail.com>2011-09-17 22:19:32 -0400
commit274d0a9aa1db3ec54b6b01625829bf52a494e01e (patch)
tree2ce0aa36ddc4e6621c85cf06124c53c012d8ac0e /app-benchmarks
parentmedia-libs/mesa: split gles USE flag into gles1 and gles2 (diff)
downloadx11-274d0a9aa1db3ec54b6b01625829bf52a494e01e.tar.gz
x11-274d0a9aa1db3ec54b6b01625829bf52a494e01e.tar.bz2
x11-274d0a9aa1db3ec54b6b01625829bf52a494e01e.zip
app-benchmarks/glmark2: version bump, fixes, move category
media-libs makes no sense.
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/glmark2/Manifest2
-rw-r--r--app-benchmarks/glmark2/glmark2-2011.08.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/app-benchmarks/glmark2/Manifest b/app-benchmarks/glmark2/Manifest
new file mode 100644
index 00000000..4baddd6b
--- /dev/null
+++ b/app-benchmarks/glmark2/Manifest
@@ -0,0 +1,2 @@
+DIST glmark2-2011.08.tar.gz 2147647 RMD160 3268b846c9d5df2b0710b20a807cff2a18f1a75b SHA1 c65b31bdabf44f7638eaf746983e5f55fd579f3f SHA256 42351988a5c5ed31b78dec2423f1a48eb18028b6066d14d6bc903ae20f81f341
+EBUILD glmark2-2011.08.ebuild 913 RMD160 043ca007f1049930ccd10da653c075b16c7fe395 SHA1 12088208c4c29a06edacae99f83ea52530dee81b SHA256 11730d42f5e2b7ad42318f0e45c3824656e28181606b84d88a5151eebe2ff945
diff --git a/app-benchmarks/glmark2/glmark2-2011.08.ebuild b/app-benchmarks/glmark2/glmark2-2011.08.ebuild
new file mode 100644
index 00000000..7444fa8a
--- /dev/null
+++ b/app-benchmarks/glmark2/glmark2-2011.08.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit waf-utils
+
+DESCRIPTION="Opengl test suite"
+HOMEPAGE="https://launchpad.net/glmark2"
+SRC_URI="http://launchpad.net/${PN}/2011.11/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gles2"
+
+RDEPEND="media-libs/libpng:1.2
+ media-libs/mesa[gles2?]
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ rm -rf ${S}/src/libpng
+ sed -i -e 's#libpng12#libpng#g' ${S}/wscript ${S}/src/wscript_build || die
+}
+
+src_configure() {
+ : ${WAF_BINARY:="${S}/waf"}
+
+ local myconf
+
+ if use gles2; then
+ myconf += "--enable-glesv2"
+ fi
+
+ # it does not know --libdir specification, dandy huh
+ CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" "${WAF_BINARY}" \
+ --prefix=/usr \
+ --enable-gl \
+ ${myconf} \
+ configure || die "configure failed"
+}