summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberger <david.heidelberger@ixit.cz>2013-10-15 17:29:35 +0200
committerDavid Heidelberger <david.heidelberger@ixit.cz>2013-10-15 17:29:35 +0200
commitb884c9d0c458e686a6cbb33a7e66a35f44fa0858 (patch)
tree669818e3d80d7108589c251956994b66f4f6048e /app-benchmarks
parentx11-drivers/xf86-input-evdev: add dependency on dev-libs/libevdev (diff)
downloadx11-b884c9d0c458e686a6cbb33a7e66a35f44fa0858.tar.gz
x11-b884c9d0c458e686a6cbb33a7e66a35f44fa0858.tar.bz2
x11-b884c9d0c458e686a6cbb33a7e66a35f44fa0858.zip
app-emulation/glmark2: bump p283, remove 278, improve coding style
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/glmark2/Manifest2
-rw-r--r--app-benchmarks/glmark2/files/2012.12_p278-cstring_include.patch11
-rw-r--r--app-benchmarks/glmark2/glmark2-2012.12_p280.ebuild48
-rw-r--r--app-benchmarks/glmark2/glmark2-2012.12_p283.ebuild (renamed from app-benchmarks/glmark2/glmark2-2012.12_p278.ebuild)51
4 files changed, 26 insertions, 86 deletions
diff --git a/app-benchmarks/glmark2/Manifest b/app-benchmarks/glmark2/Manifest
index b816b80f..559dced5 100644
--- a/app-benchmarks/glmark2/Manifest
+++ b/app-benchmarks/glmark2/Manifest
@@ -1,2 +1,2 @@
-DIST glmark2-2012.12_p278.tar.gz 7778563 SHA256 e77a5026c108c4272986f9f0ccdc1474292c19192705ec984ceed8db44dd3d2e SHA512 a998b23819538cc29363aa95f5ad8a9252fa90950e37796f59577fdde2c3374e98eb847d44fb2d75e7ec955f0f1146aec1f5ac91024dc03b74e7afa8ce266851 WHIRLPOOL 84db3c7b5c368edb4a8222f49c7d2fef79e30c9b65e038b835b566cc208d4a6bd1a068707a780f917c27884182841fd0739326083580566fffb4e560339d3183
DIST glmark2-2012.12_p280.tar.gz 7778627 SHA256 b4d675928d60a464ee23bc713d9088c96bcf81008117b791a314bcb764900928 SHA512 4b7b5d03a85d24f88fc7f33b7a28b2dff90ccc3d8752e99ee17e7fd64c4e392bf8016e67688e37b60c3d0707075e39389cd1f704c88fc18f85ba73372486feaa WHIRLPOOL a2349b166ccae2a9430ae273dcb55fc5149c19f473c1207f8a5848f13dfb53ef18c90cb9c6b1bc83f56bd3b4790414d1ed461ea290b30811707956e30b11b1e5
+DIST glmark2-2012.12_p283.tar.gz 7779355 SHA256 f13288de47f7240c714c6f15429d557eb262ae17d57479d9dd2201b9fcdc3c97 SHA512 1637227f2a0dcd9bc66cf286b24e7ae6e5a0a62f3247e6a94cc4fb78b1d86062b156bfe803bafcbdd4862386a53064f0f1347e426bdb9cd77ab44e132eb17cce WHIRLPOOL 5d5da72b65dc2c9ca0c16534e5135f61cd417c088b8cca5ed23ca0051e7d738b28d4eb6346c6d1975005ac9ba3765a29a904f143e17eb98d93b734cdbe7467e9
diff --git a/app-benchmarks/glmark2/files/2012.12_p278-cstring_include.patch b/app-benchmarks/glmark2/files/2012.12_p278-cstring_include.patch
deleted file mode 100644
index 24532574..00000000
--- a/app-benchmarks/glmark2/files/2012.12_p278-cstring_include.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur a/glmark2/trunk/src/image-reader.cpp b/glmark2/trunk/src/image-reader.cpp
---- a/glmark2/trunk/src/image-reader.cpp 2013-08-07 16:21:26.655989291 +0200
-+++ b/glmark2/trunk/src/image-reader.cpp 2013-08-07 16:20:29.053983661 +0200
-@@ -21,6 +21,7 @@
- */
- #include <png.h>
- #include <jpeglib.h>
-+#include <cstring>
- #include <memory>
-
- #include "image-reader.h"
diff --git a/app-benchmarks/glmark2/glmark2-2012.12_p280.ebuild b/app-benchmarks/glmark2/glmark2-2012.12_p280.ebuild
index d6ce2ea3..14bddddd 100644
--- a/app-benchmarks/glmark2/glmark2-2012.12_p280.ebuild
+++ b/app-benchmarks/glmark2/glmark2-2012.12_p280.ebuild
@@ -7,9 +7,11 @@ EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
inherit waf-utils python-single-r1
+REV=${PV#*_p}
+
DESCRIPTION="Opengl test suite"
HOMEPAGE="https://launchpad.net/glmark2"
-SRC_URI="http://bazaar.launchpad.net/~glmark2-dev/glmark2/trunk/tarball/280 -> ${P}.tar.gz"
+SRC_URI="http://bazaar.launchpad.net/~glmark2-dev/glmark2/trunk/tarball/${REV} -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -39,47 +41,21 @@ src_configure() {
local myconf
if use X; then
- if use opengl; then
- myconf+="x11-gl"
- fi
- if use opengl && use gles2; then
- myconf+=","
- fi
- if use gles2; then
- myconf+="x11-glesv2"
- fi
-
+ use opengl && myconf+="x11-gl"
+ use gles2 && myconf+=",x11-glesv2"
fi
- if use drm; then
- if use X; then
- myconf+=","
- fi
- if use opengl; then
- myconf+="drm-gl"
- fi
- if use opengl && use gles2; then
- myconf+=","
- fi
- if use gles2; then
- myconf+="drm-glesv2"
- fi
+ if use drm; then
+ use opengl && myconf+=",drm-gl"
+ use gles2 && myconf+=",drm-glesv2"
fi
+
if use wayland; then
- if use X || use drm; then
- myconf+=","
- fi
- if use opengl; then
- myconf+="wayland-gl"
- fi
- if use opengl && use gles2; then
- myconf+=","
- fi
- if use gles2; then
- myconf+="wayland-glesv2"
- fi
+ use opengl && myconf+=",wayland-gl"
+ use gles2 && myconf+=",wayland-glesv2"
fi
+ myconf=${myconf#,}
# it does not know --libdir specification, dandy huh
CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" "${WAF_BINARY}" \
diff --git a/app-benchmarks/glmark2/glmark2-2012.12_p278.ebuild b/app-benchmarks/glmark2/glmark2-2012.12_p283.ebuild
index e444e97c..14bddddd 100644
--- a/app-benchmarks/glmark2/glmark2-2012.12_p278.ebuild
+++ b/app-benchmarks/glmark2/glmark2-2012.12_p283.ebuild
@@ -7,9 +7,11 @@ EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
inherit waf-utils python-single-r1
+REV=${PV#*_p}
+
DESCRIPTION="Opengl test suite"
HOMEPAGE="https://launchpad.net/glmark2"
-SRC_URI="http://bazaar.launchpad.net/~glmark2-dev/glmark2/trunk/tarball/278 -> ${P}.tar.gz"
+SRC_URI="http://bazaar.launchpad.net/~glmark2-dev/glmark2/trunk/tarball/${REV} -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -19,7 +21,7 @@ IUSE="drm +gles2 opengl wayland X"
RDEPEND="media-libs/libpng
media-libs/mesa[gles2?]
X? ( x11-libs/libX11 )
- wayland? ( <dev-libs/wayland-1.2 )"
+ wayland? ( >=dev-libs/wayland-1.2 )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -29,7 +31,6 @@ REQUIRED_USE="|| ( opengl gles2 )
S="${WORKDIR}/~${PN}-dev/${PN}/trunk/"
src_prepare() {
- epatch "${FILESDIR}/${PV}-cstring_include.patch"
rm -rf "${S}/src/libpng"
sed -i "s/libpng15/libpng/g" "${S}/wscript" # allow build with >= libpng:1.6
}
@@ -40,47 +41,21 @@ src_configure() {
local myconf
if use X; then
- if use opengl; then
- myconf+="x11-gl"
- fi
- if use opengl && use gles2; then
- myconf+=","
- fi
- if use gles2; then
- myconf+="x11-glesv2"
- fi
-
+ use opengl && myconf+="x11-gl"
+ use gles2 && myconf+=",x11-glesv2"
fi
- if use drm; then
- if use X; then
- myconf+=","
- fi
- if use opengl; then
- myconf+="drm-gl"
- fi
- if use opengl && use gles2; then
- myconf+=","
- fi
- if use gles2; then
- myconf+="drm-glesv2"
- fi
+ if use drm; then
+ use opengl && myconf+=",drm-gl"
+ use gles2 && myconf+=",drm-glesv2"
fi
+
if use wayland; then
- if use X || use drm; then
- myconf+=","
- fi
- if use opengl; then
- myconf+="wayland-gl"
- fi
- if use opengl && use gles2; then
- myconf+=","
- fi
- if use gles2; then
- myconf+="wayland-glesv2"
- fi
+ use opengl && myconf+=",wayland-gl"
+ use gles2 && myconf+=",wayland-glesv2"
fi
+ myconf=${myconf#,}
# it does not know --libdir specification, dandy huh
CCFLAGS="${CFLAGS}" LINKFLAGS="${LDFLAGS}" "${WAF_BINARY}" \