summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChi-Thanh Christopher Nguyen <chithanh@gentoo.org>2013-03-10 20:52:10 +0100
committerChi-Thanh Christopher Nguyen <chithanh@gentoo.org>2013-03-10 20:52:10 +0100
commitd392a0423fbbf5c5b5a7b01b8e1f76eb89204929 (patch)
tree58913abda986d2b9cf3ff278d721a928ada41cd5 /x11-libs/libSM/libSM-9999.ebuild
parentx11-libs/libSM: sync to gx86. (diff)
downloadx11-d392a0423fbbf5c5b5a7b01b8e1f76eb89204929.tar.gz
x11-d392a0423fbbf5c5b5a7b01b8e1f76eb89204929.tar.bz2
x11-d392a0423fbbf5c5b5a7b01b8e1f76eb89204929.zip
Switch pkg_setup() calls back to src_configure().
Diffstat (limited to 'x11-libs/libSM/libSM-9999.ebuild')
-rw-r--r--x11-libs/libSM/libSM-9999.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-libs/libSM/libSM-9999.ebuild b/x11-libs/libSM/libSM-9999.ebuild
index 7ccf9d39..b150976a 100644
--- a/x11-libs/libSM/libSM-9999.ebuild
+++ b/x11-libs/libSM/libSM-9999.ebuild
@@ -25,9 +25,8 @@ RDEPEND=">=x11-libs/libICE-1.0.5[${MULTILIB_USEDEP}]
) )"
DEPEND="${RDEPEND}"
-pkg_setup() {
+src_configure() {
local withuuid=$(use_with uuid libuuid)
- xorg-2_pkg_setup
# do not use uuid even if available in libc (like on FreeBSD)
use uuid || export ac_cv_func_uuid_create=no
@@ -59,4 +58,5 @@ pkg_setup() {
${withuuid}
--without-fop
)
+ xorg-2_src_configure
}