summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-10-28 13:52:58 +0200
committerTomas Chvatal <scarabeus@gentoo.org>2010-10-28 13:52:58 +0200
commite9c296027146bfc2198f2198010c5f77925b14b0 (patch)
tree5ff1a2be42e85568625ad1ccac300ff2e3831f68 /x11-libs/libSM/libSM-9999.ebuild
parent[eclass] Sync with main tree. (diff)
downloadx11-e9c296027146bfc2198f2198010c5f77925b14b0.tar.gz
x11-e9c296027146bfc2198f2198010c5f77925b14b0.tar.bz2
x11-e9c296027146bfc2198f2198010c5f77925b14b0.zip
[x11-libs] Sync bumped packages with main tree.
Diffstat (limited to 'x11-libs/libSM/libSM-9999.ebuild')
-rw-r--r--x11-libs/libSM/libSM-9999.ebuild22
1 files changed, 17 insertions, 5 deletions
diff --git a/x11-libs/libSM/libSM-9999.ebuild b/x11-libs/libSM/libSM-9999.ebuild
index 2081c602..7a262ea0 100644
--- a/x11-libs/libSM/libSM-9999.ebuild
+++ b/x11-libs/libSM/libSM-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -8,11 +8,23 @@ inherit xorg-2
DESCRIPTION="X.Org SM library"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="ipv6"
+IUSE="doc ipv6 +uuid"
RDEPEND="x11-libs/libICE
x11-libs/xtrans
- x11-proto/xproto"
-DEPEND="${RDEPEND}"
+ !elibc_FreeBSD? (
+ uuid? ( >=sys-apps/util-linux-2.16 )
+ )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ doc? ( app-text/xmlto )"
-CONFIGURE_OPTIONS="$(use_enable ipv6)"
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_enable doc docs)
+ $(use_with doc xmlto)
+ $(use_with uuid libuuid)
+ --without-fop"
+ # do not use uuid even if available in libc (like on FreeBSD)
+ use uuid || export ac_cv_func_uuid_create=no
+}