summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-03-06 14:20:25 +0100
committerMichał Górny <mgorny@gentoo.org>2013-03-06 14:20:25 +0100
commite6520cd1de58368a882402e9edd4f27851531f05 (patch)
treea766a5d5ee35f55eab2e385c067da6c37b4953b3 /x11-libs/libxcb/libxcb-9999.ebuild
parentx11-drivers/ati-drivers: update qt dependencies to new names (diff)
downloadx11-e6520cd1de58368a882402e9edd4f27851531f05.tar.gz
x11-e6520cd1de58368a882402e9edd4f27851531f05.tar.bz2
x11-e6520cd1de58368a882402e9edd4f27851531f05.zip
Convert live ebuilds to python-r1, sync to gx86.
Diffstat (limited to 'x11-libs/libxcb/libxcb-9999.ebuild')
-rw-r--r--x11-libs/libxcb/libxcb-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/x11-libs/libxcb/libxcb-9999.ebuild b/x11-libs/libxcb/libxcb-9999.ebuild
index 63dbf27f..bb9356b8 100644
--- a/x11-libs/libxcb/libxcb-9999.ebuild
+++ b/x11-libs/libxcb/libxcb-9999.ebuild
@@ -4,9 +4,12 @@
EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} )
+PYTHON_REQ_USE=xml
+
XORG_DOC=doc
XORG_MULTILIB=yes
-inherit xorg-2
+inherit python-single-r1 xorg-2
DESCRIPTION="X C-language Bindings library"
HOMEPAGE="http://xcb.freedesktop.org/"
@@ -14,7 +17,7 @@ EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/libxcb"
[[ ${PV} != 9999* ]] && \
SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="selinux"
RDEPEND="dev-libs/libpthread-stubs[${MULTILIB_USEDEP}]
@@ -23,13 +26,15 @@ RDEPEND="dev-libs/libpthread-stubs[${MULTILIB_USEDEP}]
DEPEND="${RDEPEND}
dev-lang/python[xml]
dev-libs/libxslt
- >=x11-proto/xcb-proto-1.7"
+ >=x11-proto/xcb-proto-1.7-r1[${MULTILIB_USEDEP},${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
-src_configure() {
+pkg_setup() {
+ python-single-r1_pkg_setup
+ xorg-2_pkg_setup
XORG_CONFIGURE_OPTIONS=(
$(use_enable doc build-docs)
$(use_enable selinux)
--enable-xinput
)
- xorg-2_src_configure
}