summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChi-Thanh Christopher Nguyen <chithanh@gentoo.org>2012-06-12 20:01:09 +0200
committerChi-Thanh Christopher Nguyen <chithanh@gentoo.org>2012-06-12 20:01:09 +0200
commit02efa40b0c6799e9f70f6021610fe6c2ce8c1cd1 (patch)
treef9b856aeaac53edb22fdf98430c38b8c74a63f70 /x11-proto
parent[media-libs/mesa] sync with main tree. (diff)
downloadx11-02efa40b0c6799e9f70f6021610fe6c2ce8c1cd1.tar.gz
x11-02efa40b0c6799e9f70f6021610fe6c2ce8c1cd1.tar.bz2
x11-02efa40b0c6799e9f70f6021610fe6c2ce8c1cd1.zip
x11-proto/glproto: sync with portage for eselect-opengl changes.
Diffstat (limited to 'x11-proto')
-rw-r--r--x11-proto/glproto/glproto-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-proto/glproto/glproto-9999.ebuild b/x11-proto/glproto/glproto-9999.ebuild
index e0c8f24a..a381ed50 100644
--- a/x11-proto/glproto/glproto-9999.ebuild
+++ b/x11-proto/glproto/glproto-9999.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=4
inherit xorg-2
DESCRIPTION="X.Org GL protocol headers"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
LICENSE="SGI-B-2.0"
IUSE=""
-RDEPEND=">=app-admin/eselect-opengl-1.2.3"
+RDEPEND=">=app-admin/eselect-opengl-1.2.6"
DEPEND=""
src_install() {
@@ -25,12 +25,13 @@ pkg_postinst() {
dynamic_libgl_install() {
# next section is to setup the dynamic libGL stuff
ebegin "Moving GL files for dynamic switching"
- dodir /usr/$(get_libdir)/opengl/xorg-x11/include
+ local gldir=/usr/$(get_libdir)/opengl/xorg-x11/include/GL
+ dodir ${gldir}
local x=""
# glext.h added for #54984
for x in "${ED}"/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
if [[ -f ${x} || -L ${x} ]]; then
- mv -f "${x}" "${ED}"/usr/$(get_libdir)/opengl/xorg-x11/include
+ mv -f "${x}" "${ED}"${gldir}
fi
done
eend 0