summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-proto/xcb-proto/xcb-proto-9999.ebuild')
-rw-r--r--x11-proto/xcb-proto/xcb-proto-9999.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/x11-proto/xcb-proto/xcb-proto-9999.ebuild b/x11-proto/xcb-proto/xcb-proto-9999.ebuild
index 1788579f..85b4a9eb 100644
--- a/x11-proto/xcb-proto/xcb-proto-9999.ebuild
+++ b/x11-proto/xcb-proto/xcb-proto-9999.ebuild
@@ -4,10 +4,9 @@
EAPI=5
-PYTHON_DEPEND="*"
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} )
XORG_MULTILIB=yes
-
-inherit python xorg-2
+inherit python-single-r1 xorg-2
DESCRIPTION="X C-language Bindings protocol headers"
HOMEPAGE="http://xcb.freedesktop.org/"
@@ -15,22 +14,17 @@ EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
[[ ${PV} != 9999* ]] && \
SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
-RDEPEND=""
+RDEPEND="${PYTHON_DEPS}"
DEPEND="${RDEPEND}
dev-libs/libxml2"
-src_prepare() {
- python_clean_py-compile_files
- xorg-2_src_prepare
-}
-
-pkg_postinst() {
- python_mod_optimize xcbgen
+pkg_setup() {
+ python-single-r1_pkg_setup
}
-pkg_postrm() {
- python_mod_cleanup xcbgen
+src_configure() {
+ xorg-2_src_configure
}