summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-03-23 12:17:28 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-03-23 12:17:28 +0000
commit71a93f6d1f8ce9649d49c031205af6bd945b0bad (patch)
tree79220386fb2ed13f0f26af518a293ba77f32003b /app-emulation
parentAdd live xen-tools (diff)
downloadxen-71a93f6d1f8ce9649d49c031205af6bd945b0bad.tar.gz
xen-71a93f6d1f8ce9649d49c031205af6bd945b0bad.tar.bz2
xen-71a93f6d1f8ce9649d49c031205af6bd945b0bad.zip
Add live xen
(Portage version: 2.2_rc26/svn/Linux x86_64) svn path=/overlay/; revision=87
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen/ChangeLog13
-rw-r--r--app-emulation/xen/metadata.xml14
-rw-r--r--app-emulation/xen/xen-9999.ebuild104
3 files changed, 131 insertions, 0 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
new file mode 100644
index 0000000..0b63089
--- /dev/null
+++ b/app-emulation/xen/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/xen
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 24 Feb 2009; Alexey Shvetsov <alexxy@gentoo.org> xen-9999.ebuild:
+ fix deps
+
+*xen-9999 (24 Feb 2009)
+
+ 24 Feb 2009; Alexey Shvetsov <alexxy@gentoo.org> +metadata.xml,
+ +xen-9999.ebuild:
+ Add xen-9999
+
diff --git a/app-emulation/xen/metadata.xml b/app-emulation/xen/metadata.xml
new file mode 100644
index 0000000..8f9af95
--- /dev/null
+++ b/app-emulation/xen/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>xen</herd>
+<use>
+ <flag name='custom-cflags'>Use CFLAGS from /etc/make.conf rather than the
+ default Xen CFLAGS (not supported)</flag>
+ <flag name='pae'>Enable support for PAE kernels (usually x86-32 with >4GB
+ memory)</flag>
+ <flag name='xsm'>Enable the Xen Security Modules (XSM)</flag>
+ <flag name='acm'>Enable the ACM/sHype XSM module from IBM</flag>
+ <flag name='flask'>Enable the Flask XSM module from NSA</flag>
+</use>
+</pkgmetadata>
diff --git a/app-emulation/xen/xen-9999.ebuild b/app-emulation/xen/xen-9999.ebuild
new file mode 100644
index 0000000..b0e8ac9
--- /dev/null
+++ b/app-emulation/xen/xen-9999.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.3.0.ebuild,v 1.1 2008/09/01 00:30:53 rbu Exp $
+
+inherit mount-boot flag-o-matic toolchain-funcs mercurial
+
+DESCRIPTION="The Xen virtual machine monitor"
+HOMEPAGE="http://xen.org/"
+REPO="xen-unstable.hg"
+EHG_REPO_URI="http://xenbits.xensource.com/${REPO}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug custom-cflags pae acm flask xsm"
+
+RDEPEND="|| ( sys-boot/grub
+ sys-boot/grub-static )
+ >=sys-kernel/xen-sources-2.6.${PV}"
+PDEPEND="~app-emulation/xen-tools-${PV}"
+
+RESTRICT="test"
+
+# Approved by QA team in bug #144032
+QA_WX_LOAD="boot/xen-syms-${PV}"
+
+S="${WORKDIR}/${REPO}"
+
+pkg_setup() {
+ if [[ -z ${XEN_TARGET_ARCH} ]]; then
+ if use x86 && use amd64; then
+ die "Confusion! Both x86 and amd64 are set in your use flags!"
+ elif use x86; then
+ export XEN_TARGET_ARCH="x86_32"
+ elif use amd64; then
+ export XEN_TARGET_ARCH="x86_64"
+ else
+ die "Unsupported architecture!"
+ fi
+ fi
+
+ if use xsm ; then
+ export "XSM_ENABLE=y"
+ use acm && export "ACM_SECURITY=y"
+ if use flask ; then
+ ! use acm && export "FLASK_ENABLE=y"
+ use acm && ewarn "Both acm and flask XSM specified, defaulting to acm."
+ fi
+ elif use acm || use flask ; then
+ ewarn "acm and flask require USE=xsm to be set, dropping use flags"
+ fi
+}
+
+src_unpack() {
+ mercurial_src_unpack
+
+ # if the user *really* wants to use their own custom-cflags, let them
+ if use custom-cflags; then
+ einfo "User wants their own CFLAGS - removing defaults"
+ # try and remove all the default custom-cflags
+ find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
+ -i {} \;
+ fi
+}
+
+src_compile() {
+ local myopt
+ use debug && myopt="${myopt} debug=y"
+ use pae && myopt="${myopt} pae=y"
+
+ if use custom-cflags; then
+ filter-flags -fPIE -fstack-protector
+ replace-flags -O3 -O2
+ else
+ unset CFLAGS
+ fi
+
+ # Send raw LDFLAGS so that --as-needed works
+ emake CC="$(tc-getCC)" LDFLAGS="$(raw-ldflags)" -C xen ${myopt} || die "compile failed"
+}
+
+src_install() {
+ local myopt
+ use debug && myopt="${myopt} debug=y"
+ use pae && myopt="${myopt} pae=y"
+
+ emake LDFLAGS="$(raw-ldflags)" DESTDIR="${D}" -C xen ${myopt} install || die "install failed"
+}
+
+pkg_postinst() {
+ elog "Official Xen Guide and the unoffical wiki page:"
+ elog " http://www.gentoo.org/doc/en/xen-guide.xml"
+ elog " http://gentoo-wiki.com/HOWTO_Xen_and_Gentoo"
+
+ if use pae; then
+ echo
+ ewarn "This is a PAE build of Xen. It will *only* boot PAE kernels!"
+ fi
+}