aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Neumärker <xdch47@posteo.de>2020-02-19 17:44:18 +0100
committerVadim Misbakh-Soloviov <mva@gentoo.org>2020-02-20 01:50:56 +0700
commit8a1dcc8e862e1ca00fec39f921bcd2d9cf55c0e7 (patch)
tree7dda7a7437ae4a58e389e11fdb003612f48aa2ba /src/_ekeyword
parentUpdate portage-utils completion (diff)
downloadzsh-completion-8a1dcc8e862e1ca00fec39f921bcd2d9cf55c0e7.tar.gz
zsh-completion-8a1dcc8e862e1ca00fec39f921bcd2d9cf55c0e7.tar.bz2
zsh-completion-8a1dcc8e862e1ca00fec39f921bcd2d9cf55c0e7.zip
Merge PR #22 (eselect fixes)
[PATCH 1/6] _eselect: php-module completion [PATCH 2/6] _eselect: generic uses _describe instead of values [PATCH 3/6] _ekeyword: inital completion [PATCH 4/6] _eselect: news modules - fix order [PATCH 5/6] _eselect: completion for rc module / rc-config [PATCH 6/6] _eselect: repository fixes + options Signed-off-by: Felix Neumärker <xdch47@posteo.de> Signed-off-by: Vadim Misbakh-Soloviov <mva@gentoo.org>
Diffstat (limited to 'src/_ekeyword')
-rw-r--r--src/_ekeyword23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/_ekeyword b/src/_ekeyword
new file mode 100644
index 0000000..c86ebb0
--- /dev/null
+++ b/src/_ekeyword
@@ -0,0 +1,23 @@
+#compdef ekeyword
+
+local -a arguments=(
+ '(- :)'{-h,--help}'[Show this help message and exit]'
+ '(-m --manifest)'{-m,--manifest}'[Run `ebuild manifest` on the ebuild after modifying it]'
+ '(-n --dry-run)'{-n,--dry-run}'[Show what would be changed, but do not commit]'
+ '(-v --verbose)'{-v,--verbose}'[Be verbose while processing things]'
+ '(-q --quiet)'{-q,--quiet}'[Be quiet while processing things (only show errors)]'
+ '(--format)'--format':Select output format for showing differences:_values -V ekeywordsfmt "ekeywords formats" auto color-inline inline short-multi long-multi'
+ '(- :)'{-V,--version}'[Show version information]'
+)
+
+(( $+functions[_ekeywordargs] )) || _ekeywordargs() {
+ _files -g \*.ebuild
+
+ local -a keywords=(all $(_gentoo_arches))
+
+ compset -P '(\^|\~)'
+ _values -V "keywords" "gentoo arches" ${keywords[@]}
+}
+
+_arguments ${arguments[@]} "*:ekeywordargs:_ekeywordargs"
+