summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2020-10-22 16:39:42 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2020-10-22 16:39:42 +0000
commit8ced78a90131da8d64bb73ea42acdec4dd571daf (patch)
tree907e27094be5768722b5655cbc91249f79a3ed33
parentdev-db/phpmyadmin: Security bump (4.9.6, 5.0.3). (diff)
downloadjmbsvicetto-8ced78a90131da8d64bb73ea42acdec4dd571daf.tar.gz
jmbsvicetto-8ced78a90131da8d64bb73ea42acdec4dd571daf.tar.bz2
jmbsvicetto-8ced78a90131da8d64bb73ea42acdec4dd571daf.zip
www-apps/glpi: 9.5.2 version bump.
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
-rw-r--r--www-apps/glpi/Manifest1
-rw-r--r--www-apps/glpi/glpi-9.5.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/www-apps/glpi/Manifest b/www-apps/glpi/Manifest
index da4a309..3bea070 100644
--- a/www-apps/glpi/Manifest
+++ b/www-apps/glpi/Manifest
@@ -1 +1,2 @@
DIST glpi-9.4.5.tgz 35073134 BLAKE2B 700cd2ad3a803254ec5dded8d91a93f729c89a9f575bcc72480e4eedd35abba6e057708ca14858fcdbb1ce55e543f0fb27d1e1e73cd0dcbbbf78c87f75a2babe SHA512 3fb8289047967193abaaee824ae42d6bb4127f46ab3de09a57fca5ca1c07543dcfa3861df0549444c789fd10a6793fa549b2d85a3c425cc79ba986826f5cd579
+DIST glpi-9.5.2.tgz 43543672 BLAKE2B 7485140c8364ba2cf8b929da1e656204f47a180e7cf006af5318bb1b0d007aff0fcbe7869aad43741814e6a1d36e3e755707107b2f811e97cf37391e0e46e0cf SHA512 163c4b25c21f37e91f7a863b2a079093433f01f6a7dd2c4047c9db49db1b8070d8bb12f9803c86538c4b62d65ed2e0058727522a194ac750cb1d77d0a71304e8
diff --git a/www-apps/glpi/glpi-9.5.2.ebuild b/www-apps/glpi/glpi-9.5.2.ebuild
new file mode 100644
index 0000000..8b3c88c
--- /dev/null
+++ b/www-apps/glpi/glpi-9.5.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_PN="glpi-project"
+MY_P=${P/_/-}
+MY_PV=${PV/_/-}
+
+DESCRIPTION="The Information Resource-Manager with an additional Administration Interface."
+HOMEPAGE="http://www.glpi-project.org/"
+SRC_URI="https://github.com/${MY_PN}/${PN}/releases/download/${MY_PV}/${MY_P}.tgz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ app-admin/webapp-config
+"
+RDEPEND="
+ dev-lang/php[curl,json,mysqli,session,unicode]
+ virtual/mysql
+"
+S="${WORKDIR}/${PN}"
+
+pkg_config () {
+
+ webapp_pkg_setup
+}
+
+src_install () {
+
+ webapp_src_preinst
+
+ einfo "Installing files"
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Protect config files
+ webapp_configfile "${MY_HTDOCSDIR}/".htaccess
+
+ # Allow writing to the config and files directories
+ for dir in config files .htaccess ; do
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}/${dir}"
+ done
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}