summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2021-08-12 19:59:22 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2021-08-12 19:59:22 +0000
commita979cf9a3c6fa83012b8e522dfb1b9a5993a2867 (patch)
treed811f0429a073e7de8848d7f0a0b35958b14ae86
parentwww-apps/drupal: Security bump - SA-CORE-2021-005. (diff)
downloadjmbsvicetto-a979cf9a3c6fa83012b8e522dfb1b9a5993a2867.tar.gz
jmbsvicetto-a979cf9a3c6fa83012b8e522dfb1b9a5993a2867.tar.bz2
jmbsvicetto-a979cf9a3c6fa83012b8e522dfb1b9a5993a2867.zip
www-apps/drupal: Bump EAPI.
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
-rw-r--r--www-apps/drupal/drupal-7.82-r1.ebuild58
-rw-r--r--www-apps/drupal/drupal-8.9.18.ebuild2
-rw-r--r--www-apps/drupal/drupal-9.1.12.ebuild2
-rw-r--r--www-apps/drupal/drupal-9.2.4.ebuild2
4 files changed, 61 insertions, 3 deletions
diff --git a/www-apps/drupal/drupal-7.82-r1.ebuild b/www-apps/drupal/drupal-7.82-r1.ebuild
new file mode 100644
index 0000000..fab5db9
--- /dev/null
+++ b/www-apps/drupal/drupal-7.82-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt INSTALL.sqlite.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+}
diff --git a/www-apps/drupal/drupal-8.9.18.ebuild b/www-apps/drupal/drupal-8.9.18.ebuild
index 1fa351c..421034d 100644
--- a/www-apps/drupal/drupal-8.9.18.ebuild
+++ b/www-apps/drupal/drupal-8.9.18.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit webapp
diff --git a/www-apps/drupal/drupal-9.1.12.ebuild b/www-apps/drupal/drupal-9.1.12.ebuild
index 1fa351c..421034d 100644
--- a/www-apps/drupal/drupal-9.1.12.ebuild
+++ b/www-apps/drupal/drupal-9.1.12.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit webapp
diff --git a/www-apps/drupal/drupal-9.2.4.ebuild b/www-apps/drupal/drupal-9.2.4.ebuild
index 23610d1..2830cbc 100644
--- a/www-apps/drupal/drupal-9.2.4.ebuild
+++ b/www-apps/drupal/drupal-9.2.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit webapp